Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official CuBox-i XBian 1.0 Beta 2 thread
9th Feb, 2014, 12:54 AM
Post: #1
Official CuBox-i XBian 1.0 Beta 2 thread
This thread is ONLY for Xbian issues resulting from the CuBox-i image of Xbian. (NB: Not for the original Cubox)

Do not post anything here that is related to the Raspberry Pi. Use this thread instead.

Download the latest CuBox-i image Here or use Xbian-Installer Windoze or OSX or Linux 64 only

*** NOTE *** This is still in the development stage. Please report any issues to this thread.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
9th Feb, 2014, 09:48 AM
Post: #2
RE: Official CuBox-i XBian 1.0 Beta 2 thread
I am using xbian on Cubox-i 4pro. I've tested android, ubuntu, geexbox and OpenELEC, and currently think that xbian is the most useful xbmc distribution with the best user experience.

Since the update also Airplay is working, even though it's buggy, which I think has nothing to do with cubox or xbian. The bug is that videos from iphone are not played back correctly via Airplay and sometimes you have to rename the system name and reboot so the idevices recognizes xbian xbmc as airplay receiver. I had the same issue with Rpi and OpenELEC since iOS 7.2. So I think this is more related to iOS 7.2 together with the current xbmc release on any platform.

Xbian config is not working over the menu (restarts xbmc). But still possible via ssh.

Anything else is working fine for me, especially
- Airplay (not perfect, but pictures can be streamed, videos sometimes as well)
- HD Movies, 1080p, smooth
- AVCHD / mts -> no issues at all
- advancedsettings.xml can be configured to use mysql database to store movie information

I've tested network throughput with iperf and got about 400 Mbit/s in a gigabit LAN environment.

And thats pretty much.
I can definetly recommend xbian on cubox-i 4pro.
Find all posts by this user
Quote this message in a reply
9th Feb, 2014, 10:43 AM
Post: #3
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Same here, with Cubox-i4. I have to add that CEC works great when it works! The link between the Tv and XBMC is not easy to have and is lost very easyly, but maybe a problem with the TV or XBMC.

I want to add that I installed Transmission, works great.

I also installed BittorrentSync to be able to sync some of my folder accross the house. Seems to work great! I followed the instruction word for word for the NOT ubuntu installation described here:
http://forum.bittorrent.com/topic/18974-debian-and-ubuntu-server-unofficial-packages-for-bittorrent-sync/
Find all posts by this user
Quote this message in a reply
10th Feb, 2014, 01:03 AM
Post: #4
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Hello!
Seems that "lirc" is not loaded. Is there any specific way for installing it? I would like to hook my remote to Xbmc...
Ok I find the post for remote conf: http://forum.xbian.org/thread-1852.html
The Cubox-i4 receive my remote command, I have to configure it, I'll keep people in touch.

Some of my file don't play well on Xbmc (they play well within Xbmc on my Mac)... Some Avi file and some Mkv file do not show image, just sound, or sometimes nothing....
Find all posts by this user
Quote this message in a reply
10th Feb, 2014, 05:17 AM
Post: #5
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Hi,

i've fixed xbian-config-xbmc for gotham, but can't test on Cubox,
if you want to try before MK01 make the package,
@mk01 can i've a write acces on devel repo, at least for xbian-config, i could upload package myself.

sudo apt-get install fakeroot
git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
cd xbian-package-config-xbmc
./gen.package.sh
sudo dpkg -i xbian-package-config-xbmc.deb

Hope it will work too on cubox.

Belese

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
11th Feb, 2014, 11:17 AM
Post: #6
RE: Official CuBox-i XBian 1.0 Beta 2 thread
(10th Feb, 2014 05:17 AM)belese Wrote:  Hi,

i've fixed xbian-config-xbmc for gotham, but can't test on Cubox,
if you want to try before MK01 make the package,
@mk01 can i've a write acces on devel repo, at least for xbian-config, i could upload package myself.

sudo apt-get install fakeroot
git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
cd xbian-package-config-xbmc
./gen.package.sh
sudo dpkg -i xbian-package-config-xbmc.deb

Hope it will work too on cubox.

Belese

Unfortunately, this doesn't work on the Cubox-I4Q. Here's the run down of what I did to try to achieve this.

Terminal
xbian@xbian-cubox ~ $ sudo apt-get install fakeroot
[sudo] password for xbian:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
fakeroot
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 99.7 kB of archives.
After this operation, 291 kB of additional disk space will be used.
Get:1 http://ftp.sk.debian.org/debian/ jessie/main fakeroot armhf 1.18.4-2 [99.7 kB]
Fetched 99.7 kB in 1s (97.2 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Selecting previously unselected package fakeroot.
(Reading database ... 25468 files and directories currently installed.)
Preparing to unpack .../fakeroot_1.18.4-2_armhf.deb ...
Unpacking fakeroot (1.18.4-2) ...
Setting up fakeroot (1.18.4-2) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode
xbian@xbian-cubox ~ $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
-bash: git: command not found
xbian@xbian-cubox ~ $ whereis git
git:
xbian@xbian-cubox ~ $ sudo apt-get install git-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
git git-man liberror-perl
Suggested packages:
git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
gitweb git-arch git-bzr git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
git git-core git-man liberror-perl
0 upgraded, 4 newly installed, 0 to remove and 23 not upgraded.
Need to get 3,772 kB of archives.
After this operation, 14.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.sk.debian.org/debian/ jessie/main liberror-perl all 0.17-1.1 [22.4 kB]
Get:2 http://ftp.sk.debian.org/debian/ jessie/main git-man all 1:1.8.5.3-1 [1,228 kB]
Get:3 http://ftp.sk.debian.org/debian/ jessie/main git armhf 1:1.8.5.3-1 [2,520 kB]
Get:4 http://ftp.sk.debian.org/debian/ jessie/main git-core all 1:1.8.5.3-1 [1,496 B]
Fetched 3,772 kB in 9s (419 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Selecting previously unselected package liberror-perl.
(Reading database ... 25507 files and directories currently installed.)
Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
Unpacking liberror-perl (0.17-1.1) ...
Selecting previously unselected package git-man.
Preparing to unpack .../git-man_1%3a1.8.5.3-1_all.deb ...
Unpacking git-man (1:1.8.5.3-1) ...
Selecting previously unselected package git.
Preparing to unpack .../git_1%3a1.8.5.3-1_armhf.deb ...
Unpacking git (1:1.8.5.3-1) ...
Selecting previously unselected package git-core.
Preparing to unpack .../git-core_1%3a1.8.5.3-1_all.deb ...
Unpacking git-core (1:1.8.5.3-1) ...
Setting up liberror-perl (0.17-1.1) ...
Setting up git-man (1:1.8.5.3-1) ...
Setting up git (1:1.8.5.3-1) ...
Setting up git-core (1:1.8.5.3-1) ...
xbian@xbian-cubox ~ $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
Cloning into 'xbian-package-config-xbmc'...
fatal: unable to access 'https://github.com/xbianonpi/xbian-package-config-xbmc.git/': Problem with the SSL CA cert (path? access rights?)
xbian@xbian-cubox ~ $ git push https://github.com/xbianonpi/xbian-package-config-xbmc.git

fatal: Not a git repository (or any of the parent directories): .git
xbian@xbian-cubox ~ $ sudo apt-get install ca-certificates
[sudo] password for xbian:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
openssl
The following NEW packages will be installed:
ca-certificates openssl
0 upgraded, 2 newly installed, 0 to remove and 23 not upgraded.
Need to get 848 kB of archives.
After this operation, 1,326 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.sk.debian.org/debian/ jessie/main openssl armhf 1.0.1f-1 [663 kB]
Get:2 http://ftp.sk.debian.org/debian/ jessie/main ca-certificates all 20130906 [185 kB]
Fetched 848 kB in 21s (38.8 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Preconfiguring packages ...
Selecting previously unselected package openssl.
(Reading database ... 26276 files and directories currently installed.)
Preparing to unpack .../openssl_1.0.1f-1_armhf.deb ...
Unpacking openssl (1.0.1f-1) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../ca-certificates_20130906_all.deb ...
Unpacking ca-certificates (20130906) ...
Setting up openssl (1.0.1f-1) ...
Setting up ca-certificates (20130906) ...
Processing triggers for ca-certificates (20130906) ...
Updating certificates in /etc/ssl/certs... 164 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....done.
xbian@xbian-cubox ~ $ git config --global http.sslVerify true
xbian@xbian-cubox ~ $ cd ~/
xbian@xbian-cubox ~ $ ls .git* -l
-rw-r--r-- 1 xbian xbian 25 Feb 10 18:10 .gitconfig
xbian@xbian-cubox ~ $ nano .gitconfig
xbian@xbian-cubox ~ $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
Cloning into 'xbian-package-config-xbmc'...
remote: Reusing existing pack: 2087, done.
remote: Total 2087 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (2087/2087), 775.92 KiB | 32.00 KiB/s, done.
Resolving deltas: 100% (847/847), done.
Checking connectivity... done.
xbian@xbian-cubox ~ $ cd xbian-package-config-xbmc
xbian@xbian-cubox ~/xbian-package-config-xbmc $ ./gen.package.sh
please install binutils-arm-linux-gnueabihf
dpkg-deb: building package `xbian-package-config-xbmc' in `xbian-package-config-xbmc1.1.4-6.deb'.
xbian@xbian-cubox ~/xbian-package-config-xbmc $ sudo apt-get install binutils-arm-linux-gnueabihf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package binutils-arm-linux-gnueabihf

since the package is unavail I'm unable to build ... :\ My knowledge isn't as advanced, nor do I know where to get the package currently.
Find all posts by this user
Quote this message in a reply
12th Feb, 2014, 04:40 PM
Post: #7
RE: Official CuBox-i XBian 1.0 Beta 2 thread
It actually worked for me fine on my i4-pro.

Terminal
xbian@thinny ~ $ sudo apt-get update
[sudo] password for xbian:
Get:1 http://ftp.sk.debian.org jessie InRelease [153 kB]
Hit http://xbian.brantje.com stable InRelease
Hit http://xbian.brantje.com staging InRelease
Hit http://xbian.brantje.com devel InRelease
Hit http://xbian.brantje.com stable/main armhf Packages
Hit http://xbian.brantje.com staging/main armhf Packages
Get:2 http://ftp.sk.debian.org jessie/main armhf Packages [8,161 kB]
Hit http://xbian.brantje.com devel/main armhf Packages
Ign http://xbian.brantje.com stable/main Translation-en_US
Ign http://xbian.brantje.com stable/main Translation-en
Ign http://xbian.brantje.com staging/main Translation-en_US
Ign http://xbian.brantje.com staging/main Translation-en
Ign http://xbian.brantje.com devel/main Translation-en_US
Ign http://xbian.brantje.com devel/main Translation-en
Get:3 http://ftp.sk.debian.org jessie/main Translation-en [4,261 kB]
Fetched 12.6 MB in 29s (420 kB/s)
Reading package lists... Done
xbian@thinny ~ $ sudo apt-get install fakeroot
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
inetutils-ping
Use 'apt-get autoremove' to remove it.
The following NEW packages will be installed:
fakeroot
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 99.7 kB of archives.
After this operation, 291 kB of additional disk space will be used.
Get:1 http://ftp.sk.debian.org/debian/ jessie/main fakeroot armhf 1.18.4-2 [99.7 kB]
Fetched 99.7 kB in 1s (84.1 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Selecting previously unselected package fakeroot.
(Reading database ... 25484 files and directories currently installed.)
Preparing to unpack .../fakeroot_1.18.4-2_armhf.deb ...
Unpacking fakeroot (1.18.4-2) ...
Setting up fakeroot (1.18.4-2) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode
xbian@thinny ~ $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
-bash: git: command not found
xbian@thinny ~ $ sudo apt-get install git
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
inetutils-ping
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
git-man liberror-perl
Suggested packages:
git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
gitweb git-arch git-bzr git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,770 kB of archives.
After this operation, 14.7 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ftp.sk.debian.org/debian/ jessie/main liberror-perl all 0.17-1.1 [22.4 kB]
Get:2 http://ftp.sk.debian.org/debian/ jessie/main git-man all 1:1.8.5.3-1 [1,228 kB]
Get:3 http://ftp.sk.debian.org/debian/ jessie/main git armhf 1:1.8.5.3-1 [2,520 kB]
Fetched 3,770 kB in 7s (493 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Selecting previously unselected package liberror-perl.
(Reading database ... 25523 files and directories currently installed.)
Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
Unpacking liberror-perl (0.17-1.1) ...
Selecting previously unselected package git-man.
Preparing to unpack .../git-man_1%3a1.8.5.3-1_all.deb ...
Unpacking git-man (1:1.8.5.3-1) ...
Selecting previously unselected package git.
Preparing to unpack .../git_1%3a1.8.5.3-1_armhf.deb ...
Unpacking git (1:1.8.5.3-1) ...
Setting up liberror-perl (0.17-1.1) ...
Setting up git-man (1:1.8.5.3-1) ...
Setting up git (1:1.8.5.3-1) ...
xbian@thinny ~ $ ls
run_on_reboot xbian-config-update.log
xbian@thinny ~ $ mkdir cuboxi
xbian@thinny ~ $ cd cuboxi
xbian@thinny ~/cuboxi $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
Cloning into 'xbian-package-config-xbmc'...
fatal: unable to access 'https://github.com/xbianonpi/xbian-package-config-xbmc.git/': Problem with the SSL CA cert (path? access rights?)
xbian@thinny ~/cuboxi $ sudo apt-get install ca-certificates
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
inetutils-ping
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
openssl
The following NEW packages will be installed:
ca-certificates openssl
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 848 kB of archives.
After this operation, 1,326 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ftp.sk.debian.org/debian/ jessie/main openssl armhf 1.0.1f-1 [663 kB]
Get:2 http://ftp.sk.debian.org/debian/ jessie/main ca-certificates all 20130906 [185 kB]
Fetched 848 kB in 2s (316 kB/s)
Filesystem is not of type btrfs. Not taking any actions.
Preconfiguring packages ...
Selecting previously unselected package openssl.
(Reading database ... 26291 files and directories currently installed.)
Preparing to unpack .../openssl_1.0.1f-1_armhf.deb ...
Unpacking openssl (1.0.1f-1) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../ca-certificates_20130906_all.deb ...
Unpacking ca-certificates (20130906) ...
Setting up openssl (1.0.1f-1) ...
Setting up ca-certificates (20130906) ...
Processing triggers for ca-certificates (20130906) ...
Updating certificates in /etc/ssl/certs... 164 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....done.
xbian@thinny ~/cuboxi $ git config --global http.sslVerify true
xbian@thinny ~/cuboxi $ git clone https://github.com/xbianonpi/xbian-package-config-xbmc.git
Cloning into 'xbian-package-config-xbmc'...
remote: Reusing existing pack: 2087, done.
remote: Total 2087 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (2087/2087), 775.92 KiB | 477.00 KiB/s, done.
Resolving deltas: 100% (847/847), done.
Checking connectivity... done.
xbian@thinny ~/cuboxi $ cd xbian-package-config-xbmc/
xbian@thinny ~/cuboxi/xbian-package-config-xbmc $ ./gen.package.sh
please install binutils-arm-linux-gnueabihf
dpkg-deb: building package `xbian-package-config-xbmc' in `xbian-package-config-xbmc1.1.4-6.deb'.
xbian@thinny ~/cuboxi/xbian-package-config-xbmc $ sudo dpkg -i xbian-package-config-xbmc1.1.4-6.deb
(Reading database ... 26577 files and directories currently installed.)
Preparing to unpack xbian-package-config-xbmc1.1.4-6.deb ...
Unpacking xbian-package-config-xbmc (1.1.4-6) over (1.1.4-6) ...
Setting up xbian-package-config-xbmc (1.1.4-6) ...
xbian@thinny ~/cuboxi/xbian-package-config-xbmc $

Maybe just ignore the binutils-arm-linux-gnueabihf message. It still seems to build correctly, as I ran dpkg and now my xbian config works from within xbmc without crashing.

Thanks @belese
Find all posts by this user
Quote this message in a reply
13th Feb, 2014, 01:20 AM
Post: #8
RE: Official CuBox-i XBian 1.0 Beta 2 thread
@stolidity
glad to hear it work for you!
@Whitepyro
i've no cubox, and i'm not the autor of generate package script. maybe it miss some dependencies,
if it don't work for you, wait for package online, it should'nt be long.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
13th Feb, 2014, 10:17 AM
Post: #9
RE: Official CuBox-i XBian 1.0 Beta 2 thread
(13th Feb, 2014 01:20 AM)belese Wrote:  @stolidity
glad to hear it work for you!
@Whitepyro
i've no cubox, and i'm not the autor of generate package script. maybe it miss some dependencies,
if it don't work for you, wait for package online, it should'nt be long.

I can confirm by ignoring the prereq that it does fix the issue..

@stolidity Thanks for the tip Smile

Just don't update or it will destroy the work done.. Just did and now I need to redo it :\
Find all posts by this user
Quote this message in a reply
14th Feb, 2014, 02:04 AM
Post: #10
RE: Official XBian 1.0 RC 1 thread
Is there a way to install NetaTalk? I saw that libafpclient0 is installed but can't find netatalk and when I do apt-get install netatalk, it can't find the package...
I would like to access my external drive plugged on the cubox from my mac.
If it not possible with netatalk, I'll use samba.Undecided
Find all posts by this user
Quote this message in a reply
16th Feb, 2014, 11:56 PM
Post: #11
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Hey guys!

Great operation system, I think I'm gonna love after I fix issues!

So, I've installed the Xbian for Cubox via:

wget http://xbian.brantje.com/images/xbian-cubox.1.img.gz
gunzip xbian-cubox.1.img.gz
dd if=./xbian-cubox.1.img of=/dev/XXXXXX bs=1m

However, when I start the fresh install, the system doesn't allow me to ssh:

ssh xbian@192.168.1.12
Read from socket failed: Connection reset by peer

Can somebody point what am I doing wrong or how to fix that?

Thank you
Find all posts by this user
Quote this message in a reply
17th Feb, 2014, 12:08 AM
Post: #12
RE: Official CuBox-i XBian 1.0 Beta 2 thread
You have to activate ssh login via xbian-config first... Smile

(16th Feb, 2014 11:56 PM)vlamic Wrote:  Hey guys!

Great operation system, I think I'm gonna love after I fix issues!

So, I've installed the Xbian for Cubox via:

wget http://xbian.brantje.com/images/xbian-cubox.1.img.gz
gunzip xbian-cubox.1.img.gz
dd if=./xbian-cubox.1.img of=/dev/XXXXXX bs=1m

However, when I start the fresh install, the system doesn't allow me to ssh:

ssh xbian@192.168.1.12
Read from socket failed: Connection reset by peer

Can somebody point what am I doing wrong or how to fix that?

Thank you
Find all posts by this user
Quote this message in a reply
17th Feb, 2014, 08:31 PM
Post: #13
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Was rebooting when tried to access the config. But it works now. Had to reboot the system instead of continuing with the "welcome wizard".
Find all posts by this user
Quote this message in a reply
18th Feb, 2014, 02:03 AM
Post: #14
RE: Official CuBox-i XBian 1.0 Beta 2 thread
on first start XBian is regenerating rsa & ecsa private / public pairs to be uniq on each installation. this can take 1-2 minutes alone. the actual "problem" is that ssh is waiting for sufficiently random data from random interface. and this is not the case of clean early boot. so at the end it can take up to 5-10 minuted.

but then SSH should start.

(14th Feb, 2014 02:04 AM)dantahoua Wrote:  Is there a way to install NetaTalk? I saw that libafpclient0 is installed but can't find netatalk and when I do apt-get install netatalk, it can't find the package...
I would like to access my external drive plugged on the cubox from my mac.
If it not possible with netatalk, I'll use samba.Undecided

Debian is not providing ANY afp support in Jessie (at least at present time).

I downloaded from Sid and installed manually to image. So I suppose Netatalk will be in Sid as well.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
20th Feb, 2014, 05:33 PM
Post: #15
RE: Official CuBox-i XBian 1.0 Beta 2 thread
Hi,

I ran xbian on a PI since the first release of the 1.0 beta2. It works like a charm. Thank you for the greate work.

In Oktober 2013 i order a Cubox-i 2 (get it in the middle of January) and now I finde some time to install xbian on it.
I'm glade to find out that the xbian team is willing to support the Cubox-I.

I installed the image last night and had no problems to get a picture on my TV. (CEC don't work, but I have a Logitech K400)

When I try to
Terminal
apt-get update && apt-get upgrade
, the initscripts was unable to upgrade. (see also in the cubox forum)

Setting this package to hold
Terminal
echo initscripts hold |dpkg --set-selections
resolves this problem.

The next problem was, when I try to make a
Terminal
apt-get dist-upgrade
.

Apt-get dist-upgrade wants to install the package xbian-package-firmware from stable, but this overwrites the package xbian-package-firmware-6q 1.5.0-2 from dev.

I had to comment the stable repository in the xbian.list out to get apt-get dist-upgrade running.

Will there be the backupscript (with brtfs) in the next images?

Thank you again for the great work.

Going on testing and help to report problems to make xbian better.

mfG Matthias
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Official CuBox-i XBian 1.0 RC3 Thread IriDium 94 101,776 21st Jun, 2015 05:59 AM
Last Post: zilexa

Forum Jump: