Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: Poor writing performance with new 2TB drive
18th Jun, 2014, 07:26 PM
Post: #1
Poor writing performance with new 2TB drive
Hello everybody.

I used to run pyLoad on my Pi in combination with a 1TB external drive. I recently switched to a 2Tb drive (Toshiba Stor.E Plus) and noticed some strange behaviour in pyload:
Every since I changed the download location to the new external drive (one partition only, NTFS) pyload will only reach 100kb/s maximum. Changing it back to the old external drive, the issue is gone.
Any suggestions what could cause the poor writing performance. On my Windows PC the drive has excellent writing speed.

Best regards and thanks in advance!

//Edit:
Terminal

sudo dd if=/dev/zero of=/dev/sda1 bs=1M count=1 oflag=direct
1+0 Datensätze ein
1+0 Datensätze aus
1048576 Bytes (1,0 MB) kopiert, 0,120445 s, 8,7 MB/s

Terminal

sudo dd if=/dev/zero of=/dev/sda1 bs=100M count=1 oflag=direct
1+0 Datensätze ein
1+0 Datensätze aus
104857600 Bytes (105 MB) kopiert, 6,56833 s, 16,0 MB/s
Looks like the problem is related to pyload, right? As far as I understand it, the writing performance is much better than the <100ks/s pyload reaches.
If you agree, could someone please move the topic to the Software Forum?
Find all posts by this user
Quote this message in a reply
22nd Jun, 2014, 08:35 AM
Post: #2
RE: Poor writing performance with new 2TB drive
with that command you are testing RAW device performance . on RPI this is way too far from real FS performance.


NTFS is known to be a bit slower but 100 kbps looks like you have "sync" mount option on. it is default for external HDD;s.

it can be set to off from XBMC-XBIAN config menu (program)

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
22nd Jun, 2014, 07:43 PM
Post: #3
RE: Poor writing performance with new 2TB drive
(22nd Jun, 2014 08:35 AM)mk01 Wrote:  with that command you are testing RAW device performance . on RPI this is way too far from real FS performance.


NTFS is known to be a bit slower but 100 kbps looks like you have "sync" mount option on. it is default for external HDD;s.

it can be set to off from XBMC-XBIAN config menu (program)

Thanks. That was the solution to my problem.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: