Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: Read only ext3 HDD with smb access
19th Oct, 2014, 01:59 AM
Post: #1
Read only ext3 HDD with smb access
Hello everyone,

I finally post this bug after having read all (?) other topics concerning my problem without managing to solve it:
Xbian automounts my external HDD formated in ext3. Using xbmc I can read/write to it without any issue. By connecting to my raspberry with ssh, i can also rw to the disk without issue.
Problem comes when I try to write to the disk using my Win PC on the same network.

I already went to usbmout.conf and allows SHARESMB, SHARERW and SHARELT. I also went to xbmc and tried to allow "write for outside world" or something like that. Unfortunately this option wont stay active, i don't know why...
I also reinstall to xbian-package-samba...

Nothing works, and I am quite annoyed because transmission is downloading my torrents very well, but I have to launch ssh to copy them to the right folder, which is not quite handy.

PS: I have Xbian RC3, updated last week (for some strange reason i cannot update anymore)

Best regards and thanks in advance!
Find all posts by this user
Quote this message in a reply
27th May, 2016, 01:52 PM
Post: #2
Only Read Access to External USB Drives
Hello,
I just finish a second clean install of Xbian on my Cubox and when accessing the external drives I get only read access. I set Xbian to expert mode and select options from menu to make disks writable, but there is no way. The drives are always read only. They are both EXT3 formatted.
I try editing Samba Conf and the options SHARESMB and SHARERW are both set to "yes".
Please help. I´m newbie in linux so please give me detailed instructions.
Thanks,
Gastón
Find all posts by this user
Quote this message in a reply
27th May, 2016, 01:56 PM
Post: #3
RE: Read only ext3 HDD with smb access
Hi, had you solved this? I´m having the same issue with no solution! Thanks
Find all posts by this user
Quote this message in a reply
27th May, 2016, 10:47 PM
Post: #4
RE: Read only ext3 HDD with smb access
@GastonBA

Just tested. Having full access to my ext4 formatted external disk.

Terminal

xbian@kmxbilr2 /media $ ls -la /media
insgesamt 8
drwxr-xr-x 1 root root 22 Mai 27 14:34 .
drwxr-xr-x 1 root root 176 Mai 21 02:20 ..
lrwxrwxrwx 1 root root 14 Mai 27 14:34 usb0 -> /media/usb500g
drwxrwxrwx 6 root root 4096 Mai 27 14:36 usb500g
xbian@kmxbilr2 /media $ cd usb500g/
xbian@kmxbilr2 /media/usb500g $ mkdir x
xbian@kmxbilr2 /media/usb500g $ cd x
xbian@kmxbilr2 /media/usb500g/x $ touch y
xbian@kmxbilr2 /media/usb500g/x $ ls -la
insgesamt 8
drwxr-xr-x 2 xbian xbian 4096 Mai 27 14:40 .
drwxrwxrwx 7 root root 4096 Mai 27 14:39 ..
-rw-r--r-- 1 xbian xbian 0 Mai 27 14:40 y
xbian@kmxbilr2 /media/usb500g/x $

This is my /etc/usbmount/usbmount.conf

Code:
# Configuration file for the usbmount package, which mounts removable
# storage devices when they are plugged in and unmounts them when they
# are removed.

# Change to zero to disable usbmount
ENABLED=1

# start UDisks daemon?
STARTUDISKS=0

# Filesystem types: removable storage devices are only mounted if they
# contain a filesystem type which is in this list.
FILESYSTEMS="btrfs ntfs vfat ext2 ext3 ext4 hfsplus exfat msdos iso9660 xfs jfs"

# Directory where static name mountpoints (consisting of LABEL and UUID) will be created
MNTPNTDIR="/media"

# Include partition UUID in mountpoint folder name
UUIDNAME=no

# Dorectory where USBx symlinks will be created
LINKDIR="/media"

# Share via Samba to access through RPI from other Windows installed PC on the same network
SHARESMB=yes
SHARERW=no
SHARELT=no

# Set spindown for rotational disks (minutes 1-20), 0 to disable
SPINDOWN=0

#############################################################################
# WARNING!                                                                  #
#                                                                           #
# The "sync" option may not be a good choice to use with flash drives, as   #
# it forces a greater amount of writing operating on the drive. This makes  #
# the writing speed considerably lower and also leads to a faster wear out  #
# of the disk.                                                              #
#                                                                           #
# If you omit it, don't forget to use the command "sync" to synchronize the #
# data on your disk before removing the drive or you may experience data    #
# loss.                                                                     #
#                                                                           #
# It is highly recommended that you use the pumount command (as a regular   #
# user) before unplugging the device. It makes calling the "sync" command   #
# and mounting with the sync option unnecessary---this is similar to other  #
# operating system's "safely disconnect the device" option.                 #
#############################################################################
# Mount options: Options passed to the mount command with the -o flag.
# See the warning above regarding removing "sync" from the options.
MOUNTOPTIONS="sync,noexec,nodev,noatime,nodiratime,rw"

# Filesystem type specific mount options: This variable contains a space
# separated list of strings, each which the form "-fstype=TYPE,OPTIONS".
#
# If a filesystem with a type listed here is mounted, the corresponding
# options are appended to those specificed in the MOUNTOPTIONS variable.
#
# For example, "-fstype=vfat,gid=floppy,dmask=0007,fmask=0117" would add
# the options "gid=floppy,dmask=0007,fmask=0117" when a vfat filesystem
# is mounted.
FS_MOUNTOPTIONS="-fstype=ntfs,gid=xbian,uid=xbian,umask=0,big_writes,allow_other \
                 -fstype=vfat,gid=xbian,uid=xbian,umask=0 \
                 -fstype=hfsplus,gid=xbian,uid=xbian,umask=0,force \
                 -fstype=exfat,gid=xbian,uid=xbian,umask=0 \
                 -fstype=btrfs,compress=lzo,subvol=/"

# If set to "yes", more information will be logged via the syslog
# facility.
VERBOSE=no

USESWAPS=no

BUT

if you want to access already existing folder and files, you have to make sure that user xbian has write permissions! I'm supposing this is your problem
Find all posts by this user
Quote this message in a reply
28th May, 2016, 11:39 AM
Post: #5
RE: Read only ext3 HDD with smb access
Yes! The disks where already in use with OpenElec. So I think the last line is my problem. "xbian has write permissions"
How do I do this?
I´m not a linux user

Thanks! I solved it with your help as I know what I was looking for.
Thanks!!!
Find all posts by this user
Quote this message in a reply
29th May, 2016, 02:23 AM (This post was last modified: 29th May, 2016 02:24 AM by Nachteule.)
Post: #6
RE: Read only ext3 HDD with smb access
sudo chown -R xbian:xbian /media/<externaldisk>/

<externaldisk> is mountpoint of you external disk/ext3 partition
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: