Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CuBox-I GPU Accelerated Desktop
8th Mar, 2015, 06:39 PM
Post: #16
RE: CuBox-I GPU Accelerated Desktop
No, i'm not angry at all Smile

Quote:I was trying to consider your feelings as if I should talk to a company with whom you have a relationship.
And i told you several times you don't have to do that.

Quote:My intention was to make sure I was not crossing any of your activity with them. I get it that it would be improper for you to tell me what to say or who to speak with and you have never done this.
If you would, they will tell you.

Quote:On the other hand I felt it professional to ask if my talking with SR could have any negative impact on your relationship or business with SR. It was truly an attempt to be professional and considerate, nothing else.
SR is professional enough to not have any relationship affected by single users.

Quote:Curlymo, it seems my good intentions (really they are) pave the road to hell.

You have helped me and I appreciate it. My hope was to fulfill my statement that I wanted to help and support Xbian. It seems the best I can do for you is express my regret and keep my mouth shut.

Can we start fresh as I sincerely regret if I have offended or pissed you off in any way?

If you can advise me on how I can launch your desktop directly into terminal I would appreciate that very much but if you are done and I do not hear from you I accept that as well.
There is no need to start fresh because there was no problem in the first place. I'm still just saying you ask too much confirmation from us about what you do or say towards SR. That's all.

Quote:All the best to you and Xbian.
Thank you, of course to you to!

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
9th Mar, 2015, 01:43 AM
Post: #17
RE: CuBox-I GPU Accelerated Desktop
Great Smile

To focus on the technical, there appear to be two problems in my experience with the desktop:

1. The audio (speakers) do not work either using .wav files or video in the browser (YouTube or webRTC)

2. The desktop starts with xbmc rather than terminal which then has to be closed, the TV is turned off and the user has to turn the TV back on and then is presented with a login prompt. It would be preferable for the user if the desktop presented a login so the user can choose the next step be it a browser or whatever.

Please advise as to how to resolve, many thanks.
Find all posts by this user
Quote this message in a reply
9th Mar, 2015, 09:13 AM
Post: #18
Sound Problem solved
I spent a few hours today troubleshooting and after much reading and trial and effort found a combination of:

apt-get --reinstall install alsa-base alsa-utils alsa-oss libasound2

and coding the following in ~/.asoundrc

defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1


it worked with wav files and in the browser <video> tag

This is the culmination of a lot of reading and testing so not sure if the first step is required but what harm. If in doubt I recommend the ~/.asoundrc file change first.

Now just the launch into terminal or xserver and all is good...any ideas on this?????
Find all posts by this user
Quote this message in a reply
10th Mar, 2015, 08:49 AM
Post: #19
chromium-browser behaivor
Hi;

I just discovered this desktop and loaded it today - great job.

It includes V40 chromium-browser which is good but does not play well with the power management in xfce4.

If anyone is interested I solved the problem by uninstalling xfce4 and then removing all xfce4 files not caught by the remove/purge and then installed lxde.

I am not trying to promote lxde but chromium does not issue any of the many warning messages it does under xfce4. I am not sure if they would have interfered as I did not test for long before simply replacing xfce4 with lxde.

Does anyone know if I am heading for trouble with this change and if not I hope it helps others.

This is the best debian desktop I have found, well done.
Find all posts by this user
Quote this message in a reply
12th Mar, 2015, 02:01 AM
Post: #20
mic problem and solution
In experimenting with a two way audio/video call in chromium, I was using the flag:

--use-fake-ui-for-media-stream

At the same time I noted a failure of the mic on the computer using this flag (used only on one CuBox-i computer - the other is a windows pc).

After some experimentation, I discovered that in my set up, this flag was the cause. I therefore reverted to the flag:

--kiosk

and the mic came back.

The objective was to not require the allow dialog box to pop up which works but in one case, I lose the mic and in the other I am forced into full screen which degrades the fps for the video call so neither is ideal.

Just sharing in case anyone else had similar problems as this one took some time to track down.
Find all posts by this user
Quote this message in a reply
24th Jun, 2015, 01:50 PM
Post: #21
RE: CuBox-I GPU Accelerated Desktop
Is this still working? I've been trying to setup the GPU accelerated desktop with the release of June 20 and I've been unable to achieve something functional.

I'm getting either a Segmentation Fault or a fatal error with X that forces a reboot. I've double and triple checked the repositories, and followed all the steps. Does it need a kernel replacement or an specific version of the Xbian image? I'm not sure about what to do with the linux-image-3.14.28-armmp package. Thanks in advance for the help you can provide me
Find all posts by this user
Quote this message in a reply
2nd Aug, 2015, 05:39 AM
Post: #22
RE: CuBox-I GPU Accelerated Desktop
Hi all;

I have been working with a version I downloaded months ago and so far no significant problems aside from the odd reboot for no apparent reason which could also be anything from cpu heat to ??? but I do not think there is a real problem with this AD.

That said I would like to update/upgrade to gain any benefit but before I do I want to ask if there is any guidance on doing this to make sure I do not break anything.

Great work as this is still the only AD/chromium solution I have seen for the CuBoxi - I'm sure it was not easy.
Find all posts by this user
Quote this message in a reply
3rd Dec, 2015, 04:04 PM
Post: #23
RE: CuBox-I GPU Accelerated Desktop
Hello!

I did try this out yesterday, with the latest Cubox images. (XBian_2015.11.29_imx6.img.gz)

When executing this command
Quote:sudo apt-get install hicolor-icon-theme xfce4-panel thunar-volman linux-image-3.14.28-armmp firmware-imx xserver-xorg-dev xserver-xorg-video-imx-viv xserver xfce4 lxterminal mesa-utils xinit x11-xserver-utils x11-xserver-utils

I got this error:

Quote:ERROR: ld.so: object '/lib/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.

There was one of theese packages that wouldn´t extract, complained something about some version, I just tried to force it, but it didn´t go that well.
After a reboot, neither Kodi or X will work, it just tries for a while and then gives up, don´t remember the fault message now, I am at work.
But I can check when I get home.

Do I need to downgrade to the version you "CurlyMo" where using at the moment, or is there newer information about this?
Would be nice to have a solution that I can run with the latest updates, and without having to crash it all up if I to update to a newer version.

Someone who knows?
Find all posts by this user
Quote this message in a reply
4th Dec, 2015, 04:00 AM
Post: #24
RE: CuBox-I GPU Accelerated Desktop
(8th Mar, 2015 03:58 AM)tvideovi Wrote:  Here is the update - success

By using the March 7 img the install and instructions including the apt-get worked well without a need to force anything.

The startxfce ran properly and I will now move to my applications testing.

It seems the problem was that I was using the Feb 7/28 img and whatever the problem, it has been rectified in the March 7 img.

My challenges were also increased as at the time of download yesterday, the xbian download page link for latest img was incorrect but thanks to the other person's post (can't remember who), I was directed to the correct March 7 img which worked.

Thank you

I was about to test March 7 image, but I don't seem to find it.
Do you or anyone else have it left? Maybe host it for a while somewhere?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: