Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xbian won't find SSID *NO INTERNET*
2nd Feb, 2017, 06:10 AM
Post: #16
RE: Xbian won't find SSID *NO INTERNET*
Ah, I suppose I know where the culprit is:

RPi3's onboard WLAN interface requires crda package to work properly with channel 13 (usually I do not use the onboard WLAN)

Please install crda package (it is currently not installed per default) and after that run commands as follows:

Terminal

root@kmxbilr2 / # iwlist wlan0 scanning | grep Channel


Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:4
Frequency:2.427 GHz (Channel 4)

root@kmxbilr2 / # iw reg set DE
root@kmxbilr2 / # iwlist wlan0 scanning | grep Channel


Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:4
Frequency:2.427 GHz (Channel 4)
Channel:13
Frequency:2.472 GHz (Channel 13)

You see after setting REGDOMAIN to DE channel 13 is there Smile

To make setting permanent please set variable REGDOMAIN to DE in file /etc/default/crda:

Terminal

root@kmxbilr2 ~ # cat /etc/default/crda
# Set REGDOMAIN to a ISO/IEC 3166-1 alpha2 country code so that iw(8) may set
# the initial regulatory domain setting for IEEE 802.11 devices which operate
# on this system.
#
# Governments assert the right to regulate usage of radio spectrum within
# their respective territories so make sure you select a ISO/IEC 3166-1 alpha2
# country code suitable for your location or you may infringe on local
# legislature. See `/usr/share/zoneinfo/zone.tab' for a table of timezone
# descriptions containing ISO/IEC 3166-1 alpha2 country codes.

REGDOMAIN=DE
Find all posts by this user
Quote this message in a reply
2nd Feb, 2017, 06:49 AM
Post: #17
RE: Xbian won't find SSID *NO INTERNET*
(2nd Feb, 2017 06:10 AM)Nachteule Wrote:  Ah, I suppose I know where the culprit is:

RPi3's onboard WLAN interface requires crda package to work properly with channel 13 (usually I do not use the onboard WLAN)

Please install crda package (it is currently not installed per default) and after that run commands as follows:

Terminal

root@kmxbilr2 / # iwlist wlan0 scanning | grep Channel


Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:4
Frequency:2.427 GHz (Channel 4)

root@kmxbilr2 / # iw reg set DE
root@kmxbilr2 / # iwlist wlan0 scanning | grep Channel


Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:1
Frequency:2.412 GHz (Channel 1)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:11
Frequency:2.462 GHz (Channel 11)
Channel:4
Frequency:2.427 GHz (Channel 4)
Channel:13
Frequency:2.472 GHz (Channel 13)

You see after setting REGDOMAIN to DE channel 13 is there Smile

To make setting permanent please set variable REGDOMAIN to DE in file /etc/default/crda:

Terminal

root@kmxbilr2 ~ # cat /etc/default/crda
# Set REGDOMAIN to a ISO/IEC 3166-1 alpha2 country code so that iw(8) may set
# the initial regulatory domain setting for IEEE 802.11 devices which operate
# on this system.
#
# Governments assert the right to regulate usage of radio spectrum within
# their respective territories so make sure you select a ISO/IEC 3166-1 alpha2
# country code suitable for your location or you may infringe on local
# legislature. See `/usr/share/zoneinfo/zone.tab' for a table of timezone
# descriptions containing ISO/IEC 3166-1 alpha2 country codes.

REGDOMAIN=DE

Thanks a lot. Will try. I normally do that using country=de in the wpa_supplicant.conf.

Maybe changing this can be integrated with the wifi setup GUI.
Find all posts by this user
Quote this message in a reply
2nd Feb, 2017, 06:52 AM
Post: #18
RE: Xbian won't find SSID *NO INTERNET*
(2nd Feb, 2017 06:49 AM)udo.christ Wrote:  Thanks a lot. Will try. I normally do that using country=de in the wpa_supplicant.conf.

Maybe changing this can be integrated with the wifi setup GUI.

I'm already thinking about that Tongue
Find all posts by this user
Quote this message in a reply
2nd Feb, 2017, 07:14 AM
Post: #19
RE: Xbian won't find SSID *NO INTERNET*
(2nd Feb, 2017 06:52 AM)Nachteule Wrote:  
(2nd Feb, 2017 06:49 AM)udo.christ Wrote:  Thanks a lot. Will try. I normally do that using country=de in the wpa_supplicant.conf.

Maybe changing this can be integrated with the wifi setup GUI.

I'm already thinking about that Tongue

Well:

iw is not working and not scanning 12/13 as a consequence for me...

Terminal
root@xbian:/home/xbian# iw reg get
country 00: DFS-UNSET
(2402 - 2472 @ 40), (6, 20), (N/A)
(2457 - 2482 @ 40), (6, 20), (N/A), PASSIVE-SCAN
(2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 160), (6, 20), (N/A), PASSIVE-SCAN
(5250 - 5330 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)
root@xbian:/home/xbian# iw reg set DE
root@xbian:/home/xbian# iw reg get
country 00: DFS-UNSET
(2402 - 2472 @ 40), (6, 20), (N/A)
(2457 - 2482 @ 40), (6, 20), (N/A), PASSIVE-SCAN
(2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 160), (6, 20), (N/A), PASSIVE-SCAN
(5250 - 5330 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)
Find all posts by this user
Quote this message in a reply
2nd Feb, 2017, 07:17 AM (This post was last modified: 2nd Feb, 2017 07:18 AM by Nachteule.)
Post: #20
RE: Xbian won't find SSID *NO INTERNET*
Do you have package crda installed?

iw does not complain anything if package crda is not installed
Find all posts by this user
Quote this message in a reply
2nd Feb, 2017, 07:19 AM
Post: #21
RE: Xbian won't find SSID *NO INTERNET*
ok. need to install packages iw and crda so i get the tool and database.
these should be included with the default image,...

et-voila. channel 13 is mine alone :-)
Find all posts by this user
Quote this message in a reply
4th Feb, 2017, 04:14 AM
Post: #22
RE: Xbian won't find SSID *NO INTERNET*
(2nd Feb, 2017 07:19 AM)udo.christ Wrote:  ok. need to install packages iw and crda so i get the tool and database.

Since today iw and crda package is part of all new built images
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: