Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Kodi 14.1 video and audio output issues
18th Feb, 2015, 01:14 PM
Post: #1
Kodi 14.1 video and audio output issues
I've upgraded from the xbmc 13.2 alsa package to kodi 14.1 and one really cool feature has disappeared.

In 13.2 I selected alsa as my audio device (hifiberry dac) and music files played through the dac, while video files played through hdmi. I assumed that this was possible due to different players being used for music and video (dvdplayer and omxplayer).

In kodi 14.1 this no longer works and all audio plays through the selected device, whether it's from mkv, flac, whatever.

Is there a way to get this functionality back?


Edit: solved with workaround via add-on http://forum.kodi.tv/showthread.php?tid=201896
Find all posts by this user
Quote this message in a reply
18th Feb, 2015, 03:54 PM
Post: #2
RE: Kodi 14.1 video and audio output issues
if the case is due to using separate players than probably not that simple as there was significant change where only one player is used now

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
18th Feb, 2015, 09:22 PM
Post: #3
RE: Kodi 14.1 video and audio output issues
I can think of two possibilities: I could reinstall omx and set it as an external player for video files, or maybe use an alsa setup for routing to both hdmi and dac..I'm not yet sure if either is possible! :-)

There is an add-on that switches devices on the start of playback, there are a lot of requests in the xbmc forums for this sort of feature so I felt pretty lucky when I had it with xbian.
Find all posts by this user
Quote this message in a reply
18th Feb, 2015, 10:41 PM
Post: #4
RE: Kodi 14.1 video and audio output issues
Just installed the add-on I mentioned, works brilliantly so far!

http://forum.kodi.tv/showthread.php?tid=201896
Find all posts by this user
Quote this message in a reply
19th Feb, 2015, 04:10 PM
Post: #5
RE: Kodi 14.1 video and audio output issues
nice to see you found the way Wink
Thank you for update.
Could you also edit prefix of thread and set it to [Solved].
Thanks

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: