Thank you for your donation

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: touch not calibrating well (ELO Touchmonitor)
12th Apr, 2015, 02:35 AM
Post: #1
Brick touch not calibrating well (ELO Touchmonitor)

struggling already a long time and not doing really good progress. On the Rpi 2 I installed xbian and was happy that the touch events were arleady recognized. I'm having a ELO IntelliTouch monitor (series 2700) connected by USB.

The problem:
only a small area on the upper right corner is the toucharea ... so calibration is not working.

Found lots of stuff for an eGalaxy screen and at the end tried by ts_calibrate to generate a pointercal file what in general worked. The toucharea changed and I can move now the pointer a bit wider area but still far from being ok. I don't know what alternatives there are to calibrate the touch as ts_calibrate process had not failed. I started to manually change some values but that seems being impossible somehow.

my current resolution (by tvservice -s):
state 0x12001a [HDMI DMT (9) RGB full 4:3], 800x600 @ 60.00Hz, progressive

by ts_test I find out that let upper corner has coordinates 100, 100 while right bottom corner has 4000, 4000

after connecting USB from touch dmesg looks like this:
[ 1627.737970] usb 1-1.4: new full-speed USB device number 7 using dwc_otg
[ 1627.892675] usb 1-1.4: New USB device found, idVendor=04e7, idProduct=0020
[ 1627.892693] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1627.892705] usb 1-1.4: Product: Elo TouchSystems 2700 IntelliTouch® USB Touchmonitor Interface
[ 1627.892715] usb 1-1.4: Manufacturer: Elo TouchSystems, Inc.
[ 1627.892726] usb 1-1.4: SerialNumber: 20000000
[ 1627.957156] input: Elo TouchSystems, Inc. Elo TouchSystems 2700 IntelliTouch® USB Touchmonitor Interface as /devices/platform/bcm2708_usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:04E7:0020.0005/input/input4
[ 1627.957794] hid-generic 0003:04E7:0020.0005: input,hidraw1: USB HID v1.00 Pointer [Elo TouchSystems, Inc. Elo TouchSystems 2700 IntelliTouch® USB Touchmonitor Interface] on usb-bcm2708_usb-1.4/input0
[ 1627.974415] usbcore: registered new interface driver usbtouchscreen

the original generated pointercal that didn't work fine, but before any manual change was:
12989 -123 -308576 -28 9829 -511816 65536 800 600 0

really would love to see that touchscreen working fine, hope someone is willing to help!

thank you,
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: