Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WD Elements 2tb, usb 3.0, 2.5 inch not working
21st May, 2015, 07:41 PM
Post: #1
WD Elements 2tb, usb 3.0, 2.5 inch not working
Hello, i have the above hard drive, and i bought powered usb hub and 3A power supply for the Raspberry pi 2, so i think it has enough power, but no matter what, it wont work. I have the latest Xbian. If someone have some suggestions, it would be great. Thanks
Find all posts by this user
Quote this message in a reply
22nd May, 2015, 02:43 AM
Post: #2
RE: WD Elements 2.5 tb, usb 3.0, 2.5 inch not working
Did you connect everything like below schematic ?
(thanks Pratik)


There are only 10 types of people in the world: those who understand binary, and those who don't
Find all posts by this user
Quote this message in a reply
22nd May, 2015, 07:42 PM
Post: #3
RE: WD Elements 2.5 tb, usb 3.0, 2.5 inch not working
Ok thanks for this, but i can't do this, because i bought usb hub with 1A power supply, and separately 3A for the Raspberry itself, and can't use it for the hub because it has different power cable. I just don't see what is the difference if i connect it like this in the schematics. I only have one hard drive in usb huv, and directly in raspberry usb wlan adapter and usb for wireless keyboard and mouse. I have tried connecting another 1tb hard and it mounted instantly and i tried again with wd elements 2tb and it mounted it, but it couldn't access the files, the hard drive makes clicking noise like it doesn't have enough power, so i suspect it's cheap chinese power suply fault. I will try with something else when i get my hands on.
Find all posts by this user
Quote this message in a reply
22nd May, 2015, 11:45 PM
Post: #4
RE: WD Elements 2.5 tb, usb 3.0, 2.5 inch not working
I've a feeling something is odd here. WD do not do a 2.5 inch 2.5TB hdd
http://www.wdc.com/en/products/products.aspx?id=470#Tab3

They do have a 3,5 inch 2.5TB HDD
http://www.wdc.com/en/products/products.aspx?id=260

I have both models but in different capacities.

The 2.5 inch USB drive can be powered by a 500ma USB socket

However, my 3.5 inch 2TB elements desktop came with it's own 12V 1.5amp power supply, so this could be the problem.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
24th May, 2015, 06:47 PM
Post: #5
RE: WD Elements 2.5 tb, usb 3.0, 2.5 inch not working
Sorry i write it wrong, i meant 2tb.
And i found a solution, a had one universal power supply 1.8A which i connected to the usb hub and it works now. So the bottom line is, i bought a cheap chinese usb hub from ebay, and it's power supply says it is 1A but obviously it's not. So be carefull when ordering. Thanks for the replies.
Find all posts by this user
Quote this message in a reply
25th May, 2015, 02:35 AM
Post: #6
RE: WD Elements 2tb, usb 3.0, 2.5 inch not working
Just NEVER use cheap ebay/dx.com/etc. chinese power supplies. These things are deadly. Check the many websites about it.

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
25th May, 2015, 05:13 PM
Post: #7
RE: WD Elements 2tb, usb 3.0, 2.5 inch not working
You know that sounds a lot easier than it is, right. Not a lot of electronics that's not built in China.
Find all posts by this user
Quote this message in a reply
25th May, 2015, 06:11 PM
Post: #8
RE: WD Elements 2tb, usb 3.0, 2.5 inch not working
I added a little more nuance.

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: