Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cubox-i Wireless only works when Ethernet connected
2nd Jan, 2016, 12:17 PM
Post: #1
Cubox-i Wireless only works when Ethernet connected
Xbian release: 20151221; Xbian 1.0/Kernel 4.3.3
Kodi: 15.2
Overclock: default
Hardware: Cubox-i with the Freescale iMX6 Quad
Network: Embedded WiFi card and Ethernet port.

I want this box to work on WiFi only. So far I have been able to get ethernet working (dhcp, default) and the WiFi configuration (static) works only when the ethernet cable is connected. I've done all configuration with Xbian-config command UI.

So at some point I can ssh with two different IPs. If I unplug the ethernet cable both interfaces go down. If I boot without the cable, WiFi does not start.

I tried configuring network bonding just for the sake of testing (see this), but it didn't work.

Has anyone been through this?

Thanks.
Find all posts by this user
Quote this message in a reply
9th Jan, 2016, 10:52 PM
Post: #2
RE: Cubox-i Wireless only works when Ethernet connected
On RPi2 - removing the Ethernet also brings both connections down, but on reboot the wireless still works.

I'd suggest setting your STATIC IP for the Wifi via the ssh xbian-config as that is what I used. Also have a look in /etc/network/interfaces and check that the SSID and PSK both look correct.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
28th Jan, 2016, 10:26 AM (This post was last modified: 28th Jan, 2016 10:26 AM by Nachteule.)
Post: #3
RE: Cubox-i Wireless only works when Ethernet connected
I've never had problems on all my boxes (RPi1, RPi2 and i.MX6 (Hummingboard)). I'm always using static IP's for ETH and WLAN. ETH is mostly unplugged
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: