Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: Installing libwebkitgtk
1st Mar, 2016, 05:17 AM
Post: #1
Installing libwebkitgtk
I have XBian 1.0 (knockout) on my Raspberry PI B, and I would like to install some lightweight browser with javascript support (which I would then run through vnc). Right now I'm using Iceweasel, but that one is quite slow, so I was thinking about installing surf, Epiphany or kweb. Problem is all those are webkit based and when I'm trying to install them through apt, I'm getting into a conflict. They all need libwebkitgtk-1.0-0 (>= 1.3.10), but that one depends on libegl1-mesa (>= 7.8.1) or libegl1-x11 and libgles2-mesa (>= 7.8.1) or libgles2 which are in conflict with xbian-package-firmware. According to its description, this one, however, should provide libegl1-mesa and libgles2-mesa. Is there a way I can make libwebkitgtk correctly install even with keeping xbian-package-firmware?
Find all posts by this user
Quote this message in a reply
1st Mar, 2016, 07:39 AM
Post: #2
RE: Installing libwebkitgtk
If you will use VNC, it will never go fast, so I would assume that not Iceweasel AKA Firefox is so slow, it's VNC
Find all posts by this user
Quote this message in a reply
21st Feb, 2017, 06:02 AM
Post: #3
RE: Installing libwebkitgtk
I have the same problem--trying to install a webbrowser in lxde based on xbian (seemed like a sensible idea at the time). Is there a way to resolve the dependency problem?
Find all posts by this user
Quote this message in a reply
21st Feb, 2017, 08:33 AM
Post: #4
RE: Installing libwebkitgtk
Will check if there is a way out of the dependency jungle Smile
Find all posts by this user
Quote this message in a reply
23rd Feb, 2017, 09:24 AM
Post: #5
RE: Installing libwebkitgtk
Should be fixed with recent xbian-package-firmware update

Terminal

root@kmxbilr2 ~ # dpkg-query -s xbian-package-firmware
Package: xbian-package-firmware
Essential: yes
Status: install ok installed
Priority: optional
Section: firmware
Installed-Size: 16665
Origin: XBian
Maintainer: mkreisl <development@xbian.org>
Architecture: armhf
Version: 4-1487795786
Replaces: raspberrypi-artwork, raspberrypi-bootloader, libraspberrypi0, libraspberrypi-bin, libraspberrypi-dev, xbian-update (<= 1.0-0.4)
Provides: libraspberrypi0, libraspberrypi-dev, libegl1-mesa (= 8.0.0), libegl1-mesa-dev, libegl1-mesa-drivers, libgles2-mesa-dev, libgles2-mesa (= 8.0.0)
Conflicts: libraspberrypi0, raspberrypi-artwork, raspberrypi-bootloader, libraspberrypi0, libraspberrypi-bin, libraspberrypi-dev, xbian-package-firmware-6q, libegl1-mesa, libegl1-mesa-dev, libegl1-mesa-drivers, libgles2-mesa-dev, libgles2-mesa
Description: RPI firmware (RPI2 compatible)
(at commit src 1a717bb3efc7f4751d8c1839f8d48111a89958f8, commit xbian repo d21cb928705f3a6dae4a346559178ac44f46837b)

Terminal

root@kmxbilr2 ~ # apt-get install -s libwebkitgtk-1.0-0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
libcec-dev libio-socket-inet6-perl libsocket6-perl python-cffi python-ply python-pycparser sendemail
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
aspell aspell-en dconf-gsettings-backend dconf-service dictionaries-common emacsen-common fontconfig glib-networking glib-networking-common glib-networking-services
gsettings-desktop-schemas libaspell15 libatk1.0-0 libatk1.0-data libcairo2 libdatrie1 libdconf1 libenchant1c2a libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-common libhunspell-1.3-0 libjavascriptcoregtk-1.0-0 libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libpixman-1-0 libproxy1 libsecret-1-0 libsecret-common libsoup2.4-1 libthai-data libthai0 libwebkitgtk-1.0-common libxcb-render0 libxcb-shm0
libxcomposite1 libxcursor1 libxinerama1 libxrandr2 libxrender1 libxt6 shared-mime-info
Vorgeschlagene Pakete:
aspell-doc spellutils wordlist libenchant-voikko libvisual-0.4-plugins gstreamer-codec-install gnome-codec-install gstreamer1.0-tools librsvg2-common gvfs
Empfohlene Pakete:
enchant gstreamer1.0-plugins-base hicolor-icon-theme libgtk2.0-bin hunspell-en-us hunspell-dictionary myspell-dictionary gstreamer1.0-plugins-good geoclue-2.0
Die folgenden NEUEN Pakete werden installiert:
aspell aspell-en dconf-gsettings-backend dconf-service dictionaries-common emacsen-common fontconfig glib-networking glib-networking-common glib-networking-services
gsettings-desktop-schemas libaspell15 libatk1.0-0 libatk1.0-data libcairo2 libdatrie1 libdconf1 libenchant1c2a libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-common libhunspell-1.3-0 libjavascriptcoregtk-1.0-0 libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libpixman-1-0 libproxy1 libsecret-1-0 libsecret-common libsoup2.4-1 libthai-data libthai0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libxcb-render0
libxcb-shm0 libxcomposite1 libxcursor1 libxinerama1 libxrandr2 libxrender1 libxt6 shared-mime-info
0 aktualisiert, 47 neu installiert, 0 zu entfernen und 136 nicht aktualisiert.
...
Inst libwebkitgtk-1.0-common (2.4.9-1~deb8u1 Debian:8.7/stable [all])
Inst libwebkitgtk-1.0-0 (2.4.9-1~deb8u1 Debian:8.7/stable [armhf])
root@kmxbilr2 ~ #
Find all posts by this user
Quote this message in a reply
28th Feb, 2017, 04:23 AM
Post: #6
RE: Installing libwebkitgtk
Hi,

I'm having a similar issue :
Code:
root@xbian ~ # apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbian-package-firmware : Conflicts: libegl1-mesa
E: Broken packages

It's on a Raspberry Pi 2 Model B, and the installed version of xbian-package-firmware is version 4-1487795751.

Hope it's nothing big Big Grin
Find all posts by this user
Quote this message in a reply
28th Feb, 2017, 06:43 AM
Post: #7
RE: Installing libwebkitgtk
@Pymous:

Already wrote on IRC:

Code:
[19:53] <mkreisl> i suppose you have packages installed which requires libegl1-mesa higher than 8.0.0
[19:55] <mkreisl> debian version is 10.3.1 for jessie, and 13.0.4 for jessie backport and stretch
[19:57] <mkreisl> can you confirm this?

Waiting now for reply ...
Find all posts by this user
Quote this message in a reply
28th Feb, 2017, 08:06 AM
Post: #8
RE: Installing libwebkitgtk
I confirm Smile

I "fixed" the issue by disabling other mirrors I installed (nodesources, ...) and using aptitude to handle any further conflict in the upgrade process (libcec was one of them), and now everything is working great ! Smile

Thanks for your help ! :3
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: