Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Updates not working
25th May, 2016, 10:33 AM
Post: #1
Updates not working
Hi guys,

I have two RPi with the Xbian version 20160406-0,
which tell me both I have several upgrades awaiting
(see attachment with list).

But when trying to update/upgrade those, it just does
not work on both (see attachment with failure).

Does anyone know, what is wrong here?

PS I have not changed anything on the system. I am
just doing the usual update procedures within xbian-config
every four or five weeks.


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
25th May, 2016, 02:07 PM
Post: #2
RE: Updates not working
It looks like a shared lib is standing in the way.

I would backup and force it.

Please read rules and do a search before you post! | FAQs | How to post log file? | Can't find an answer? Contact us.
Visit this user's website Find all posts by this user
Quote this message in a reply
25th May, 2016, 09:50 PM
Post: #3
RE: Updates not working
@syco

Could be this issue again
Find all posts by this user
Quote this message in a reply
25th May, 2016, 10:08 PM
Post: #4
RE: Updates not working
Ah, shit, the Samba thing, alright.

I will give it a try and report back later, mates.
Find all posts by this user
Quote this message in a reply
25th May, 2016, 11:16 PM
Post: #5
RE: Updates not working
Okay, that is what I did:

1. sudo dpkg -r --force-all python-samba samba samba-common-bin samba-common samba-dsdb-modules samba-libs:armhf

2. sudo apt-get -f install

3. sudo apt-get install samba python-samba samba-common-bin samba-common samba-dsdb-modules samba-libs libsmbclient libldb1 python-ldb

It seems, step 3 was unneccessary after step 2, but well, it seems to work now.

All the updates/upgrades went through.

Thank you very much for your prompt and helping support.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  [PROBLEM] Updates not working syco 5 4,984 1st Jun, 2013 06:33 AM
Last Post: Koenkk

Forum Jump: