Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TVHeadEnd rejecting login
13th Jun, 2016, 12:40 PM
Post: #1
TVHeadEnd rejecting login
Just installed the lastest XBian with Kodi 16.1 on a Raspberry Pi Model B+. Logged in and installed tvheadend with apt-get install xbian-package-tvheadend, rebooted and then attempted to access http://<IP address here>:9981. Web page appears and prompt for tvheadend login pops up. Copy and paste details from .hts/tvheadend/accesscontrol/1, but get "Login Rejected, try again?"

Is this a known issue with a fix? Or was the install procedure wrong? Or something else?

Any constructive assistance or questions welcome. Hoping to get OTA TV soon.
Find all posts by this user
Quote this message in a reply
13th Jun, 2016, 11:16 PM
Post: #2
RE: TVHeadEnd rejecting login
(13th Jun, 2016 12:40 PM)livetv Wrote:  Is this a known issue with a fix? Or was the install procedure wrong? Or something else?

Any constructive assistance or questions welcome. Hoping to get OTA TV soon.

Seems to be issue in tvheadend, IMO they changed authorization database structure and setting default xbian/raspberry user does not longer work.

To get access to tvheadend without username/password, please add -C parameter in file /etc/default/tvheadend (see also here)

Code:
# TVH_ARGS
#   add any other arguments
TVH_ARGS="-C"

and then restart tvheadend

Terminal

sudo restart tvheadend

This should help
Find all posts by this user
Quote this message in a reply
14th Jun, 2016, 12:49 PM
Post: #3
RE: TVHeadEnd rejecting login
Thanks much! Will give it a try. Hopefully this will get documented somewhere? Or have people given up on OTA TV? Ready made settop boxes for the purpose (that work) cost way more than an RPi.

(13th Jun, 2016 11:16 PM)Nachteule Wrote:  
(13th Jun, 2016 12:40 PM)livetv Wrote:  Is this a known issue with a fix? Or was the install procedure wrong? Or something else?

Any constructive assistance or questions welcome. Hoping to get OTA TV soon.

Seems to be issue in tvheadend, IMO they changed authorization database structure and setting default xbian/raspberry user does not longer work.

To get access to tvheadend without username/password, please add -C parameter in file /etc/default/tvheadend (see also here)

Code:
# TVH_ARGS
#   add any other arguments
TVH_ARGS="-C"

and then restart tvheadend

Terminal

sudo restart tvheadend

This should help
Find all posts by this user
Quote this message in a reply
14th Jun, 2016, 10:06 PM
Post: #4
RE: TVHeadEnd rejecting login
(14th Jun, 2016 12:49 PM)livetv Wrote:  Thanks much! Will give it a try. Hopefully this will get documented somewhere? Or have people given up on OTA TV?

Yeah, seems to be uncool using OTA tv Tongue

Only fresh installations are affected, not older ones with already existing tvheadend configuration

I'm already testing a fix for that issue
Find all posts by this user
Quote this message in a reply
15th Jun, 2016, 04:00 AM (This post was last modified: 15th Jun, 2016 04:28 AM by Nachteule.)
Post: #5
RE: TVHeadEnd rejecting login
Fixed, FYI look here

Please note you have to remove all files from folder /home/xbian/.hts/tvheadend/accesscontrol/ before installing new fixed package
Find all posts by this user
Quote this message in a reply
15th Jun, 2016, 12:57 PM
Post: #6
RE: TVHeadEnd rejecting login
Find all posts by this user
Quote this message in a reply
15th Jun, 2016, 10:04 PM
Post: #7
RE: TVHeadEnd rejecting login
@livetv
Your last post is not very informative Tongue
Find all posts by this user
Quote this message in a reply
16th Jun, 2016, 09:23 AM
Post: #8
RE: TVHeadEnd rejecting login
Well, it was informative until the forum ate it. Got into tvheadend alright, setup passwords, then discovered that the TV tuner was not being detected. It is a Hauppauge WintTV 850. There is no /dev/dvb/ directory, but lsmod turns up a bunch of modules that got loaded, see below. Some of those look relevant. I had this tuner working on my desktop x86 linux box a few months ago, but the tuner is not detected there either now. Thanks for all the help so far, googling has been less than successful.

Code:
cx231xx_dvb             8045  0
dvb_core               81298  3 dvb_usb,lgdt3305,cx231xx_dvb
cx231xx_alsa            5776  0
tda18271               34609  0
hid_logitech            9806  0
tea5767                 5668  0
tuner                  14708  0
cx25840                45519  0
evdev                  11221  5
joydev                  8936  0
cx231xx               134584  2 cx231xx_alsa,cx231xx_dvb
cx2341x                17895  1 cx231xx
videobuf_vmalloc        4525  1 cx231xx
videobuf_core          17243  2 cx231xx,videobuf_vmalloc
i2c_mux                 2496  1 cx231xx
tveeprom               11607  1 cx231xx
v4l2_common             4279  4 cx2341x,cx231xx,cx25840,tuner
videodev              140015  5 cx2341x,cx231xx,cx25840,tuner,v4l2_common
media                  11951  4 cx231xx,cx25840,tuner,videodev
Find all posts by this user
Quote this message in a reply
16th Jun, 2016, 09:47 PM
Post: #9
RE: TVHeadEnd rejecting login
In my own experience there are two reasons for this behavior:

1) the stick does not 'like' the usb port (had this issue here using cubieboard2 and terratec dvb-c stick)
2) firmware is missing (your device requires firmware file). I'm sure you already found this this site
Find all posts by this user
Quote this message in a reply
14th Apr, 2017, 07:54 AM
Post: #10
RE: TVHeadEnd rejecting login
(13th Jun, 2016 11:16 PM)Nachteule Wrote:  
(13th Jun, 2016 12:40 PM)livetv Wrote:  Is this a known issue with a fix? Or was the install procedure wrong? Or something else?

Any constructive assistance or questions welcome. Hoping to get OTA TV soon.

Seems to be issue in tvheadend, IMO they changed authorization database structure and setting default xbian/raspberry user does not longer work.

To get access to tvheadend without username/password, please add -C parameter in file /etc/default/tvheadend (see also here)

Code:
# TVH_ARGS
#   add any other arguments
TVH_ARGS="-C"

and then restart tvheadend

Terminal

sudo restart tvheadend

This should help

Hello
I've edited the file and restarted the service, no luck. Tvheadend just doesn't care... Huh Still can't connect.
Find all posts by this user
Quote this message in a reply
14th Apr, 2017, 11:51 AM
Post: #11
RE: TVHeadEnd rejecting login
@Chiron

What happened before? Any updates, system crash, new installation ???
Find all posts by this user
Quote this message in a reply
15th Apr, 2017, 05:19 AM
Post: #12
RE: TVHeadEnd rejecting login
Well, I've reinstalled some weeks ago. Everything is working fine, but I can't remember the password I set, a typo error when I set it up, or most likely I'm getting old... Tongue
Find all posts by this user
Quote this message in a reply
16th Apr, 2017, 03:38 AM
Post: #13
RE: TVHeadEnd rejecting login
I had a power outage during an update.
Everything got corrupted and I had to reinstall an restore my backup.

but still no access to tvheadend gui. Do you know how to reset the password?

Ok I finally managed it
Code:
service tvheadend stop
tvheadend -C
I and I could connect to the gui. :-)
Find all posts by this user
Quote this message in a reply
16th Apr, 2017, 05:27 AM
Post: #14
RE: TVHeadEnd rejecting login
That's fine Smile

And procedure described in my post did not work? Undecided
Find all posts by this user
Quote this message in a reply
16th Apr, 2017, 07:52 AM
Post: #15
RE: TVHeadEnd rejecting login
(16th Apr, 2017 05:27 AM)Nachteule Wrote:  That's fine Smile

And procedure described in my post did not work? Undecided

No, it didn't. Confused
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: