Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Just came from Openelec. Reboot issue - RPi 2
22nd Jun, 2016, 03:11 AM
Post: #1
Just came from Openelec. Reboot issue - RPi 2
I was using Openelec but after someone on the HDHomeRun forum said XBIAN worked a lot better I switched and have to say it does. It is much smoother in video playback and the addon bugs I had are gone. The one problem I have is reboot doesn't seem to work on my Raspberry Pi 2. When I reboot the system (ssh and via kodi reboot) all I get is a black screen, to actually reboot I have to pull the power and plug it back in. Is this normal?
Find all posts by this user
Quote this message in a reply
22nd Jun, 2016, 03:55 AM
Post: #2
RE: Just came from Openelec. Reboot issue - RPi 2
No this is not normal.... and it's possible the SD card has been corrupted because of this.

1) Is this a recent image?
2) Have you made any modifications?


If all is Ok, remove "splash" from /boot/cmdline.txt and try again. You should see a lot of system messages, it might then be possible to determine what is causing the error.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
22nd Jun, 2016, 05:51 AM
Post: #3
RE: Just came from Openelec. Reboot issue - RPi 2
Sometimes it takes a bit longer to reboot (up to 2min). So please be patient Shy
Find all posts by this user
Quote this message in a reply
22nd Jun, 2016, 12:47 PM
Post: #4
RE: Just came from Openelec. Reboot issue - RPi 2
(22nd Jun, 2016 05:51 AM)Nachteule Wrote:  Sometimes it takes a bit longer to reboot (up to 2min). So please be patient Shy

Ya that was it. Why does it take so long to reboot?!? Openelec rebooted in like 20 seconds (max).
Find all posts by this user
Quote this message in a reply
22nd Jun, 2016, 09:16 PM
Post: #5
RE: Just came from Openelec. Reboot issue - RPi 2
(22nd Jun, 2016 12:47 PM)Eric Lieberman Wrote:  
(22nd Jun, 2016 05:51 AM)Nachteule Wrote:  Sometimes it takes a bit longer to reboot (up to 2min). So please be patient Shy

Ya that was it. Why does it take so long to reboot?!? Openelec rebooted in like 20 seconds (max).

cos you have a fully operational OS in behind and not just lightweight Kodi build Wink

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
22nd Jun, 2016, 10:00 PM
Post: #6
RE: Just came from Openelec. Reboot issue - RPi 2
Usually one or some services are blocking fast shutdown/reboot.

File /var/log/upstart/upstart-ev.log may help to find the culprit
Find all posts by this user
Quote this message in a reply
23rd Jun, 2016, 08:08 AM
Post: #7
RE: Just came from Openelec. Reboot issue - RPi 2
(22nd Jun, 2016 10:00 PM)Nachteule Wrote:  Usually one or some services are blocking fast shutdown/reboot.

File /var/log/upstart/upstart-ev.log may help to find the culprit

Wed Jun 22 10:06:38 EDT 2016 40821.99 160298.44 mounted /run/btrfs-snap 1.19 0.44 0.21 7/263 30144
Wed Jun 22 10:06:50 EDT 2016 40834.08 160337.88 stopped anacron 1.32 0.49 0.23 1/255 30242




That is all that shows up in the log.
Find all posts by this user
Quote this message in a reply
23rd Jun, 2016, 10:07 AM
Post: #8
RE: Just came from Openelec. Reboot issue - RPi 2
(23rd Jun, 2016 08:08 AM)Eric Lieberman Wrote:  Wed Jun 22 10:06:38 EDT 2016 40821.99 160298.44 mounted /run/btrfs-snap 1.19 0.44 0.21 7/263 30144
Wed Jun 22 10:06:50 EDT 2016 40834.08 160337.88 stopped anacron 1.32 0.49 0.23 1/255 30242

That is all that shows up in the log.

Only those 2 lines HuhHuhHuh

That's part of mine:

Terminal

Sat Jun 18 01:00:56 CEST 2016 10.37 0.83 starting mountall 0.30 0.07 0.02 3/103 401
Sat Jun 18 01:00:56 CEST 2016 10.36 0.83 started devroot 0.30 0.07 0.02 5/102 401
Sat Jun 18 01:00:57 CEST 2016 10.55 0.83 started xbian-failaccess 0.30 0.07 0.02 4/103 417
Sat Jun 18 01:00:57 CEST 2016 10.55 0.83 stopped devroot 0.30 0.07 0.02 3/103 417
Sat Jun 18 01:00:57 CEST 2016 11.20 0.83 mounted /run 0.30 0.07 0.02 8/116 461
Sat Jun 18 01:00:57 CEST 2016 11.21 0.83 starting udev 0.30 0.07 0.02 9/116 461
Sat Jun 18 01:00:57 CEST 2016 11.33 0.83 mounted /tmp 0.30 0.07 0.02 5/109 467
Sat Jun 18 01:00:58 CEST 2016 11.74 0.83 started hwclock.sh 0.30 0.07 0.02 10/119 500
Sat Jun 18 01:00:58 CEST 2016 11.76 0.83 started upstart-udev-bridge 0.30 0.07 0.02 11/119 500
Sat Jun 18 01:00:58 CEST 2016 11.79 0.83 started hwclock-systemd-disable 0.30 0.07 0.02 16/117 500
Sat Jun 18 01:00:58 CEST 2016 11.99 0.83 stopped hwclock-systemd-disable 0.30 0.07 0.02 2/104 503
Sat Jun 18 01:00:59 CEST 2016 12.91 0.83 started xbmc-failed-start 0.30 0.07 0.02 16/132 558
Sat Jun 18 01:00:59 CEST 2016 12.90 0.83 mounted /lib/modules 0.30 0.07 0.02 16/132 558
Sat Jun 18 01:00:59 CEST 2016 13.15 0.83 started failsafe 0.30 0.07 0.02 11/124 573
Sat Jun 18 01:01:00 CEST 2016 13.69 0.83 mounted /home 0.30 0.07 0.02 13/128 609
Sat Jun 18 01:01:00 CEST 2016 13.80 0.83 started module-init-tools 0.30 0.07 0.02 11/121 613
Sat Jun 18 01:01:00 CEST 2016 14.19 0.83 stopped gssd 0.30 0.07 0.02 4/113 627
Sat Jun 18 01:01:01 CEST 2016 14.90 0.83 stopped module-init-tools 0.30 0.07 0.02 12/140 689
Sat Jun 18 01:01:01 CEST 2016 14.91 0.83 starting xbmc-preload 0.30 0.07 0.02 13/141 691
Sat Jun 18 01:01:01 CEST 2016 14.91 0.83 started idmapd 0.30 0.07 0.02 11/140 689
Sat Jun 18 01:01:01 CEST 2016 14.90 0.83 started procps 0.30 0.07 0.02 13/139 689
Sat Jun 18 01:01:01 CEST 2016 14.88 0.83 started xbian-run 0.30 0.07 0.02 14/141 691
Sat Jun 18 01:01:01 CEST 2016 15.23 0.83 stopped procps 1.96 0.41 0.13 7/117 705
Sat Jun 18 01:01:02 CEST 2016 16.05 0.83 starting network-interface eth0 1.96 0.41 0.13 9/125 752
Sat Jun 18 01:01:02 CEST 2016 16.50 0.83 started xbian-inotifyd-bridge 1.96 0.41 0.13 8/121 782
Sat Jun 18 01:01:03 CEST 2016 17.49 0.83 xbmc-rc 1.96 0.41 0.13 13/140 839
Sat Jun 18 01:01:03 CEST 2016 17.50 0.83 stopped hostname.sh 1.96 0.41 0.13 12/140 839
Sat Jun 18 01:01:03 CEST 2016 17.51 0.83 started dbus 1.96 0.41 0.13 14/139 839
Sat Jun 18 01:01:04 CEST 2016 17.77 0.83 started idmapd 1.96 0.41 0.13 8/133 847
Sat Jun 18 01:01:04 CEST 2016 18.09 0.83 splash 1.96 0.41 0.13 5/127 866
Sat Jun 18 01:01:05 CEST 2016 18.82 0.83 started mountall 1.96 0.41 0.13 8/140 901
Sat Jun 18 01:01:05 CEST 2016 18.82 0.83 autofs 1.96 0.41 0.13 11/139 901
Sat Jun 18 01:01:05 CEST 2016 18.82 0.83 started autofs 1.96 0.41 0.13 7/140 901
Sat Jun 18 01:01:05 CEST 2016 19.14 0.83 started xbian-handle-cursor 1.96 0.41 0.13 5/129 908
Sat Jun 18 01:01:06 CEST 2016 20.28 0.83 mounted /proc 4.12 0.89 0.29 22/161 978
Sat Jun 18 01:01:06 CEST 2016 20.29 0.83 mounted /sys 4.12 0.89 0.29 18/162 978
Sat Jun 18 01:01:06 CEST 2016 20.25 0.83 mounted /dev/pts 4.12 0.89 0.29 17/162 978
Sat Jun 18 01:01:06 CEST 2016 20.26 0.83 mounted /tmp 4.12 0.89 0.29 19/162 978
Sat Jun 18 01:01:06 CEST 2016 20.26 0.83 mounted /dev 4.12 0.89 0.29 22/161 978
Sat Jun 18 01:01:06 CEST 2016 20.28 0.83 mounted / 4.12 0.89 0.29 18/162 978
Sat Jun 18 01:01:06 CEST 2016 20.18 0.83 mounted /home 4.12 0.89 0.29 11/161 977
Sat Jun 18 01:01:06 CEST 2016 20.22 0.83 mounted /lib/modules 4.12 0.89 0.29 28/157 978
Sat Jun 18 01:01:07 CEST 2016 20.69 0.83 mounted /run/rpc_pipefs 4.12 0.89 0.29 5/126 991
Sat Jun 18 01:01:08 CEST 2016 21.49 0.83 net-device-up eth0 4.12 0.89 0.29 7/123 1029

You should find start and stop of each service. Interesting value is last columm, this is time from last boot. So if one service blocks system you'll see a big time difference
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: