Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[PROBLEM] RPi3 takes over TV
15th Sep, 2016, 06:34 AM
Post: #1
[PROBLEM] RPi3 takes over TV
Raspberry Pi 3
HDHomerun add-on
Samsung series 8 TV 2016 w/simple remote
XBian / Kodi, of course - though about 7/2012 release

CEC works and the most of the remote functions map (except channel up/down). That's good.
The issue is after I change to another (HDMI) source using the TV menu. For example, the cable box, or AppleTV. From 5 seconds to a minute later Xbian commandeers the HDMI and switches the TV back to itself. Bad! All I can think of is the RPi is toggling the HDMI somehow announcing that it is starting up and making the TV switch back to it by convention.

With that in mind I'll try adding the config file line to not power on TV upon power on of RPi.

Any other advice?

BTW - I reworked my Xbian install to the 7/2012 version after something I did with the most current version caused video output to immediately stop right after HDHomerun add-on loaded. Fortunately the entire process is simple and fast.
Find all posts by this user
Quote this message in a reply
15th Sep, 2016, 04:12 PM
Post: #2
RE: [PROBLEM] RPi3 takes over TV
(15th Sep, 2016 06:34 AM)robtown Wrote:  Raspberry Pi 3
HDHomerun add-on
Samsung series 8 TV 2016 w/simple remote
XBian / Kodi, of course - though about 7/2012 release

CEC works and the most of the remote functions map (except channel up/down). That's good.
The issue is after I change to another (HDMI) source using the TV menu. For example, the cable box, or AppleTV. From 5 seconds to a minute later Xbian commandeers the HDMI and switches the TV back to itself. Bad! All I can think of is the RPi is toggling the HDMI somehow announcing that it is starting up and making the TV switch back to it by convention.

With that in mind I'll try adding the config file line to not power on TV upon power on of RPi.

Any other advice?

BTW - I reworked my Xbian install to the 7/2012 version after something I did with the most current version caused video output to immediately stop right after HDHomerun add-on loaded. Fortunately the entire process is simple and fast.

Change settings System -> Settings -> System -> Input Devices -> Peripherals -> CEC adapter

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: