Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: KeyError in upstart-bridge/service.py
22nd Nov, 2016, 07:08 AM
Post: #1
KeyError in upstart-bridge/service.py
Hello,
I am using XBian distribution, but when "logged in" to a profile, an upstart-bridge-related error appears in the kodi notification box (bottom right corner). Otherwise all seems to work ...

This is (the only error) message in kodi.log:

Code:
ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.KeyError'>
                                            Error Contents: ('result',)
                                            Traceback (most recent call last):
                                              File "/usr/local/share/kodi/addons/script.service.xbian.upstart-bridge/service.py", line 205, in <module>
                                                service = UpstartBridge()
                                              File "/usr/local/share/kodi/addons/script.service.xbian.upstart-bridge/service.py", line 20, in __init__
                                                self.monitor = XBMCMonitor(self)
                                              File "/usr/local/share/kodi/addons/script.service.xbian.upstart-bridge/service.py", line 123, in __init__
                                                json_version = json_response['result']['version']
                                            KeyError: ('result',)
                                            -->End of Python script error report<--

Is this something for a bug report? What is the purpose of upstart-bridge service, btw?

Thank you very much.
Best regards,
D.
Find all posts by this user
Quote this message in a reply
22nd Nov, 2016, 08:33 AM
Post: #2
RE: KeyError in upstart-bridge/service.py
(22nd Nov, 2016 07:08 AM)DanT Wrote:  Is this something for a bug report? What is the purpose of upstart-bridge service, btw?

How do you get this error message?

I'm using profile(s) since years but never got this error.

AFAIR there is already an issue report on github (maybe closed)

The purpose of this module is sending Kodi events to upstart
Find all posts by this user
Quote this message in a reply
7th Dec, 2016, 07:53 AM
Post: #3
RE: KeyError in upstart-bridge/service.py
(22nd Nov, 2016 08:33 AM)Nachteule Wrote:  How do you get this error message?
Well, I don't know, to be honest. It just appears on the screen as soon as Kodi is started (I was wrong in the original post - the error appears BEFORE a profile is selected).

I made some photos of the error message box, I just don't know how to put them here (seems that external link is accepted only).

(22nd Nov, 2016 08:33 AM)Nachteule Wrote:  AFAIR there is already an issue report on github (maybe closed)
Hmmm, I did not find any relevant info. Could you, please, point me to the error?

(22nd Nov, 2016 08:33 AM)Nachteule Wrote:  The purpose of this module is sending Kodi events to upstart
Yes, I expect so :-) I hoped for a bit more details about what type of info in passed from kodi to upstart (or vice versa) - if it is related to a udev messages or services startup/stop. But it is just my curiosity, this answer is not particularly important :-)

(7th Dec, 2016 07:53 AM)DanT Wrote:  I made some photos of the error message box, I just don't know how to put them here (seems that external link is accepted only).

Here they are:
shows the error message (in Czech) saying: Error in XBian XBMC-Upstart bridge. More information in log"

Just after his error, "OK" message box appears:
Find all posts by this user
Quote this message in a reply
7th Dec, 2016, 08:22 AM
Post: #4
RE: KeyError in upstart-bridge/service.py
(7th Dec, 2016 07:53 AM)DanT Wrote:  Well, I don't know, to be honest. It just appears on the screen as soon as Kodi is started (I was wrong in the original post - the error appears BEFORE a profile is selected).

Ah, I see. You have this issue

Quote:Hmmm, I did not find any relevant info. Could you, please, point me to the error?

See above

I'm using autologin and so I do not have this issue
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: