Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: RPI 3 running xbian need kodi 16
28th Jan, 2017, 03:02 PM
Post: #1
RPI 3 running xbian need kodi 16
hey guys, i just tried to install xbian to run kodi on my rpi 3, i found that i received the latest kodi distro. is it possible to install using kodi 16?
Find all posts by this user
Quote this message in a reply
28th Jan, 2017, 08:51 PM
Post: #2
RE: RPI 3 running xbian need kodi 16
(28th Jan, 2017 03:02 PM)Kerat Wrote:  hey guys, i just tried to install xbian to run kodi on my rpi 3, i found that i received the latest kodi distro. is it possible to install using kodi 16?

Stable images are still built on 16.1 so you should be good

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 12:01 AM
Post: #3
RE: RPI 3 running xbian need kodi 16
Actually not! The latest "Xbian-latest-rpi3" is Kodi 17. No idea when it changed, or if any of the earlier releases offer Kodi 16.
I personally don't think Xbian (Krypton) is ready to be released as stable.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 12:18 AM
Post: #4
RE: RPI 3 running xbian need kodi 16
Ooops, you guys are right. Forgot to disable staging repo when image is built for Rpi2/3

Will fix this ASAP, sorry for that Sad

And @Kerat, I agree with you, Krypton is IMO far far away from stable state Dodgy
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 03:41 AM
Post: #5
RPI 3 running xbian need kodi 16
Thank you for looking into this. I don't mind doing testing in less trafficked areas, but this build will be used in my master bedroom and I need it to have a high WAF. My wife is very comfortable with Kodi 16's interface.


Sent from my iPhone using Tapatalk
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 03:45 AM
Post: #6
RE: RPI 3 running xbian need kodi 16
Fixed, image for RPi2/3 is now available for download Smile

Set to solved
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 04:00 AM
Post: #7
RE: RPI 3 running xbian need kodi 16
For those that have installed the "wrong" image can the system be "downgraded" by just editing /etc/apt/sources.d/xbian.list and comment out the staging line and doing an upgrade in xbian-config?

Or is it best to start again from scratch?

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 04:09 AM
Post: #8
RE: RPI 3 running xbian need kodi 16
No, not needed. You can downgrade xbian-package-xbmc by running in ssh session:

Terminal

root@kmxbilr ~ # sudo apt-cache policy xbian-package-xbmc
xbian-package-xbmc:
Installed: 17.0~RC4-1484950842
Candidate: 17.0~RC4-1484950842
Version table:
*** 17.0~RC4-1484950842 0
100 /var/lib/dpkg/status
17.0~RC4-1484523222 0
500 mirror://apt.xbian.org/mirror.txt/ devel/rpi-jessie armhf Packages
17.0~RC2-1483315447 0
500 mirror://apt.xbian.org/mirror.txt/ devel/rpi-jessie armhf Packages
17.0~RC1-1483011624 0
500 mirror://apt.xbian.org/mirror.txt/ devel/rpi-jessie armhf Packages
16.1-1483301050 0 <<<<<<<<<<<<<
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi-jessie armhf Packages
16.1-1481421998 0
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi-jessie armhf Packages
16.1-1463971457 0
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi-jessie armhf Packages

root@kmxbilr ~ # sudo apt-get install xbian-package-xbmc=16.1-1483301050

First command: Gives you a list of available packages
Second command: Install version you want to have

That's all you have to do Smile
Find all posts by this user
Quote this message in a reply
29th Jan, 2017, 05:19 AM
Post: #9
RE: RPI 3 running xbian need kodi 16
My apology for my earlier post as I should have checked before I replied.
Nice to see it has been looked into and fixed. Thanks to our top man Smile

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Jan, 2017, 04:10 AM
Post: #10
RPI 3 running xbian need kodi 16
Reinstalled, it installed kodi 16. Thank you.


Sent from my iPhone using Tapatalk
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: