Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: Couchpotato: 500: Internal Server Error
8th Feb, 2017, 11:48 AM
Post: #1
Couchpotato: 500: Internal Server Error
Hi everyone,

Im a xbian user that never used before couchpotato. Now I'm trying to setting it up but I can't. i hope someone could help me.

Software
XBian version: 1.0
XBMC/Kodi version: 16.1
Overclock settings: none

Hardware
Device type and model (e.g. Raspberry Pi Model A/B 256/512 MB, CuBox-i i4Pro, ...): Raspberry Pi 3 Model B
Power supply rating: 2.5 A, original
SD card size and make/type: 2GB
Network (Ethernet or wireless): Wireless
Connected devices (TV, USB, network storage, ...): TV via HDMI

Log files
Link to logfile(s): not provided

Problem description:
I'im trying to use couchpotato but I get "500: Internal Server Error". I have uninstalled and installed couchpotato from xbian .xbian-config-start. I if have a look at
Code:
cat /etc/couchpotato/logs/CouchPotato.log
I always see something like this:

Terminal
02-08 02:06:06 ERROR Uncaught exception GET / (192.168.1.134)
HTTPRequest(protocol='http', host='192.168.1.2:9095', method='GET', uri='/', version='HTTP/1.1', remote_ip='192.168.1.134', headers={'Connection': 'Keep-Alive', 'Accept-Language': 'es-ES', 'Accept-Encoding': 'gzip, deflate', 'Authorization': 'Basic eGJpYW46cmFzcGJlcnJ5', 'Host': '192.168.1.2:9095', 'Accept': 'text/html, application/xhtml+xml, image/jxr, */*', 'User-Agent': 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393'})
Traceback (most recent call last):
File "/usr/local/share/couchpotato/libs/tornado/web.py", line 1141, in _when_complete
else:
File "/usr/local/share/couchpotato/libs/tornado/web.py", line 1162, in _execute_method

File "/usr/local/share/couchpotato/couchpotato/__init__.py", line 28, in get
return self.get_secure_cookie('user')
File "/usr/local/share/couchpotato/couchpotato/__init__.py", line 39, in index
if not views.get(route):
File "/usr/local/share/couchpotato/libs/tornado/template.py", line 273, in generate
execute = namespace["_tt_execute"]
File "index_html.generated.py", line 111, in _tt_execute
_tt_tmp = json_encode(Env.get('args', unicode = True)) # index.html:83
TypeError: get() got an unexpected keyword argument 'unicode'

After looking on internet I have tried this
Code:
sudo find /usr/local/share/couchpotato/ -name "*.pyc" -exec rm -rf {} \;
but I have still the same problem.

How to reproduce:
sudo /etc/init.d/couchpotato restart
Connect to the URL.

Thanks.
Find all posts by this user
Quote this message in a reply
9th Feb, 2017, 03:15 AM (This post was last modified: 9th Feb, 2017 05:44 AM by Nachteule.)
Post: #2
RE: Couchpotato: 500: Internal Server Error
xbian-package-couchpotato is a 3 year old package. Probably this is the problem

I build new package which is available soon at our repository and mirrors.

Please note, couchpotato requires a python-openssl version 15 or higher, which is not available in debian jessie repository.

To get a recent package before installing xbian-package-couchpotato, you have to enable jessie-backport repo as follows:

1) add jessie-backport to /etc/apt/sources.list

Terminal

cat /etc/apt/sources.list
deb http://http.debian.net/debian/ jessie main contrib non-free

deb http://http.debian.net/debian/ jessie-backports main contrib non-free

2) modify pin settings by adding file jessie-backports into folder /etc/apt/preferences.d

Terminal

cat /etc/apt/preferences.d/jessie-backports
Package: *
Pin: release a=jessie-backports
Pin-Priority: 800

3) run sudo apt-get update

Terminal

sudo apt-get update
...
...
OK http://http.debian.net jessie-backports/main armhf Packages
OK http://http.debian.net jessie-backports/contrib armhf Packages
OK http://http.debian.net jessie-backports/non-free armhf Packages
OK http://http.debian.net jessie-backports/contrib Translation-en
OK http://http.debian.net jessie-backports/main Translation-en
OK http://http.debian.net jessie-backports/non-free Translation-en
OK http://http.debian.net jessie/main armhf Packages
OK http://http.debian.net jessie/contrib armhf Packages
OK http://http.debian.net jessie/non-free armhf Packages
OK http://http.debian.net jessie/contrib Translation-en
OK http://http.debian.net jessie/main Translation-de_DE
OK http://http.debian.net jessie/main Translation-de
OK http://http.debian.net jessie/main Translation-en
OK http://http.debian.net jessie/non-free Translation-en
Find all posts by this user
Quote this message in a reply
9th Feb, 2017, 08:54 AM
Post: #3
RE: Couchpotato: 500: Internal Server Error
Thanks!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: