Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Constant loss of connection
15th Apr, 2017, 02:55 AM
Post: #16
RE: Constant loss of connection
I am facing the same issue with my Edimax WiFi dongle using the rtl8192cu driver on a Raspberry PI 2. The wifi seems to go to sleep randomly and throws off all connections until I reconnect or reboot.

Will try to disable sleep mode with parameters tonight.

One odd thing I noticed since last update (now Kernel 4.9.20+) is that the WiFi LED stays on and never blinks. I am strongly suspecting a common driver issue here.

Weekend is here so I will poke around and see if this issue can be fixed. Will report back.
Find all posts by this user
Quote this message in a reply
15th Apr, 2017, 03:24 AM (This post was last modified: 15th Apr, 2017 03:30 AM by Nachteule.)
Post: #17
RE: Constant loss of connection
(15th Apr, 2017 02:55 AM)abdulmueid Wrote:  I am facing the same issue with my Edimax WiFi dongle using the rtl8192cu driver on a Raspberry PI 2. The wifi seems to go to sleep randomly and throws off all connections until I reconnect or reboot.

rtl8192cu driver is still crap! You should use legacy 8192cu driver instead (don't forget to blacklist rtl8192cu).

Quote:Will try to disable sleep mode with parameters tonight.

One odd thing I noticed since last update (now Kernel 4.9.20+) is that the WiFi LED stays on and never blinks. I am strongly suspecting a common driver issue here.

8192cu driver has module parameter which lets you turn off led completely (that I'm using in my living room, makes me nervous always watching to that blinking led ...)

Terminal

modinfo 8192cu | grep led
parm: rtw_led_enable:Enable status LED (int)

This is my setting
Terminal

root@kmxbilr / # cat /etc/modprobe.d/8192cu.conf
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_led_enable=0
blacklist rtl8192cu
Find all posts by this user
Quote this message in a reply
15th Apr, 2017, 03:55 AM
Post: #18
RE: Constant loss of connection
Thank you very much kind sir. I am used to Xbian working out of the box, so never bothered with the drivers.

You saved me a lot of time Smile

(15th Apr, 2017 03:24 AM)Nachteule Wrote:  
(15th Apr, 2017 02:55 AM)abdulmueid Wrote:  I am facing the same issue with my Edimax WiFi dongle using the rtl8192cu driver on a Raspberry PI 2. The wifi seems to go to sleep randomly and throws off all connections until I reconnect or reboot.

rtl8192cu driver is still crap! You should use legacy 8192cu driver instead (don't forget to blacklist rtl8192cu).

Quote:Will try to disable sleep mode with parameters tonight.

One odd thing I noticed since last update (now Kernel 4.9.20+) is that the WiFi LED stays on and never blinks. I am strongly suspecting a common driver issue here.

8192cu driver has module parameter which lets you turn off led completely (that I'm using in my living room, makes me nervous always watching to that blinking led ...)

Terminal

modinfo 8192cu | grep led
parm: rtw_led_enable:Enable status LED (int)

This is my setting
Terminal

root@kmxbilr / # cat /etc/modprobe.d/8192cu.conf
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_led_enable=0
blacklist rtl8192cu
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: