Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi won't start after upgrade....
29th May, 2017, 02:29 AM
Post: #1
Kodi won't start after upgrade....
Hi,

Kodi no longer starts on one pi after the 17.2 and 17.3 upgrades. It is a pi1 and a manual 'kodi start' seems to just go on for ever.
'Kodi status' gives 'xbmc start/pre-start, process 2805 yet strangely process 2805 is not showing in 'top'. But I don't know what to do now!

A Pi2 is doing the exact same thing. Argggghhhh....

Please help me out! Smile
Find all posts by this user
Quote this message in a reply
29th May, 2017, 05:03 AM
Post: #2
RE: Kodi won't start after upgrade....
Maybe your database RPi is dead again Tongue

Installed 17.2 and 17.3 on my RPi1, absolutely no problem
Find all posts by this user
Quote this message in a reply
29th May, 2017, 06:18 AM
Post: #3
RE: Kodi won't start after upgrade....
I wish it were the db pi - that would be an easy fix. I'll hold off upgrading the other 2 pi for now as I don't want to loose them all!
Find all posts by this user
Quote this message in a reply
29th May, 2017, 07:21 AM
Post: #4
RE: Kodi won't start after upgrade....
1) Did you already looked into Kodi's log file?
2) You could try to install 17.1 again, to see if this version comes up
3) You could install older version or kernel package (4.9.30 was built at Saturday, but I don't use this version, RPi1 still using 4.9.16 and my RPi2 and 3 are running devel version 4.11.2)
Find all posts by this user
Quote this message in a reply
29th May, 2017, 08:06 PM
Post: #5
RE: Kodi won't start after upgrade....
Thanks for the tips.

Well, this is strange. I spent a few hours repeatedly trying the 'faulty' installs and rebooting them each time they failed. After about the 6th reboot they both suddenly worked. I have no idea why all the previous reboots had no effect, but as of now they are operational again. I'm lost for any sane explaination of what might be going on! ???
Find all posts by this user
Quote this message in a reply
29th May, 2017, 09:53 PM
Post: #6
RE: Kodi won't start after upgrade....
Hmmm, that's weird

Seems you have a heavy problem in your system environment. As already told last time, it's not normal that Kodi does not come up if db server is not working
Find all posts by this user
Quote this message in a reply
29th May, 2017, 10:26 PM
Post: #7
RE: Kodi won't start after upgrade....
Yes, that was/is a very strange problem. Have not tried it again since, but likely still the case. I did update the db pi today and that had no issues at all.

Now I am trying to install python on one of the naughty pi1's, it worked on another xbian pi last week, but as usual I get problems with this one....at least this time you won't have to sort it out. ;-)

Oh, there is an issue with DNS too on the xbian/kodi install. Seems that if you go into the kodi setup>xbian>networks and try to set DNS it gives a network error. I tried to set a new DNS in /etc/network/interfaces but still it would not set the DNS server. The only way was to use xbian-config and then it stays on the new server address. Didn't know if you were aware of that or not.
Find all posts by this user
Quote this message in a reply
30th May, 2017, 03:24 AM (This post was last modified: 30th May, 2017 03:26 AM by Nachteule.)
Post: #8
RE: Kodi won't start after upgrade....
(29th May, 2017 10:26 PM)Skywatch Wrote:  Oh, there is an issue with DNS too on the xbian/kodi install. Seems that if you go into the kodi setup>xbian>networks and try to set DNS it gives a network error. I tried to set a new DNS in /etc/network/interfaces but still it would not set the DNS server. The only way was to use xbian-config and then it stays on the new server address. Didn't know if you were aware of that or not.

Next strange thing Dodgy

1) Just tested (newer did this before Smile) and set new name server -> works as expected. No error appeared and network is restarted successfully
2) You're confusing me Huh. Nameservers are not set in /etc/network/interfaces, they are set (up to 3) in file /etc/resolv.conf
3) xbian-config and Kodi config GUI using same helper scripts in background. So both should work
Find all posts by this user
Quote this message in a reply
30th May, 2017, 03:55 AM
Post: #9
RE: Kodi won't start after upgrade....
Learning all the time! Smile

I thought that /etc/resolv.conf got it's data from /etc/network/interfaces? - Maybe I am not fully aware of how all this works Smile

When I tried to set a new dns server (pi hole) in17.1, it just gave a network error message in kodi and reverted to the old server ip.

Maybe I should get out more and stop dreaming of the perfect pi setup!
Find all posts by this user
Quote this message in a reply
30th May, 2017, 04:33 AM
Post: #10
RE: Kodi won't start after upgrade....
(30th May, 2017 03:55 AM)Skywatch Wrote:  Learning all the time! Smile

Big Grin

Quote:I thought that /etc/resolv.conf got it's data from /etc/network/interfaces? - Maybe I am not fully aware of how all this works Smile

Only if you let dhcp configuring your network device(s). The dhcp client is writing values into /etc/resolv.conf

Quote:When I tried to set a new dns server (pi hole) in17.1, it just gave a network error message in kodi and reverted to the old server ip.

Maybe your /etc/network/interfaces is in a format the helper scripts can not deal with (manually edited, when I started with XBian, I was editiing this file manually and xbian-config always reported errors Tongue)

Quote:Maybe I should get out more and stop dreaming of the perfect pi setup!

Perfect setup - LOL - this is impossible Tongue
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  [SOLVED] TV not working after Kodi 17 upgrade Chiron 5 1,174 7th Feb, 2017 09:30 AM
Last Post: Nachteule
  [PROBLEM] Can't upgrade from Kodi 14.2-BETA1 blaiz0r 2 2,580 31st Oct, 2015 06:24 PM
Last Post: jakenl

Forum Jump: