Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with SSH tunneling
1st Oct, 2017, 12:38 AM
Post: #1
Problems with SSH tunneling
So I'm trying to route xbian's traffic, through my server, via an SSH tunnel. Procedure:

  1. SSH using putty into Xbian
  2. SSH into server [ ssh -p <server-port> -D <bound-port> user@host] from within xbian terminal
  3. Go into Xbian GUI and change network settings under: settings>system>internet access
  4. Use proxy, select SOCKS5, server: "localhost", port < bound port>
  5. Test IP via whatsmyip on web viewer (does not show server IP)



How come it doesn't work?

Debug log here: https://pastebin.com/siYFrzhF
Find all posts by this user
Quote this message in a reply
1st Oct, 2017, 03:10 AM
Post: #2
RE: Problems with SSH tunneling
(1st Oct, 2017 12:38 AM)cairnarvon Wrote:  So I'm trying to route xbian's traffic, through my server, via an SSH tunnel. Procedure:

  1. SSH using putty into Xbian
  2. SSH into server [ ssh -p <server-port> -D <bound-port> user@host] from within xbian terminal
  3. Go into Xbian GUI and change network settings under: settings>system>internet access
  4. Use proxy, select SOCKS5, server: "localhost", port < bound port>
  5. Test IP via whatsmyip on web viewer (does not show server IP)

I'm neither SSH tunnel nor SOCKS expert, but your tunnel command under point 2 looks very strange

Shouldn't you use

Terminal

ssh -L [bind_address:]port:host:port user@server

for opening an SSH tunnel Huh
Find all posts by this user
Quote this message in a reply
2nd Oct, 2017, 03:17 AM
Post: #3
RE: Problems with SSH tunneling
(1st Oct, 2017 03:10 AM)Nachteule Wrote:  
(1st Oct, 2017 12:38 AM)cairnarvon Wrote:  So I'm trying to route xbian's traffic, through my server, via an SSH tunnel. Procedure:

  1. SSH using putty into Xbian
  2. SSH into server [ ssh -p <server-port> -D <bound-port> user@host] from within xbian terminal
  3. Go into Xbian GUI and change network settings under: settings>system>internet access
  4. Use proxy, select SOCKS5, server: "localhost", port < bound port>
  5. Test IP via whatsmyip on web viewer (does not show server IP)

I'm neither SSH tunnel nor SOCKS expert, but your tunnel command under point 2 looks very strange

Shouldn't you use

Terminal

ssh -L [bind_address:]port:host:port user@server

for opening an SSH tunnel Huh

I've tested the syntax on a Debian machine and it is correct. It seems that step 3 is where the problems are. The settings are pure window dressing and do not actually change anything, it's there as a potential future feature. If you want to use an SSH tunnel you have to configure it for a specific add-on, though I'm getting errors there too like " channel 9: open failed: connect failed: Connection refused
".Huh
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: