Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] build-essential on stretch (cubox-i)
4th Nov, 2017, 06:45 AM
Post: #1
[SOLVED] build-essential on stretch (cubox-i)
I am unable to install build-essential on my new stretch install for the cubox-i.

Code:
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:6.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I drilled down in the dependencies, and the root cause appears to be the version of linux-libc-dev available for this platform.
Code:
apt-get install libc6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev : Depends: linux-libc-dev (>= 4.9.30-1) but 4.8.15+rt9-1498667745 is to be installed

Any ideas?
Find all posts by this user
Quote this message in a reply
4th Nov, 2017, 10:04 AM
Post: #2
RE: build-essential on stretch (cubox-i)
Do you have linux-libc-dev already installed Huh

I'ts not installed per default on a fresh installation
Find all posts by this user
Quote this message in a reply
4th Nov, 2017, 12:09 PM
Post: #3
RE: build-essential on stretch (cubox-i)
(4th Nov, 2017 10:04 AM)Nachteule Wrote:  Do you have linux-libc-dev already installed Huh

I'ts not installed per default on a fresh installation

It was not fresh, but a couple of days old. Forgive me, I misspoke earlier. (I was still posting while the toddlers were awake, which short circuits a good portion of higher thought).

For some reason it seems to prefer the 4.8.15 version. Once I updated it manually with:
Terminal
apt-get install linux-libc-dev=4.9.51-1
it seems to be perfectly happy to install build-essential.

Will things compile if I am still on a 4.8.15 kernel and a 4.9.51 linux-libc-dev?
Find all posts by this user
Quote this message in a reply
4th Nov, 2017, 10:08 PM
Post: #4
RE: build-essential on stretch (cubox-i)
(4th Nov, 2017 12:09 PM)tempest Wrote:  
(4th Nov, 2017 10:04 AM)Nachteule Wrote:  Do you have linux-libc-dev already installed Huh

I'ts not installed per default on a fresh installation

It was not fresh, but a couple of days old. Forgive me, I misspoke earlier. (I was still posting while the toddlers were awake, which short circuits a good portion of higher thought).

For some reason it seems to prefer the 4.8.15 version. Once I updated it manually with:
Terminal
apt-get install linux-libc-dev=4.9.51-1
it seems to be perfectly happy to install build-essential.

A lot of packages are pinned, please look into file /etc/apt/preferences.d/xbian

Quote:Will things compile if I am still on a 4.8.15 kernel and a 4.9.51 linux-libc-dev?

Sure, if you don't want do compile off-tree kernel modules Smile
Find all posts by this user
Quote this message in a reply
4th Nov, 2017, 11:54 PM
Post: #5
RE: build-essential on stretch (cubox-i)
(4th Nov, 2017 10:08 PM)Nachteule Wrote:  Sure, if you don't want do compile off-tree kernel modules Smile

Since Xbian includes a bulletproof 8192cu driver, for my dongle I have no need of this. Thanks so much for clearing that up for me.
Find all posts by this user
Quote this message in a reply
5th Nov, 2017, 01:56 AM
Post: #6
RE: [SOLVED] build-essential on stretch (cubox-i)
(4th Nov, 2017 11:54 PM)tempest Wrote:  
(4th Nov, 2017 10:08 PM)Nachteule Wrote:  Sure, if you don't want do compile off-tree kernel modules Smile

Since Xbian includes a bulletproof 8192cu driver, for my dongle I have no need of this. Thanks so much for clearing that up for me.

Yeah, I'm using this driver as well Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  ffmpeg (stretch) (cubox-i) tempest 8 271 6th Nov, 2017 02:26 AM
Last Post: Nachteule

Forum Jump: