Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't stop samba service.
21st Nov, 2017, 10:32 PM
Post: #1
Can't stop samba service.
One Xbian box now has samba enabled and when I try to stop the service I says "Failed to stop service..."
Nothing in rc.local either.

How do I disable this please?
Find all posts by this user
Quote this message in a reply
21st Nov, 2017, 11:42 PM
Post: #2
RE: Can't stop samba service.
How did you try to stop Samba?

Samba service (smbd) is enabled via inetd, so this service can't be stopped like other services, you only can disable autostart of this service (this removes entries from /etc/inetd.conf)
Find all posts by this user
Quote this message in a reply
22nd Nov, 2017, 06:59 AM
Post: #3
RE: Can't stop samba service.
Thanks.

What happened is that it lost connection to the sql media databse on another pi after update. I looked in xbian-config>services and noticed samba not running, so turned it on to see what would happen (libraries worked then!) - But now I can't turn samba off again.
I looked in /etc/inetd.conf ...Do I just comment out the line 'microsoft-ds stream tcp nowait root /usr/sbin/smbd smbd'???

Yup! - That did it Smile

@Nachteule
Thanks for pointing me in the right direction! Smile
Find all posts by this user
Quote this message in a reply
22nd Nov, 2017, 07:10 AM
Post: #4
RE: Can't stop samba service.
(22nd Nov, 2017 06:59 AM)Skywatch Wrote:  Thanks.

What happened is that it lost connection to the sql media databse on another pi after update. I looked in xbian-config>services and noticed samba not running, so turned it on to see what would happen (libraries worked then!) - But now I can't turn samba off again.
I looked in /etc/inetd.conf ...Do I just comment out the line 'microsoft-ds stream tcp nowait root /usr/sbin/smbd smbd'???

Yup! - That did it Smile

@Nachteule
Thanks for pointing me in the right direction! Smile

This is exactly what "Disable autostart" in xbian-config GUI does Smile
Find all posts by this user
Quote this message in a reply
22nd Nov, 2017, 08:17 AM
Post: #5
RE: Can't stop samba service.
Not here it doesn't - All I have for options is.....

1. Autostart
2. (re)start
3. Stop
4. Edit
5. Delete

These are all via ssh > xbian-config > services menu. Do you really have a 'disable autostart' option in there on your pi? I tried 'autostart' and there is no option to toggle it or turn it off - it only enables autostart.
Find all posts by this user
Quote this message in a reply
22nd Nov, 2017, 09:09 AM
Post: #6
RE: Can't stop samba service.
(22nd Nov, 2017 08:17 AM)Skywatch Wrote:  Not here it doesn't - All I have for options is.....

1. Autostart
2. (re)start
3. Stop
4. Edit
5. Delete

These are all via ssh > xbian-config > services menu. Do you really have a 'disable autostart' option in there on your pi? I tried 'autostart' and there is no option to toggle it or turn it off - it only enables autostart.

Kodi's xbian-config GUI has it Tongue and console xbian-config has Autostart as toggle function Cool
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
Thumbs Up [SOLVED] Samba Won't Stop Autostarting [ACTUALLY IT DOES!] josch 2 4,432 19th Jan, 2014 09:39 PM
Last Post: josch

Forum Jump: