Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Disable automatic update not working?
2nd Dec, 2017, 05:25 AM
Post: #1
Disable automatic update not working?
Hello,

xbian keeps updating automatically even if I set it to not doit by Kodi addon or shell script. I guess there is a config file with a true/false or yes/no line, which file is this one in order to check if it's proprly setted?

Thank you very much.

Edit 1:
Umm maybe this one

Terminal
/etc/apt/apt.conf.d/20auto-upgrades

Edit 2
strange...

Terminal
xbian@xbian:~$ cat /etc/apt/apt.conf.d/
01autoremove 05xbian 10periodic 20auto-upgrades 99progress-bar
01autoremove-kernels 06xbian-btrfs 10xbian-periodic 50unattended-upgrades 99xbian-update-motd
03forceloop 07xbian-cache 15update-stamp 70debconf

xbian@xbian:~$ cat /etc/apt/apt.conf.d/10xbian-periodic
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "0";

xbian@xbian:~$ cat /etc/apt/apt.conf.d/20auto-upgrades
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";

Two files with the same configuration?

Anyways, I see that https://github.com/xbianonpi/xbian-update/blob/e8bc5464d17c754a7f8231fc1ec43259885693f2/content/DEBIAN/postinst uses 10xbian-periodic. I suppose that 20auto-upgrades is executed after it and that's my problem.


Just to index here: https://wiki.debian.org/UnattendedUpgrades#Automatic_call_via_.2Fetc.2Fapt.2Fapt.conf.d.2F20auto-upgrades
Find all posts by this user
Quote this message in a reply
2nd Dec, 2017, 06:44 AM
Post: #2
RE: Disable automatic update not working?
The question is - where does your /etc/apt/apt.conf.d/20auto-upgrades file came from (answer below)?

I've checked all my XBian's, neither this file appears on my XBian's nor it exists on my standard Debian's - but
it is there in a recent generated XBian image. So, it seams that this was introduced with Debian Stretch [1] - if APT::Periodic::Update-Package-Lists and/or? APT::Periodic::Unattended-Upgrade setting does not exist, this file will be generated by postinst procedure of package unattended-upgrades Confused

So, you can remove /etc/apt/apt.conf.d/20auto-upgrades safely, and I'll think about a solution how to solve this issue permanently

[1] Latest Jessie image does not have this file, so it is new Stretch behavior
Find all posts by this user
Quote this message in a reply
4th Dec, 2017, 12:48 AM (This post was last modified: 4th Dec, 2017 12:56 AM by Nachteule.)
Post: #3
RE: Disable automatic update not working?
(2nd Dec, 2017 06:44 AM)Nachteule Wrote:  So, you can remove /etc/apt/apt.conf.d/20auto-upgrades safely, and I'll think about a solution how to solve this issue permanently

With recent updates from Dec 2 (xbian-update, xbian-package-config-shell and xbian-package-config-xbmc), this issue is fixed.

10xbian-periodic has been moved to 20auto-upgrades now Smile

Terminal

root@kmxbilr ~ # cat /etc/apt/apt.conf.d/20auto-upgrades
//
// This content is managed by xbian-config console application and
// Kodi's XBian config GUI. Please do not modify this file manually
// unless you know what you are doing.
//
APT::Periodic::Unattended-Upgrade "0";
APT::Periodic::Update-Package-Lists "1";
root@kmxbilr
Find all posts by this user
Quote this message in a reply
4th Dec, 2017, 12:50 AM
Post: #4
RE: Disable automatic update not working?
Set to solved
Find all posts by this user
Quote this message in a reply
4th Dec, 2017, 04:49 AM
Post: #5
RE: Disable automatic update not working?
thanks!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: