Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17.4 instead of 17.6 ??
19th Dec, 2017, 08:01 PM
Post: #1
Kodi 17.4 instead of 17.6 ??
Hi all,

My Kodi is still in 17.4 same if i try to update packet from Xbian config...

Do i have to do something special to update to KODI 17.6 ?

Many thanks for your explanation.

KR Olivier

Software
XBian version: Xbian 1.0 (knockout) Kernel Linux 4.9.48
XBMC/Kodi version: 17.4
Overclock settings: No overclocking (PI3:none)

Hardware
Device type and model: Raspberry Pi Model 3
Power supply rating: Aukru Power 3A
SD card size and make/type: 32Go
Network (Ethernet or wireless): Ethernet
Connected devices (TV, USB, network storage, ...): TV LG OLED
Find all posts by this user
Quote this message in a reply
19th Dec, 2017, 11:52 PM
Post: #2
RE: Kodi 17.4 instead of 17.6 ??
Did you run "Check for updates" first?
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 01:25 AM
Post: #3
RE: Kodi 17.4 instead of 17.6 ??
(19th Dec, 2017 11:52 PM)Nachteule Wrote:  Did you run "Check for updates" first?

Yes i did and i said that all is correcly updated. But i'm still in 17.4 version of KODI ...
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 01:47 AM
Post: #4
RE: Kodi 17.4 instead of 17.6 ??
Hmmm, hard to believe Dodgy

Please run

Code:
sudo apt-get update

and give me output of

Code:
sudo apt-cache policy xbian-package-xbmc
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 05:09 AM
Post: #5
RE: Kodi 17.4 instead of 17.6 ??
Thanks Nachteule for your help...

The check for update i have made is from xbian config (in kodi menu)

I did what you said:

$ sudo apt-get update =>
Reading package lists... Done
E: Method mirror has died unexpectedly!
E: Sub-process mirror received a segmentation fault.

$ sudo apt-cache policy xbian-package-xbmc
xbian-package-xbmc:
Installed: 17.4-1504805281
Candidate: 17.4-1504805281
Version table:
*** 17.4-1504805281 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages
100 /var/lib/dpkg/status
17.4-1504149269 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages
17.3-1496271830 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages


Nothing is updated ... Strange no ?
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 05:29 AM (This post was last modified: 20th Dec, 2017 05:34 AM by Nachteule.)
Post: #6
RE: Kodi 17.4 instead of 17.6 ??
Not strange

Your /etc/apt/sources.list.d/xbian.list is incorrect.
Since Debian Stretch mirror method is not longer supported.

Look into this wiki article, correct your xbian.list and try again Smile
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 07:42 AM
Post: #7
RE: Kodi 17.4 instead of 17.6 ??
Ok thank, i have changed my "/etc/apt/sources.list.d/xbian.list" by :
deb http://apt.xbian.org/ stable main rpi2-stretch rpi2-stretch armv7l-stretch
### deb http://apt.xbian.org/ staging main rpi2-stretch rpi2-stretch armv7l-stretch
### deb http://apt.xbian.org/ devel main rpi2-stretch rpi2-stretch armv7l-stretch

I have changed also my ”/etc/apt/sources.list” by
deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free
as i don't know if i'm raspbian or debian i tried also :
deb http://deb.debian.org/debian stretch main non-free

i stil get in all cases :
sudo apt-get update
Reading package lists... Done
E: Method mirror has died unexpectedly!
E: Sub-process mirror received a segmentation fault.
xbian@xbian /etc/apt $ sudo apt-cache policy xbian-package-xbmc
xbian-package-xbmc:
Installed: 17.4-1504805281
Candidate: 17.4-1504805281
Version table:
*** 17.4-1504805281 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages
100 /var/lib/dpkg/status
17.4-1504149269 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages
17.3-1496271830 500
500 http://apt.xbian.org stable/rpi2-stretch armhf Packages

a misstake somewhere ?
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 08:45 AM (This post was last modified: 20th Dec, 2017 08:48 AM by Nachteule.)
Post: #8
RE: Kodi 17.4 instead of 17.6 ??
Hmmm, that's weird Huh

Your hardware is Pi3, so Debian is used, not Raspbian Exclamation

Last idea for today, are there additional files in folder /etc/apt/sources.list.d/ ?
Usually there is xbian.list only

And, please post output of

Code:
sudo grep -r mirror /etc/apt/
Find all posts by this user
Quote this message in a reply
20th Dec, 2017, 06:00 PM
Post: #9
RE: Kodi 17.4 instead of 17.6 ??
Hi,

Ok i change back ”/etc/apt/sources.list” by
deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free


There are the output asked (after rebboting) :
/etc/apt/sources.list.d/pilight.list:deb mirror://apt.pilight.org/mirror.txt stable main
/etc/apt/sources.list:deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free

Sound good ?
Find all posts by this user
Quote this message in a reply
21st Dec, 2017, 01:15 AM
Post: #10
RE: Kodi 17.4 instead of 17.6 ??
(20th Dec, 2017 06:00 PM)billythekid Wrote:  Hi,

Ok i change back ”/etc/apt/sources.list” by
deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free

You're confusing me Huh In your first post you told us that you're using Pi Model 3, so I assume you're using a Pi3
But - you are running Raspbian, which is only necessary for Pi 1 and Pi Zero and the kernel built for Pi1 can not be used on Pi3

So which hardware do you use exactly ?

Quote:There are the output asked (after rebboting) :
/etc/apt/sources.list.d/pilight.list:deb mirror://apt.pilight.org/mirror.txt stable main

So, here ^^^^ is the culprit. You have to change mirror://apt.pilight.org/mirror.txt to http://apt.pilight.org
Find all posts by this user
Quote this message in a reply
21st Dec, 2017, 02:26 AM
Post: #11
RE: Kodi 17.4 instead of 17.6 ??
Yes i have a PI3 and i put the file ”/etc/apt/sources.list” contain : "deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free"

ok thks, i have changed as you said "mirror://apt.pilight.org/mirror.txt" to "http://apt.pilight.org" in "pilight.list"

The apt-get updtate seem to be better (see trace below) but in fact when i reboot at the end, it's the same : i'm still in 17.4 version of kodi ...

It's starting to be more and more strange no ?



xbian@xbian /etc/apt/sources.list.d $ sudo apt-get update
Get:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://apt.xbian.org stable InRelease [10.9 kB]
Get:3 http://apt.pilight.org stable InRelease [3,970 B]
Ign:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Get:4 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages [1 6.4 MB]
Get:5 http://apt.xbian.org stable/main armhf Packages [14.0 kB]
Get:6 http://apt.xbian.org stable/rpi2-stretch armhf Packages [22.5 kB]
Ign:3 http://apt.pilight.org stable InRelease
Get:7 http://apt.pilight.org stable/main armhf Packages [7,349 B]
Get:8 http://mirrordirector.raspbian.org/raspbian stretch/non-free armhf Packages [115 kB]
Fetched 16.6 MB in 2min 1s (137 kB/s)
Reading package lists... Done
W: GPG error: http://mirrordirector.raspbian.org/raspbian stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9165938D90FDDD2E
W: The repository 'http://mirrordirector.raspbian.org/raspbian stretch InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://apt.pilight.org stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CC28DD82EF4C718C
W: The repository 'http://apt.pilight.org stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
xbian@xbian /etc/apt/sources.list.d $ sudo apt-get update
Find all posts by this user
Quote this message in a reply
21st Dec, 2017, 02:52 AM
Post: #12
RE: Kodi 17.4 instead of 17.6 ??
(21st Dec, 2017 02:26 AM)billythekid Wrote:  Yes i have a PI3 and i put the file ”/etc/apt/sources.list” contain : "deb http://mirrordirector.raspbian.org/raspbian/ stretch main non-free"

^^^^ SO THIS ENTRY IS WRONG ^^^^

I already wrote that: raspbian is for P1 and Pi Zero, debian for all others

This has to be deb http://deb.debian.org/debian stretch main contrib non-free ExclamationExclamationExclamation

Quote:ok thks, i have changed as you said "mirror://apt.pilight.org/mirror.txt" to "http://apt.pilight.org" in "pilight.list"

The apt-get updtate seem to be better (see trace below) but in fact when i reboot at the end, it's the same : i'm still in 17.4 version of kodi ...

It's starting to be more and more strange no ?

Nothing is strange. Sometimes it could be useful to use your own brain (sorry for those hard words, but also my patience has limitations)

Quote:xbian@xbian /etc/apt/sources.list.d $ sudo apt-get update
Get:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://apt.xbian.org stable InRelease [10.9 kB]
Get:3 http://apt.pilight.org stable InRelease [3,970 B]
Ign:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Get:4 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages [1 6.4 MB]
Get:5 http://apt.xbian.org stable/main armhf Packages [14.0 kB]
Get:6 http://apt.xbian.org stable/rpi2-stretch armhf Packages [22.5 kB]
Ign:3 http://apt.pilight.org stable InRelease
Get:7 http://apt.pilight.org stable/main armhf Packages [7,349 B]
Get:8 http://mirrordirector.raspbian.org/raspbian stretch/non-free armhf Packages [115 kB]
Fetched 16.6 MB in 2min 1s (137 kB/s)
Reading package lists... Done
W: GPG error: http://mirrordirector.raspbian.org/raspbian stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9165938D90FDDD2E
W: The repository 'http://mirrordirector.raspbian.org/raspbian stretch InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://apt.pilight.org stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CC28DD82EF4C718C
W: The repository 'http://apt.pilight.org stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
xbian@xbian /etc/apt/sources.list.d $ sudo apt-get update

apt-get update command never installs packages, it just updates the local package database - nothing more

To install newer packages, you have to run sudo apt-get upgrade
Find all posts by this user
Quote this message in a reply
21st Dec, 2017, 09:20 AM
Post: #13
RE: Kodi 17.4 instead of 17.6 ??
:-) many thanks for your patience... As you see my programing skill and linux skill are not very very high ...

After your are not oblige to answer me this is a forum (sorry for those hard words, ... ;-) )

IT WORK !!! so to summarize, i had to modify /etc/apt/sources.list.d/pilight.list, /etc/apt/sources.list & /etc/apt/sources.list.d/xbian.list
After i had to Update AND upgrade

Many thanks Nachteule, i don't know from where you are but if a days you come to france/marseille tell me i offer you a beer :-)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: