Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Samba error: sys_path_to_bdev() failed for path [.]!
10th Feb, 2018, 01:53 AM
Post: #1
Samba error: sys_path_to_bdev() failed for path [.]!
Samba stoped working few days ago. All clients are failing to connect. /var/log/samba/log.smbd log is full of this message:
Terminal
[2018/02/05 09:16:03.212296, 0] ../source3/lib/sysquotas.c:461(sys_get_quota)
sys_path_to_bdev() failed for path [.]!

Any ideas?
Find all posts by this user
Quote this message in a reply
10th Feb, 2018, 11:18 PM
Post: #2
RE: Samba error: sys_path_to_bdev() failed for path [.]!
I think it will require a few more details to sort this out.

For a start what is in your samba config file? What mounts? etc.... The more info you can give the more likely someone can help you.
Find all posts by this user
Quote this message in a reply
10th Feb, 2018, 11:40 PM
Post: #3
RE: Samba error: sys_path_to_bdev() failed for path [.]!
I did not make any changes in configuration, when samba stopped working. I think problem is related to some automaticly installed update.

smb.conf
Terminal
# DO NOT EDIT THIS FILE. FOR ADDITIONAL SETTINGS OR SHARES DEFINITION
# USE 'net' (man net).

[global]
server string = PI2
# guest ok = yes
guest ok = no
security = user
socket options = TCP_NODELAY SO_RCVBUF=65535 SO_SNDBUF=65535
registry shares = yes
syslog = 0
map to guest = bad user
workgroup = DZB
bind interfaces only = No
encrypt passwords = true
log level = 0
# smb ports = 445
unix extensions = No
wide links = yes

# Some routers requires following performance tweaks
# (see http://forum.xbian.org/thread-3851.html)
# Uncomment following 3 lines if necessary

# aio read size = 2048
# aio write size = 2048
# socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072

include = /etc/samba/user.conf
include = /etc/samba/shares.conf

shares.conf:
Terminal
[data]
path = /data
guest ok = no
read only = no
valid users = user1
browseable = yes
veto files = /._*/.DS_Store/
delete veto files = yes

[download]
path = /data/download
guest ok = no
read only = no
valid users = user1 user2
browseable = yes
veto files = /._*/.DS_Store/
delete veto files = yes
Find all posts by this user
Quote this message in a reply
10th Feb, 2018, 11:57 PM (This post was last modified: 11th Feb, 2018 12:02 AM by Nachteule.)
Post: #4
RE: Samba error: sys_path_to_bdev() failed for path [.]!
@Dzintars Bergs

Could you please check if Samba is running as daemon or started by inetd? I made some modifications in xbian-package-config-shell and maybe this does not work on your manually editied machine (you remenber your last samba issue)

Please read comments in file /etc/default/samba
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:12 AM
Post: #5
RE: Samba error: sys_path_to_bdev() failed for path [.]!
Samba was running as daemon before. Now RUN_MODE="inetd" is uncomented:
Terminal
#
# Run mode of Samba (smbd) process. If set to 'inetd', smbd is
# being spawned by inetd daemon on request, otherwise smbd is
# started as daemon via smbd upstart job. After changing this
# variable, you have to run 'sudo xbian-config services select'
# or reboot system
#
RUN_MODE=inetd

I tried to comment the line and restart, it did not help.
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:15 AM
Post: #6
RE: Samba error: sys_path_to_bdev() failed for path [.]!
Please check if Samba is running as daemon, for example by

Code:
sudo status smbd

or

Code:
pgrep smbd
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:18 AM
Post: #7
RE: Samba error: sys_path_to_bdev() failed for path [.]!
I checked xbian-config. Samba service was disabled. I enbaled autostort, commented "RUN_MODE=inetd". Now samba works and is running as daemon.

Terminal
root@pi2 ~ # status smbd
smbd start/running, process 1169
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:22 AM
Post: #8
RE: Samba error: sys_path_to_bdev() failed for path [.]!
So it's working again? Fine

Please do not comment the RUN_MODE line, it's better to write

Code:
RUN_MODE=daemon

instead, because upcoming xbian-config GUI allows you to switch between inetd and daemon mode without editing anything, and for that this line is required
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:31 AM
Post: #9
RE: Samba error: sys_path_to_bdev() failed for path [.]!
Yes, it works fine now. I changed RUN_MODE to daemon. Thanks again for help! Smile
Find all posts by this user
Quote this message in a reply
11th Feb, 2018, 12:32 AM
Post: #10
RE: Samba error: sys_path_to_bdev() failed for path [.]!
You're welcome Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: