Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: External Harddrive mounts itself read-only
4th Aug, 2014, 12:01 AM
Post: #1
External Harddrive mounts itself read-only
Hi,

Software
XBian version: XBian v1.0B2
XBMC version: default
Overclock settings: default

Hardware
Power supply rating: > 1Amp
RPi model (model A/B 256mb/512mb): B 512MB
SD card size and make/type: 32GB Class 10
Network (wireless or LAN): wireless
Connected devices (TV, USB, network storage, etc.): WiFi and USB HDD

Logile
Link to logfile(s): http://pastebin.com/rbbxcBqN

Problem description:

I have a strange Problem since a couple of weeks:
My XBian boots normaly and recognizes my external HDD without problems. But when I start to transfer files onto my external HDD, after the first 5 or 6 files I get an Error that says:
Code:
Writing failed: The filesystem is only readable
The only way to gain access again is to reboot the complete system.
Doing a "umount /media/gigastore" work, but I can't remount the HDD
When I do "mount /media/gigastore" it says
Code:
mount: can't find /media/gigastore/ in /etc/fstab or /etc/mtab
As far as I know I did not change anything besides doing updates with
apt-get update && apt-get upgrade

Any ideas?
Find all posts by this user
Quote this message in a reply
6th Aug, 2014, 02:13 AM
Post: #2
RE: External Harddrive mounts itself read-only
It is better to do all upgrades via xbian-config as this sorts out dependencies better than apt-get... However.

1) Check the permissions of the HDD - ls -al Should be rwxrwxrwx (777)
2) How are you copying the files? What command and from where?
3) Have you "ticked" the box in XBMC -> xbian-config -> XBMC -> "Shares should be World......"
4) Post the output of dmesg via http://www.pastebin.com

No need to post xbmc.log at the moment.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
18th Aug, 2014, 05:25 AM
Post: #3
RE: External Harddrive mounts itself read-only
Problem solved: I changed the USB-cable.. Undecided

Now everything works again as it used to
Find all posts by this user
Quote this message in a reply
20th Aug, 2014, 01:20 AM
Post: #4
RE: External Harddrive mounts itself read-only
Can you change the status of the thread to "Solved" Tnx

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: