Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17 “Krypton”
11th Jul, 2016, 08:05 PM
Post: #16
RE: Kodi 17 “Krypton”
Sure, have merely no inhibitions Cool
Find all posts by this user
Quote this message in a reply
9th Aug, 2016, 03:29 AM
Post: #17
RE: Kodi 17 “Krypton”
(7th Jul, 2016 08:34 PM)IriDium Wrote:  I've been playing around with this and so far it is looking good.

Only points I can flag up are:
1) Settings -> Interface -> Control -> Configure attached controllers: Is greyed out (Works on LE)

What is behind this? Last weekend I built Krypton for my openSUSE notebook and there this is greyed out also Huh
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 06:07 AM
Post: #18
RE: Kodi 17 “Krypton”
Hi,

I´ve tried to update from Devel Repo to get Krypton installed but after successful and reboot it stucks on command prompt asking for username and password. If I enter both nothing else happens (like normal SSH Session). Any Idea what could cause the problem and how to solve it?

Thanks in Advance.
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 06:58 AM
Post: #19
RE: Kodi 17 “Krypton”
@DazDavid

What exactly did you do?

Just updating package xbian-package-xbmc or did you run sudo apt-get upgrade?

What HW do you have, RPi1, 2 or 3?
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:07 AM
Post: #20
RE: Kodi 17 “Krypton”
(26th Oct, 2016 06:58 AM)Nachteule Wrote:  @DazDavid

What exactly did you do?

Just updating package xbian-package-xbmc or did you run sudo apt-get upgrade?

What HW do you have, RPi1, 2 or 3?

Im running on RPI2 and I did a Update using Xbian-Config Menu. Before Dev Update I enabled Staging Repo and run update just fine. After updating with Dev Repo enabled it stucked in the command prompt.
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:13 AM
Post: #21
RE: Kodi 17 “Krypton”
I suppose Kodi does not come up, probably due to CEC version problem. See this thead

Do you have QWERTZ keyboard? Then probably you can not login because of y in password
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:19 AM
Post: #22
RE: Kodi 17 “Krypton”
(26th Oct, 2016 07:13 AM)Nachteule Wrote:  I suppose Kodi does not come up, probably due to CEC version problem. See this thead

Do you have QWERTZ keyboard? Then probably you can not login because of y in password


The problem is not, that I cannot login. Login is possible but there is no GUI, only a command line. I´ve read the Thread you linked but there is only a problem with CEC (which indeed I use but without GUI, I dont need CEC Smile). Any order suggestions?
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:22 AM
Post: #23
RE: Kodi 17 “Krypton”
If Kodi does not come up, you'll NEVER get GUI

Please look into Kodi's log (it is in /home/xbian/.kodi/temp file kodi.log) to see what happens
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:28 AM
Post: #24
RE: Kodi 17 “Krypton”
If you can't see anything in log, please show me output of

Terminal

sudo dpkg -l | grep cec
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:28 AM
Post: #25
RE: Kodi 17 “Krypton”
(26th Oct, 2016 07:22 AM)Nachteule Wrote:  If Kodi does not come up, you'll NEVER get GUI

Please look into Kodi's log (it is in /home/xbian/.kodi/temp file kodi.log) to see what happens

With "GUI" I mean KODI of course (KODI also has a graphical user interfaces...). I just wanted to state out that I dont see anything expect a login prompt.

I already checked the log but there are no obvious errors, just INFO and DEBUG Entries. Here are the last rows:

Code:
21:01:41 142.692291 T:1766794160   DEBUG: CurlFile::Open(0x71021410) http://mirrors.kodi.tv/addons/krypton/script.module.routing/script.module.routing-0.2.0.zip
21:01:42 142.850464 T:1710224304    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/local/lib/kodi/addons: No such file or directory'
21:01:42 142.994781 T:1766794160   DEBUG: CCurlFile::Open - effective URL: <http://ftp.hosteurope.de/mirror/xbmc.org/addons/krypton/script.module.routing/script.module.routing-0.2.0.zip>
21:01:42 143.542038 T:1800348592   DEBUG: PushCecKeypress - received key a8 duration 0 (rep:0 size:0)
21:01:42 143.542313 T:1800348592   DEBUG: PushCecKeypress - added key a8
21:01:43 143.925858 T:1800348592   DEBUG: PushCecKeypress - received key a8 duration 384 (rep:0 size:1)
21:01:43 143.926193 T:1800348592   DEBUG: PushCecKeypress - replaced key a8
21:01:43 144.139877 T:1800348592   DEBUG: PushCecKeypress - received key a9 duration 0 (rep:0 size:1)
21:01:43 144.140198 T:1800348592   DEBUG: PushCecKeypress - added key a9
21:01:43 144.248657 T:1933570992   DEBUG: CurlFile::Open(0x661adca0) http://mirrors.kodi.tv/addons/krypton/resource.language.en_us/resource.language.en_us-3.0.2.zip
21:01:43 144.436935 T:1933570992   DEBUG: CCurlFile::Open - effective URL: <http://ftp.halifax.rwth-aachen.de/xbmc/addons/krypton/resource.language.en_us/resource.language.en_us-3.0.2.zip>
21:01:43 144.535645 T:1800348592   DEBUG: PushCecKeypress - received key a9 duration 396 (rep:0 size:2)
21:01:43 144.535904 T:1800348592   DEBUG: PushCecKeypress - replaced key a9
21:01:45 146.440460 T:1914696624   DEBUG: CAESinkPi:Deinitialize
21:01:45 146.441238 T:1914696624   DEBUG: CAESinkPi:SetAudioProps hdmi_stream_channels 0 hdmi_channel_map 00000000
21:01:45 146.446350 T:1914696624   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.audio_render handle 0x72301a68
21:01:47 147.851242 T:1766794160    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/local/lib/kodi/addons: No such file or directory'
21:01:47 147.872635 T:1766794160   DEBUG: CAddonDatabase: script.module.routing has been installed.
21:01:55 156.600388 T:1766794160   DEBUG: CAddonMgr: enabled script.module.routing
21:01:56 156.965057 T:1933570992    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/local/lib/kodi/addons: No such file or directory'
21:02:26 187.713150 T:1766794160    INFO: Previous line repeats 1 times.
21:02:26 187.713409 T:1766794160   DEBUG: LocalizeStrings: loaded 167 strings from file /home/xbian/.kodi/addons/script.extendedinfo/resources/language/resource.language.en_gb/strings.po

(26th Oct, 2016 07:28 AM)Nachteule Wrote:  If you can't see anything in log, please show me output of

Terminal

sudo dpkg -l | grep cec

Here the Output:

Code:
ii  cec-utils                         3.1.0.1~xbian-1462859882   armhf        libCEC communication Library (utility programs)
ii  libcec                            3.1.0.1~xbian-1462859882   armhf        Meta package libCEC.
ii  libcec-dev                        3.1.0.1~xbian-1462859882   armhf        libCEC communication Library (development files)
ii  libcec3:armhf                     3.1.0.1~xbian-1462859882   armhf        libCEC communication Library (shared library)
ii  python-libcec                     3.1.0.1~xbian-1462859882   armhf        Python bindings for libCEC
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:45 AM
Post: #26
RE: Kodi 17 “Krypton”
Hmmm, if your system time is correct, this is old log file. Seems that Kodi Krypton is never being started

What's the output of

Terminal
sudo apt-cache policy xbian-package-xbmc
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:52 AM
Post: #27
RE: Kodi 17 “Krypton”
(26th Oct, 2016 07:45 AM)Nachteule Wrote:  Hmmm, if your system time is correct, this is old log file. Seems that Kodi Krypton is never being started

What's the output of

Terminal
sudo apt-cache policy xbian-package-xbmc

This Logfile is from today. 21 o´clock was the last entry.

Here is the output of
Terminal
sudo apt-cache policy xbian-package-xbmc

Code:
xbian-package-xbmc:
  Installed: 17.0~BETA4-1477072007
  Candidate: 17.0~BETA4-1477072007
  Version table:
*** 17.0~BETA4-1477072007 0
        500 mirror://apt.xbian.org/mirror.txt/ devel/rpi2-jessie armhf Packages
        100 /var/lib/dpkg/status
     17.0~BETA4-1475772125 0
        500 mirror://apt.xbian.org/mirror.txt/ devel/rpi2-jessie armhf Packages
     17.0~BETA1-1470887655 0
        500 mirror://apt.xbian.org/mirror.txt/ devel/rpi2-jessie armhf Packages
     16.1-1464413943 0
        500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
     16.1-1463962758 0
        500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
     16.1-1463948584 0
        500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
     16.1-1461886888 0
        500 mirror://apt.xbian.org/mirror.txt/ staging/rpi2-jessie armhf Packages
     16.1~RC3-1460933065 0
        500 mirror://apt.xbian.org/mirror.txt/ staging/rpi2-jessie armhf Packages
     16.1~RC2-1459742363 0
        500 mirror://apt.xbian.org/mirror.txt/ staging/rpi2-jessie armhf Packages
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 07:55 AM
Post: #28
RE: Kodi 17 “Krypton”
So you never tried starting Kodi after 21 o´clock Huh

Btw, you can start Kodi manually by typing
Terminal
kodi start

from cmdline
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 08:10 AM
Post: #29
RE: Kodi 17 “Krypton”
(26th Oct, 2016 07:55 AM)Nachteule Wrote:  So you never tried starting Kodi after 21 o´clock Huh

Btw, you can start Kodi manually by typing
Terminal
kodi start

from cmdline

Well I tried the whole day to get it running with different ways of updating... at some point I got frustrated and played GTA...

Thanks for the hint with the command to start kodi (I was looking for something like this to find the problem). With the command KODI starts but crashes after entering XBIAN-Config (maybe was just coincidence, I just tried once).

Is that a normal behaviour in Dev Version that KODI needs to be started manually? I couldnt read something like this somewhere. Also is there a way to autostart KODI like on stable release or do I have to do that on my own?
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 08:42 AM
Post: #30
RE: Kodi 17 “Krypton”
(26th Oct, 2016 08:10 AM)DazDavid Wrote:  Is that a normal behaviour in Dev Version that KODI needs to be started manually? I couldnt read something like this somewhere. Also is there a way to autostart KODI like on stable release or do I have to do that on my own?

Of course, it is NOT Tongue This is exactly the version I'm running on my system, and never had issues with autostarting Kodi.

Will try to update my test system and see what happens tomorrow
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: