Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17 “Krypton”
26th Oct, 2016, 03:24 PM
Post: #31
RE: Kodi 17 “Krypton”
I have tried the other day and all was fine. Updated to latest and it boot fine when done. Only problem was when entering XBian config it ended in black screen. Than pressed back and started XBian config again and it loaded. Tried to update few times and it was always same behaviour with config.
Than I went back as I did not like few bits on latest Kodi

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 04:51 PM
Post: #32
RE: Kodi 17 “Krypton”
Hey Guys,

I dont know why it only happens to me but all is fine now. After I started KODi once manually it starts automatically now after Reboot. Also Xbian-Config works. Thanks yor your help.
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 06:47 PM
Post: #33
RE: Kodi 17 “Krypton”
Has anybody got amazon prime working on Krypton? I tried to install libwidevine like descripted here
and copied the libwidevinecdm.so to ~/.kodi/cdm/ but I receive following error in log when I try to play a Movie from Amazon:

Code:
10:19:27 5579.943359 T:1346368432   DEBUG: AddOnLog: InputStream MPEG DASH: Searching for decrypters in: /home/xbian/.kodi/cdm
10:19:27 5579.944336 T:1346368432   DEBUG: AddOnLog: InputStream MPEG DASH: Supported URN:
10:19:27 5579.945801 T:1346368432   DEBUG: CurlFile::Open(0x5323e370) http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BC67814A/videoquality$1080p/prod/3998/533d/aec8/4cf3-b68e-ea4ed98aeec9/155de9bc-2abb-4cc4-8e3b-5af7839ab76c_corrected.mpd
10:19:28 5580.348633 T:1954579168   DEBUG: ------ Window Init (DialogBusy.xml) ------
10:19:28 5580.349121 T:1954579168   DEBUG: Window DialogBusy.xml was already loaded
10:19:28 5580.349121 T:1954579168   DEBUG: Alloc resources: 0.01ms
10:19:29 5581.565918 T:1346368432   DEBUG: AddOnLog: InputStream MPEG DASH: Download http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BC67814A/videoquality$1080p/prod/3998/533d/aec8/4cf3-b68e-ea4ed98aeec9/155de9bc-2abb-4cc4-8e3b-5af7839ab76c_corrected.mpd finished
10:19:29 5581.566895 T:1346368432    INFO: AddOnLog: InputStream MPEG DASH: Successfully parsed .mpd file. #Streams: 4 Download speed: 0.0000 Bytes/s
10:19:29 5581.566895 T:1346368432   ERROR: AddOnLog:
10:19:29 5581.567383 T:1346368432   DEBUG: AddOnLog: InputStream MPEG DASH: GetStreamIds()
10:19:29 5581.567383 T:1346368432   ERROR: CVideoPlayer::OpenInputStream - error opening [http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BC67814A/videoquality$1080p/prod/3998/533d/aec8/4cf3-b68e-ea4ed98aeec9/155de9bc-2abb-4cc4-8e3b-5af7839ab76c_corrected.mpd]
10:19:29 5581.567871 T:1346368432  NOTICE: CVideoPlayer::OnExit()
10:19:29 5581.567871 T:1346368432   DEBUG: AddOnLog: InputStream MPEG DASH: Close()
10:19:29 5581.567871 T:1346368432    INFO: ADDON: Dll Stopped - InputStream MPEG DASH
10:19:29 5581.567871 T:1346368432   DEBUG: OnPlayBackStopped: play state was 1, starting 1

Looks like a problem with the widevine Libary but Im not really famliar with it. Does anybody has a hint how to get it working? Many Thanks
Find all posts by this user
Quote this message in a reply
26th Oct, 2016, 09:41 PM
Post: #34
RE: Kodi 17 “Krypton”
Sorry, can't help. Do not have Amazon Prime account

But this looks strange:
Quote:10:19:29 5581.566895 T:1346368432 INFO: AddOnLog: InputStream MPEG DASH: Successfully parsed .mpd file. #Streams: 4 Download speed: 0.0000 Bytes/s

I would check if this file is there and having size > 0 (downloaded it manually by wget and size is 3709242 bytes)
Find all posts by this user
Quote this message in a reply
30th Oct, 2016, 04:43 AM
Post: #35
RE: Kodi 17 “Krypton”
@DazDavid

I got amazon prime video to run (via inputstream) with the help of instructions and files from this page.

Here the instructions adjusted for Xbian: Wink
1. Inputstream.mpd for RPi 2/3 download, install and activate, see here: [Kodi 17] Inputstream AddOns for the Kodi [17] VideoPlayer, current Git builds
2. Switch to the Kodi home directory (cd /home/xbian/.kodi), if the cdm folder does not exist (ls), create itself (mkdir cdm)
3. Create symlink to libssd_wv: ln -s /home/xbian/.kodi/addons/inputstream.mpd/lib/libssd_wv.so /home/xbian/.kodi/cdm
4. Download libwidevinecdm and copy to the cdm directory:
Quote: # Download the Chromium archive
wget http://odroidxu.leeharris.me.uk/xu3/chromium-widevine-1.4.8.823-2-armv7h.pkg.tar.xz -P /tmp/chromium
# Install xz-utils to extract archive
sudo apt-get update
sudo apt-get install xz-utils
# Unpack the archive
tar xfv /tmp/chromium/chromium-widevine-1.4.8.823-2-armv7h.pkg.tar.xz -C /tmp/chromium
# Libwidevinecdm.so into the cdm folder
cp /tmp/chromium/usr/lib/chromium/libwidevinecdm.so /home/xbian/.kodi/cdm
# Customize file permissions
chmod 755 /home/xbian/.kodi/cdm/libwidevinecdm.so
# Delete Chromium folder again
rm -r /tmp/chromium
5. Install the amazon prime video addon and change the source to inpustream (settings)

ps: amazon is currently switching to a new security level, which is not supported correctly by inputstrems at the moment. If you start such a video it plays sound but no picture! The developers of the inputstream addon are working on a way to fix this!
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 07:42 AM
Post: #36
RE: Kodi 17 “Krypton”
(30th Oct, 2016 04:43 AM)Harald654 Wrote:  @DazDavid

I got amazon prime video to run (via inputstream) with the help of instructions and files from this page.

Here the instructions adjusted for Xbian: Wink
1. Inputstream.mpd for RPi 2/3 download, install and activate, see here: [Kodi 17] Inputstream AddOns for the Kodi [17] VideoPlayer, current Git builds
2. Switch to the Kodi home directory (cd /home/xbian/.kodi), if the cdm folder does not exist (ls), create itself (mkdir cdm)
3. Create symlink to libssd_wv: ln -s /home/xbian/.kodi/addons/inputstream.mpd/lib/libssd_wv.so /home/xbian/.kodi/cdm
4. Download libwidevinecdm and copy to the cdm directory:
Quote: # Download the Chromium archive
wget http://odroidxu.leeharris.me.uk/xu3/chromium-widevine-1.4.8.823-2-armv7h.pkg.tar.xz -P /tmp/chromium
# Install xz-utils to extract archive
sudo apt-get update
sudo apt-get install xz-utils
# Unpack the archive
tar xfv /tmp/chromium/chromium-widevine-1.4.8.823-2-armv7h.pkg.tar.xz -C /tmp/chromium
# Libwidevinecdm.so into the cdm folder
cp /tmp/chromium/usr/lib/chromium/libwidevinecdm.so /home/xbian/.kodi/cdm
# Customize file permissions
chmod 755 /home/xbian/.kodi/cdm/libwidevinecdm.so
# Delete Chromium folder again
rm -r /tmp/chromium
5. Install the amazon prime video addon and change the source to inpustream (settings)

ps: amazon is currently switching to a new security level, which is not supported correctly by inputstrems at the moment. If you start such a video it plays sound but no picture! The developers of the inputstream addon are working on a way to fix this!

Thanks for the Howto! Unfortunatelly Im hanging already at the first step... I downloaded the Package for RPI2/3 and I assume that with "install" is meant to install as normal Addon via Zip but everytime I try to install the Zip Archive it says "Failes to install Addon...". Logfile says "Failed to unpack archive". Is that a bug in the current Xbian Dev Version?
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 07:54 AM (This post was last modified: 3rd Dec, 2016 07:55 AM by Nachteule.)
Post: #37
RE: Kodi 17 “Krypton”
(3rd Dec, 2016 07:42 AM)DazDavid Wrote:  Thanks for the Howto! Unfortunatelly Im hanging already at the first step... I downloaded the Package for RPI2/3 and I assume that with "install" is meant to install as normal Addon via Zip but everytime I try to install the Zip Archive it says "Failes to install Addon...". Logfile says "Failed to unpack archive". Is that a bug in the current Xbian Dev Version?

You do not have to install inputstream.mpd addon, because it is already included in xbian-package-xbmc for Rpi2/3.
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 07:56 AM
Post: #38
RE: Kodi 17 “Krypton”
The problem is that Kodi cannot create a new Temp folder?!

Create - Error creating /home/xbian/.kodi/temp/675f539f-56ac-42a8-addb-cb09317266c4/lib
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 08:05 AM (This post was last modified: 3rd Dec, 2016 08:06 AM by Nachteule.)
Post: #39
RE: Kodi 17 “Krypton”
Do you have /home/xbian/.kodi/temp/ mounted to different device?

I do and I'm getting failure by installing/updating addons.
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 08:11 AM
Post: #40
RE: Kodi 17 “Krypton”
(3rd Dec, 2016 08:05 AM)Nachteule Wrote:  Do you have /home/xbian/.kodi/temp/ mounted to different device?

I do and I'm getting failure by installing/updating addons.

No is all on one microSD Card
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 08:15 AM
Post: #41
RE: Kodi 17 “Krypton”
Hmmm, please show me output of

Terminal

sudo findmnt /home/xbian/.kodi/temp/

to make sure that folder is not mouted

In my systems output looks like:

Terminal

root@kmxbilr ~ # sudo findmnt /home/xbian/.kodi/temp/
TARGET SOURCE FSTYPE OPTIONS
/home/xbian/.kodi/temp /dev/zram3 ext2 rw,nosuid,noatime,block_validity,barrier,user_xattr,acl
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 08:38 AM
Post: #42
RE: Kodi 17 “Krypton”
(3rd Dec, 2016 08:15 AM)Nachteule Wrote:  Hmmm, please show me output of

Terminal

sudo findmnt /home/xbian/.kodi/temp/

to make sure that folder is not mouted

In my systems output looks like:

Terminal

root@kmxbilr ~ # sudo findmnt /home/xbian/.kodi/temp/
TARGET SOURCE FSTYPE OPTIONS
/home/xbian/.kodi/temp /dev/zram3 ext2 rw,nosuid,noatime,block_validity,barrier,user_xattr,acl

The Output of
Code:
sudo findmnt /home/xbian/.kodi/temp/
Is empty.

Anyway i followed the instructions to install Amazon Prime Video and the Rest worked, even to install sandmans repo which is also Zip Archive?! I will check tomorrow if it is working, I just tested some Videos and all are blocked because of DRM Sad
Find all posts by this user
Quote this message in a reply
3rd Dec, 2016, 10:59 PM
Post: #43
RE: Kodi 17 “Krypton”
(3rd Dec, 2016 07:54 AM)Nachteule Wrote:  You do not have to install inputstream.mpd addon, because it is already included in xbian-package-xbmc for Rpi2/3.

right, but then you have to change the symlink on my howto (point 3) to the appropriate path. If i have understood it correctly, "libssd_wv.so" must match with the Inputstream.mpd version how is used.

Btw: inputstream.mpd and inputstream.smoothstream will be replaced by InputStream Adaptive for the future.

RPi2+Xbian(Kodi 17)
Find all posts by this user
Quote this message in a reply
4th Dec, 2016, 12:22 AM
Post: #44
RE: Kodi 17 “Krypton”
(3rd Dec, 2016 10:59 PM)Harald654 Wrote:  right, but then you have to change the symlink on my howto (point 3) to the appropriate path. If i have understood it correctly, "libssd_wv.so" must match with the Inputstream.mpd version how is used.

Btw: inputstream.mpd and inputstream.smoothstream will be replaced by InputStream Adaptive for the future.

Very interesting. And this addon has been already added to official Kodi addon repository and the older ones have been vanished 2 hours ago. Will see if it can build successfully and then I'll add it to xbmc package

Thanks for info Smile
Find all posts by this user
Quote this message in a reply
4th Dec, 2016, 12:36 AM
Post: #45
RE: Kodi 17 “Krypton”
(4th Dec, 2016 12:22 AM)Nachteule Wrote:  Will see if it can build successfully and then I'll add it to xbmc package

Thanks for info Smile

It would be great if you can update Kodi to beta 6 Smile

RPi2+Xbian(Kodi 17)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: