Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: cannot install python-pycurl and other packages
10th Jun, 2016, 02:20 AM
Post: #1
cannot install python-pycurl and other packages
Hi,
I am trying to instal PyLoad. I do not know what I am doing wrong, but I can't install several packages and repositories seem not working.
Software
XBian version: 1.0 (Knockout) Kernel 4.4.12+
XBMC/Kodi version: 16.1
Overclock settings: None

Hardware
Device type and model: RPI 2

What I done: http://pastebin.com/mkJCrZu4.

Any thoughts? Could I have damaged my package database (but update normally works)?
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 03:40 AM
Post: #2
RE: cannot install python-pycurl and other packages
You haven't explained what you are trying to do, or achieve but from the error messages, you are trying to do something that is not possible.

Nothing has been damaged, it's just saying that python-pycurl requires a different release of libcurl3-gnutls, whereas spidermonkey.bin has not been found in the normal paths (Is it available for Jessie?)

A quick look around, seems to suggest a lot more work is required to install spidermonkey on the Rpi - let alone XBian.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 04:27 AM
Post: #3
RE: cannot install python-pycurl and other packages
You have at least 2 problems:

1) The libcurl problem can be solved, look here

2) spidermonkey is not longer available at Jessie. Maybe you can solve this by using the package from Wheezy (I'm still having pyLoad installed on my Jessie based homeserver, but do not use it anymore). You can download package from here
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 05:02 AM
Post: #4
RE: cannot install python-pycurl and other packages
Ok. Thank you for reply. I have always thought that software in the repository has to be installable.

It seems to me that this process could break anytime again. Is there supported download manager with capabilites of PyLoad?
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 06:03 AM
Post: #5
RE: cannot install python-pycurl and other packages
Software in the repositories CAN be installed but each dependancy has to be reliant on many sub dependancies. As XBian is at the "Bleeding edge" there will always be issues.

However, dependancies can be overridden, but this is not advised as any number of other issues can occur, and is not recommended.

As requested before, you haven't explained what exactly you are trying to achieve.

There are supported download mangers in XBian but without knowing what PyLoad achieves over transmission, it's difficult to answer.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 06:05 AM
Post: #6
RE: cannot install python-pycurl and other packages
(10th Jun, 2016 05:02 AM)knezi Wrote:  Ok. Thank you for reply. I have always thought that software in the repository has to be installable.

Which repository do you mean?

Quote:It seems to me that this process could break anytime again. Is there supported download manager with capabilites of PyLoad?

Yeah, that is good question. pyLoad seems for me to be a zombie, I'm using JDownloader now, but installing is a little bit tricky and requires a lot of resources (java application)
Find all posts by this user
Quote this message in a reply
10th Jun, 2016, 06:32 AM
Post: #7
RE: cannot install python-pycurl and other packages
(10th Jun, 2016 06:05 AM)Nachteule Wrote:  Which repository do you mean?
No particular. i have thought that repositories are based on this.

Transmission is torrent client. What I need is download manager that can download from servers, has web interface (or at least is it possible to control it over network) and can handle captcha codes (not recognition, but ask the user to fill it). Ideally does not require a lot of resources Smile.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  [SOLVED] Basic - how to install packages - Bluetooth IRONMAN 3 4,144 24th Mar, 2015 01:30 AM
Last Post: deHakkelaar
  How to install rpi.gpio module for python? borrid 0 3,658 12th May, 2014 04:56 PM
Last Post: borrid

Forum Jump: