Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official XBian 1.0 RC 1 thread
28th Apr, 2014, 08:25 AM
Post: #166
RE: Official XBian 1.0 RC 1 thread
Where is RC2 thread?
Find all posts by this user
Quote this message in a reply
28th Apr, 2014, 08:08 PM
Post: #167
RE: Official XBian 1.0 RC 1 thread
Only the MOTD states RC2, the /etc/xbian_version still says RC1

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
30th Apr, 2014, 04:23 AM
Post: #168
Lightbulb IR Remote not working after boot
After each new boot (or re-boot), an IR remote (mceusb with the IR receiver connected via GPIO) did not work as expected. Mostly, none of the keys triggered an action in XBMC. Sometimes, the navigation keys (up, down left, right) worked, but nothing else. (Monitoring key presses via irw was always OK with all keys generating messages.)

In my case, this seemed to be related to the way XBMC is started. Obviously XBMC starts before lircd is ready and then fails to establish a connection to lircd.

I was able to fix the problem by applying this patch:

Code:
*** /etc/init/xbmc.conf.orig    2014-04-29 19:26:05.723005716 +0200
--- /etc/init/xbmc.conf    2014-04-29 19:26:55.326163747 +0200
***************
*** 13,19 ****
  env ZTEMPXBMC=0
  env DEBUG='--debug'
  
! start on started xbmc-preload and started dbus and (started autofs or xbian-nowait)
  stop on runlevel [06]
  
  # only effective during starting until full load. for niceness, set /etc/default/xbmc
--- 13,19 ----
  env ZTEMPXBMC=0
  env DEBUG='--debug'
  
! start on started xbmc-preload and started dbus and started lirc and (started autofs or xbian-nowait)
  stop on runlevel [06]
  
  # only effective during starting until full load. for niceness, set /etc/default/xbmc

Please note that this is only an initial attempt at resolving the problem. I have not checked for side effects, e.g. different configurations without lircd. And the test I have introduced may not be sufficient: Checking if lircd is actually ready to accept connections before starting XBMC would probably be a more robust option.
Find all posts by this user
Quote this message in a reply
30th Apr, 2014, 09:40 PM
Post: #169
RE: Official XBian 1.0 RC 1 thread
Here are more details about the long NFS Boot Time after last xbian update.
I was able to find out which "update module/component" raised the nfs boot time:
After updating "xbian-package-initramfs-tools" the boot duration raised from few seconds to more than one minute, so there must be some changes which adversely affected the NFS Boot.

Note: I have not fixed the translation.py problem yet but this should not affect the boot problem.

And here are some config/log files but I can't find any reason for the long boot time.
cmdline.txt: pastebin link
config.txt: pastebin link
dmesg output: pastebin link
/var/log/messages output: pastebin link
xbmc.log: pastebin link
vmstat 5 20 output: pastebin link
top output: pastebin link

Regards,
tom
Find all posts by this user
Quote this message in a reply
30th Apr, 2014, 11:05 PM
Post: #170
RE: Official XBian 1.0 RC 1 thread
How did you measure the 1 minute boot time?

Until you were able to use SSH? Until XBMC booted?

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
1st May, 2014, 02:57 AM
Post: #171
RE: Official XBian 1.0 RC 1 thread
How did I measure?
Yes, of course this is not measured on the raspberry itself.
This is only the "human" measuring sitting in Front of the TV while xbian boots until the XBMC Frontend is shown - using a clock.
But I have tested with SSH too. Until the boot is finished I can't login and the waiting time to be able to login is also increased after updating the xbian-package-initramfs-tools.
Find all posts by this user
Quote this message in a reply
1st May, 2014, 03:06 AM
Post: #172
RE: Official XBian 1.0 RC 1 thread
(28th Apr, 2014 08:25 AM)agent5150 Wrote:  Where is RC2 thread?

Just for you :-) RC 2

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
1st May, 2014, 04:22 AM
Post: #173
RE: Official XBian 1.0 RC 1 thread
(23rd Feb, 2014 10:51 PM)Lucifer Wrote:  So ... i found how to upgrade ...

1. Flash beta 2
2. boot and wait for partition resize.
3. SSH login
4. Exit xbian-config
5. $ sudo -s
6. # service xbmc stop
7. # apt-get update
8. # apt-get install xbian-package-kernel
9. # apt-get install dpkg
10. # apt-get install xbian-package-firmware
11. # reboot
12. Wait for SSH service to start
13. Repeat steps 3 to 5.
14. # dpkg --clear-avail
15. # apt-get update
16. # apt-get upgrade
17. # apt-get dist-upgrade
18. # apt-get autoremove
19. # apt-get install (the last held back package (CEC)).
20. # apt-get autoremove
21. # reboot

WARNING! If you use XBMC Backup - DO NOT RESTORE FROM IT!

Hi Lucifer,

I tried the upgrade method that you detailed in these steps. I have tried this a couple of times now, each time reflashing my SD card back to Xbian 1.0 Beta 2 from the Windows installer if it broke, but still with no success.

I found that after doing apt-get dist-upgrade in step #17, my Pi would do an automatic reboot. Every time this happens, it will come back up in the recovery boot console and at that point I have no idea what part of the upgrade has broken the boot process. But I get the usual "cannot read device /dev/mmcblk02" error.

Along the way I also had the issue where it would refuse to complete apt-get upgrade due to conflicting python2.7 libraries, but I was able to get past this with a force install "apt-get -o Dpkg::Options::="--force-all" upgrade "

Just thought I'd share my experiences and wondered if there are any updates to the instructions on how to get from Xbian 1.0 Beta 2 to the latest RC1?
Find all posts by this user
Quote this message in a reply
1st May, 2014, 02:44 PM
Post: #174
RE: Official XBian 1.0 RC 1 thread
For testing boot issues, I found that telnet starts long before ssh so you may try that to troubleshoot the problem

***please click 'thanks' if I helped!***
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Official XBian Raspberry B+ models thread IriDium 4 9,627 23rd Nov, 2014 09:14 PM
Last Post: 0xFF
  Official XBian 1.0 RC 2 Gotham (XBMC 13) thread IriDium 167 247,393 10th Sep, 2014 04:41 AM
Last Post: weezer
  Official XBian 1.0 RC 2 thread IriDium 61 82,130 16th Aug, 2014 03:10 PM
Last Post: mehlvogel
  Official XBian 1.0 Beta 2 thread IriDium 411 625,914 7th Mar, 2014 09:56 PM
Last Post: leadergr
  Official XBian 1.0 Beta 1 thread Koenkk 303 588,700 12th Dec, 2013 12:46 AM
Last Post: Exnor
  Official XBian 1.0 Alpha 5 thread Koenkk 366 765,811 15th Aug, 2013 07:35 AM
Last Post: anthonyonions
  Official XBMC 12.2 Thread Koenkk 118 229,160 4th Jul, 2013 09:11 AM
Last Post: mk01

Forum Jump: