Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official XBian 1.0 RC 2 thread
5th May, 2014, 11:09 PM
Post: #16
RE: Official XBian 1.0 RC 2 thread
(5th May, 2014 10:57 PM)Skywatch Wrote:  There's a RC2??? ;-)

Well I did apt-get upgrade and got the following message......

armhf.deb (--unpack):
trying to overwrite '/usr/lib/python2.7/lib-dynload/_hashlib.so', which is also in package python2.7 2.7.3-6
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


And that's where it halted.

Anyone have bright ideas on this?

skywatch


http://wiki.xbian.org/Updating

Last couple of lines.
Find all posts by this user
Quote this message in a reply
6th May, 2014, 01:40 AM
Post: #17
RE: Official XBian 1.0 RC 2 thread
See Python

Latest upgrade eliminates the problem - or seems to.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
6th May, 2014, 01:48 AM
Post: #18
RE: Official XBian 1.0 RC 2 thread
Thanks for the advice.

I run the commands as per the link and tried again. This time I get.....

Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/b/base-files/base-files_7.1wheezy5+rpi1_armhf.deb Something wicked happened resolving 'mirrordirector.raspbian.org:http' (-5 - No address associated with hostname)
Failed to fetch http://xbian.brantje.com/pool/stable/main/x/xbian-package-splash/xbian-package-splash_2.0.2-7_armhf.deb Something wicked happened resolving 'xbian.brantje.com:http' (-5 - No address associated with hostname)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So now where do I go?

skywatch.
Find all posts by this user
Quote this message in a reply
6th May, 2014, 01:56 AM
Post: #19
RE: Official XBian 1.0 RC 2 thread
Sounds like a network issue - can you ping either of the hosts?

Try again Bruce!!

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
6th May, 2014, 05:22 AM
Post: #20
RE: Official XBian 1.0 RC 2 thread
(5th May, 2014 10:57 PM)Skywatch Wrote:  There's a RC2??? ;-)

Well I did apt-get upgrade and got the following message......

armhf.deb (--unpack):
trying to overwrite '/usr/lib/python2.7/lib-dynload/_hashlib.so', which is also in package python2.7 2.7.3-6
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


And that's where it halted.

Anyone have bright ideas on this?

skywatch

Try installing them manually, in a single operation, e.g.:
dpkg -i /var/cache/apt/archives/*python2.7*.deb
Visit this user's website Find all posts by this user
Quote this message in a reply
6th May, 2014, 06:38 AM
Post: #21
RE: Official XBian 1.0 RC 2 thread
Thank you to all of you who tried to help me out!

I finally got 2x pi's updated to RC2 and will try them out this week....

Thanks!

Skywatch
Find all posts by this user
Quote this message in a reply
7th May, 2014, 10:01 AM
Post: #22
RE: Official XBian 1.0 RC 2 thread
Hi all
I updated xbian using xbian-config update tool all requiere packages.
All seem ok except Movies/TV Shows access from main menu. They has disappeared and "hide" option from confluence settings has been disabled (grey background).
In other hand, all menus are flowing faster than RC1.

Regards,
Alberto.
Find all posts by this user
Quote this message in a reply
7th May, 2014, 04:57 PM
Post: #23
RE: Official XBian 1.0 RC 2 thread
@Tito_leon.

You should be able to get them back by updating the movie DB.

Right click on the link to your movies/TVs and select scan for new content.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
8th May, 2014, 05:47 AM
Post: #24
RE: Official XBian 1.0 RC 2 thread
With the update to RC2 (maybe even RC1, I just pushed a number of upgrades), I lost ssh acces to my pi.

I had a custom setup (one of you guys helped me with that) with a chrooted sftp environment and the ssh server summoned not via the standard way but in some "old fashioned" manner, but I have no idea if the problem is related to this.

xbian-config wont allow to set ssh to "autostart", and when I try to start ssh from the config, the config tool just crashes.
Manually ssh'ing localhost gives "protocol family not supported".

Any ideas?
Find all posts by this user
Quote this message in a reply
8th May, 2014, 04:02 PM
Post: #25
RE: Official XBian 1.0 RC 2 thread
Hi,
after installing latest updates it works fine until doing via ssh as xuser xbian.

config > Packages > 11 repository >1 repro -> install

Installation works. After that selecting ->config > packages > something > something
happens this
Terminal
/usr/local/include/xbian-config/modules/packages/functions: line 66: 10
10*1024: syntax error in expression (error token is "10*1024")

cu
hawe
Visit this user's website Find all posts by this user
Quote this message in a reply
8th May, 2014, 10:48 PM
Post: #26
RE: Official XBian 1.0 RC 2 thread
Yep, my SSH is broken as well. Since no keyboard was plugged in, I couldn't log into the Pi at all. Connecting a keyboard after boot causes the Pi to crash sometimes. Hard-resetting the Pi shreds the filesystem. Awesome.

It's really annoying that something breaks with every single update and you have to roll back or read the forums for hours. The most annoying thing for me is that most issues require you to have physical access to the Pi to fix them (SD card issues, stuck at boot, now the SSH thing). This is nothing like administering a "normal" (headless) Linux server.

I think I'm going to try a different distribution for the Pi. YMMV.
Find all posts by this user
Quote this message in a reply
8th May, 2014, 11:58 PM
Post: #27
RE: Official XBian 1.0 RC 2 thread
Is it possible to upgrade from xbian RC2 to Xbian Gotham ?
Find all posts by this user
Quote this message in a reply
9th May, 2014, 12:37 AM
Post: #28
RE: Official XBian 1.0 RC 2 thread
@xunil
apt-get install xbian-package-xbmc-gotham-nightly

See Gotham

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
9th May, 2014, 05:28 AM
Post: #29
RE: Official XBian 1.0 RC 2 thread
I upgraded to RC2 and Gotham but now no videos will play!!!

They appear in the list with art work and icons, but clicking on them just gets a message that the file is 'no longer available'. Updating the library takes a few seconds and doesn't cure the problem.

What am I missing or overlooking here?

Skywatch
Find all posts by this user
Quote this message in a reply
9th May, 2014, 05:34 AM
Post: #30
RE: Official XBian 1.0 RC 2 thread
Sounds like your sources got messed up. Can you try adding them again?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Official XBian Raspberry B+ models thread IriDium 4 9,188 23rd Nov, 2014 09:14 PM
Last Post: 0xFF
  Official XBian 1.0 RC 2 Gotham (XBMC 13) thread IriDium 167 237,364 10th Sep, 2014 04:41 AM
Last Post: weezer
  Official XBian 1.0 RC 1 thread IriDium 173 252,703 1st May, 2014 02:44 PM
Last Post: dharmabm
  Official XBian 1.0 Beta 2 thread IriDium 411 604,994 7th Mar, 2014 09:56 PM
Last Post: leadergr
  Official XBian 1.0 Beta 1 thread Koenkk 303 571,466 12th Dec, 2013 12:46 AM
Last Post: Exnor
  Official XBian 1.0 Alpha 5 thread Koenkk 366 745,369 15th Aug, 2013 07:35 AM
Last Post: anthonyonions
  Official XBMC 12.2 Thread Koenkk 118 222,309 4th Jul, 2013 09:11 AM
Last Post: mk01

Forum Jump: