Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17 “Krypton”
30th Dec, 2016, 12:29 AM
Post: #91
RE: Kodi 17 “Krypton”
(30th Dec, 2016 12:27 AM)rikardo1979 Wrote:  
(29th Dec, 2016 11:41 PM)Nachteule Wrote:  
(29th Dec, 2016 07:08 AM)rikardo1979 Wrote:  anyone having an issue with CEC? I mean I set it to not interact with device apart from remote stuff. I mean it should not turn OFF/ON device, etc.
But it does. If I turn the TV off to stand by in few sec its come back ON to the HDMI input where RPi is connected.
Also my media keys (stop, play, pause, etc) on TV remote does not work anymore.

All was fine before I did update from 16.1 build

No, don't have this issue. But I have not representative system environment, Kodi mostly is not able to power on my TV. Maybe logs could help to see what happens. AFAIR this issue was already reported earlier here (not Krypton) with some TV models.
may try augrade to 17.1 again and see if there is anything in logs but I doubt

Ok. Please don't forget to enable additional CEC logging
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 02:46 AM
Post: #92
RE: Kodi 17 “Krypton”
(30th Dec, 2016 12:29 AM)Nachteule Wrote:  
(30th Dec, 2016 12:27 AM)rikardo1979 Wrote:  
(29th Dec, 2016 11:41 PM)Nachteule Wrote:  
(29th Dec, 2016 07:08 AM)rikardo1979 Wrote:  anyone having an issue with CEC? I mean I set it to not interact with device apart from remote stuff. I mean it should not turn OFF/ON device, etc.
But it does. If I turn the TV off to stand by in few sec its come back ON to the HDMI input where RPi is connected.
Also my media keys (stop, play, pause, etc) on TV remote does not work anymore.

All was fine before I did update from 16.1 build

No, don't have this issue. But I have not representative system environment, Kodi mostly is not able to power on my TV. Maybe logs could help to see what happens. AFAIR this issue was already reported earlier here (not Krypton) with some TV models.
may try augrade to 17.1 again and see if there is anything in logs but I doubt

Ok. Please don't forget to enable additional CEC logging
log file

Even more fun now as it stops working at all
When I upgraded to 17 it was working, even media keys but when I switched TV OFF it brings it back ON in few seconds later.
Than I rebooted and it was not working at all and I cant make it working ever since.
HuhHuhHuhUndecided
Log at top
Thanks in advance

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 03:14 AM
Post: #93
RE: Kodi 17 “Krypton”
@chochis
(29th Dec, 2016 11:46 PM)Nachteule Wrote:  
(29th Dec, 2016 05:44 PM)chochis Wrote:  The addon does not need that directory any more, by default it expects the files to be under .kodi/cdm directory.

Ah, ok. Was just a thought

Quote:Any way, I downloaded and compiled the libssd_wv.so in my computer and it is different in size, but the behaviour is the same one.
About the account: Did you get it because of me? I you did, let me pay you the first month ^^! (I don't want to disturb or annoy you).

Yes and no. It was already on my todo list testing Amazon Prime and SkyGo, but you are the reason why I'm starting with Prime now. I got account from my son for testing, so currently there are no additional costs for me Smile

So, done

Works like a charm Smile

What I did is putting libssd_wv.so (extracted from inputstream.adaptive-1.0.6.zip) and libwidevinecdm.so (got from there http://odroidxu.leeharris.me.uk/xu3/chromium-widevine-1.4.8.823-2-armv7h.pkg.tar.xz) into folder /home/xbian/.kodi/cdm:

Terminal

xbian@xbian ~/.kodi/cdm $ ls -la /home/xbian/.kodi/cdm
total 5780
drwxr-xr-x 1 root root 58 Dec 29 16:32 .
drwxr-xr-x 1 xbian xbian 72 Dec 29 16:21 ..
-rwxr-xr-x 1 xbian xbian 791216 Dec 29 16:32 libssd_wv.so
-rwxr-xr-x 1 xbian xbian 5122508 Dec 29 16:29 libwidevinecdm.so

and installed Amazon VOD 0.3.1 addon from Sandmann79 Repo

No need for compiling libssd_wv.so and installing 3rd party inputstream.adaptive addon, token that one shipped with xbian-package-xbmc (currently installed ii xbian-package-xbmc 17.0~RC1-1482772525 armhf XBMC (rpi2/krypton))
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 03:52 AM (This post was last modified: 30th Dec, 2016 03:52 AM by Nachteule.)
Post: #94
RE: Kodi 17 “Krypton”
(30th Dec, 2016 02:46 AM)rikardo1979 Wrote:  Even more fun now as it stops working at all
When I upgraded to 17 it was working, even media keys but when I switched TV OFF it brings it back ON in few seconds later.
Than I rebooted and it was not working at all and I cant make it working ever since.
HuhHuhHuhUndecided
Log at top
Thanks in advance

That's wired. The log you posted is when Kodi does not come up?

That's what I get when I turn off TV

Code:
18:37:02.586 8068.240723 T:1723855792   DEBUG: XBian-config : xbian-config reboot : ['0']
18:40:10.632 8256.286133 T:1837102000   DEBUG: CecLogMessage - >> 0f:36
18:40:10.633 8256.287109 T:1837102000   DEBUG: SetState - set standby 1, screensaver is active
18:40:10.633 8256.287109 T:1837102000   DEBUG: CecLogMessage - TV (0): power status changed from 'on' to 'standby'
18:40:10.633 8256.288086 T:1837102000   DEBUG: CecLogMessage - >> TV (0) -> Broadcast (F): standby (36)
18:42:02.906 8368.560547 T:1723855792   DEBUG: XBian-config : xbian-config reboot : ['0']

Nothing more.
I have three devices, two RPi's (1x RPi1 Kodi 16.1, 1xRPi2 Kodi 17.0rc1) and one i.MX6 (Hummingboard, Kodi 16.1) under power connected to my TV and one PC (not powered).

I could not see the standby message in your log
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 05:12 AM
Post: #95
RE: Kodi 17 “Krypton”
(30th Dec, 2016 03:52 AM)Nachteule Wrote:  
(30th Dec, 2016 02:46 AM)rikardo1979 Wrote:  Even more fun now as it stops working at all
When I upgraded to 17 it was working, even media keys but when I switched TV OFF it brings it back ON in few seconds later.
Than I rebooted and it was not working at all and I cant make it working ever since.
HuhHuhHuhUndecided
Log at top
Thanks in advance

That's wired. The log you posted is when Kodi does not come up?

That's what I get when I turn off TV

Code:
18:37:02.586 8068.240723 T:1723855792   DEBUG: XBian-config : xbian-config reboot : ['0']
18:40:10.632 8256.286133 T:1837102000   DEBUG: CecLogMessage - >> 0f:36
18:40:10.633 8256.287109 T:1837102000   DEBUG: SetState - set standby 1, screensaver is active
18:40:10.633 8256.287109 T:1837102000   DEBUG: CecLogMessage - TV (0): power status changed from 'on' to 'standby'
18:40:10.633 8256.288086 T:1837102000   DEBUG: CecLogMessage - >> TV (0) -> Broadcast (F): standby (36)
18:42:02.906 8368.560547 T:1723855792   DEBUG: XBian-config : xbian-config reboot : ['0']

Nothing more.
I have three devices, two RPi's (1x RPi1 Kodi 16.1, 1xRPi2 Kodi 17.0rc1) and one i.MX6 (Hummingboard, Kodi 16.1) under power connected to my TV and one PC (not powered).

I could not see the standby message in your log

Kodi is running but CEC does not work at all now.
Before it was a different story. It was turning TV back on every time you switch TV OFF. After few secs came back ON(TV).
And the media keys were not working.

Now after I reverted back to 16.1 and upgraded again to 17 it does not work at all.

I will try revert back to 16.1 and than upgrade to 17 again. But its a last chance I giving to it Smile I do not have a nerve for this Tongue

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 05:14 AM
Post: #96
RE: Kodi 17 “Krypton”
(30th Dec, 2016 03:14 AM)Nachteule Wrote:  and installed Amazon VOD 0.3.1 addon from Sandmann79 Repo

No need for compiling libssd_wv.so and installing 3rd party inputstream.adaptive addon, token that one shipped with xbian-package-xbmc (currently installed ii xbian-package-xbmc 17.0~RC1-1482772525 armhf XBMC (rpi2/krypton))

What did you watched?
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 05:45 AM
Post: #97
RE: Kodi 17 “Krypton”
(30th Dec, 2016 05:14 AM)chochis Wrote:  What did you watched?

A lot of Videos from DE, about 4 of 5 are working, the rest does not work due to DRM changes. But in this case, a message window pops up. Never had sound without video.
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 05:47 AM (This post was last modified: 30th Dec, 2016 05:47 AM by rikardo1979.)
Post: #98
RE: Kodi 17 “Krypton”
now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 05:57 AM (This post was last modified: 30th Dec, 2016 06:00 AM by Nachteule.)
Post: #99
RE: Kodi 17 “Krypton”
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

Maybe you have issue something like this

And again, do not see any standby message in log Huh

Sometimes it helps disconecting all hdmi cables from TV, powering off TV completely, reconnect cables and reboot RPi.
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:02 AM
Post: #100
RE: Kodi 17 “Krypton”
(30th Dec, 2016 05:57 AM)Nachteule Wrote:  
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

Maybe you have issue something like this

And again, do not see any standby message in log Huh

Sometimes it helps disconecting all hdmi cables from TV, powering off TV completely, reconnect cables and reboot RPi.

what stand by message? my RPi is not going to stand by.only TV. I turn TV OFF and RPi is always ON. I never turn it OFF or never set CEC to do so

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:03 AM
Post: #101
RE: Kodi 17 “Krypton”
Strange messages

Code:
19:41:44.303 1083.927246 T:1837102000   DEBUG: CecLogMessage - logical address changed to Broadcast (f)
19:41:44.480 1084.104858 T:1879045040   DEBUG: EGL tv_service_callback (2,1,16)
19:41:44.481 1084.105469 T:1837102000   DEBUG: CecLogMessage - GetPhysicalAddress - physical address = 4200
19:41:44.540 1084.164673 T:1837102000   DEBUG: CecLogMessage - Playback 1 (4) was already marked as active source
19:41:44.540 1084.164917 T:1837102000   DEBUG: CecLogMessage - physical address unchanged (4200)
19:41:44.540 1084.165039 T:1837102000   DEBUG: CecLogMessage - >> source activated: Playback 1 (4)
19:41:44.540 1084.165161 T:1837102000   DEBUG: CecLogMessage - scheduling active source message for 'Playback 1'
19:41:44.570 1084.194824 T:1837102000 WARNING: CecLogMessage - unhandled response received: opcode=89 initiator=4 destination=0 response=1
19:41:44.930 1084.555054 T:1837102000   DEBUG: CecLogMessage - logical Broadcast (f) address lost
19:41:44.931 1084.555298 T:1837102000   DEBUG: CecLogMessage - logical address f was taken by another device

Address changed to Broadcast, this seems to confuse CEC completely
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:05 AM
Post: #102
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:02 AM)rikardo1979 Wrote:  what stand by message? my RPi is not going to stand by.only TV. I turn TV OFF and RPi is always ON. I never turn it OFF or never set CEC to do so

See my post, that's what I get when powering off TV
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:10 AM
Post: #103
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:05 AM)Nachteule Wrote:  
(30th Dec, 2016 06:02 AM)rikardo1979 Wrote:  what stand by message? my RPi is not going to stand by.only TV. I turn TV OFF and RPi is always ON. I never turn it OFF or never set CEC to do so

See my post, that's what I get when powering off TV

maybe cos your settings? I have every single option OFF in cec settings. Even screensaver is sett OFF.

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:11 AM
Post: #104
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:03 AM)Nachteule Wrote:  Strange messages

Code:
19:41:44.303 1083.927246 T:1837102000   DEBUG: CecLogMessage - logical address changed to Broadcast (f)
19:41:44.480 1084.104858 T:1879045040   DEBUG: EGL tv_service_callback (2,1,16)
19:41:44.481 1084.105469 T:1837102000   DEBUG: CecLogMessage - GetPhysicalAddress - physical address = 4200
19:41:44.540 1084.164673 T:1837102000   DEBUG: CecLogMessage - Playback 1 (4) was already marked as active source
19:41:44.540 1084.164917 T:1837102000   DEBUG: CecLogMessage - physical address unchanged (4200)
19:41:44.540 1084.165039 T:1837102000   DEBUG: CecLogMessage - >> source activated: Playback 1 (4)
19:41:44.540 1084.165161 T:1837102000   DEBUG: CecLogMessage - scheduling active source message for 'Playback 1'
19:41:44.570 1084.194824 T:1837102000 WARNING: CecLogMessage - unhandled response received: opcode=89 initiator=4 destination=0 response=1
19:41:44.930 1084.555054 T:1837102000   DEBUG: CecLogMessage - logical Broadcast (f) address lost
19:41:44.931 1084.555298 T:1837102000   DEBUG: CecLogMessage - logical address f was taken by another device

Address changed to Broadcast, this seems to confuse CEC completely

question is why it brings TV back ON from standby? And than change it Smile Never had this issue before

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:22 AM (This post was last modified: 30th Dec, 2016 06:24 AM by Nachteule.)
Post: #105
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:11 AM)rikardo1979 Wrote:  question is why it brings TV back ON from standby? And than change it Smile Never had this issue before

I'm absolutely no CEC expert. IMO RPi does not get correct message from TV

Code:
19:41:44.932 1084.556641 T:1837102000   DEBUG: CecLogMessage - TV (0): device status changed into 'unknown'

and tries to communicate again with you TV - and this wakes TV up again

libcec has changed from 3.x to 4.0, that's the main difference between 16.x and 17.x
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: