Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17 “Krypton”
30th Dec, 2016, 06:26 AM
Post: #106
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:22 AM)Nachteule Wrote:  
(30th Dec, 2016 06:11 AM)rikardo1979 Wrote:  question is why it brings TV back ON from standby? And than change it Smile Never had this issue before

I'm absolutely no CEC expert. IMO RPi does not get correct message from TV

Code:
19:41:44.932 1084.556641 T:1837102000   DEBUG: CecLogMessage - TV (0): device status changed into 'unknown'

and tries to communicate again with you TV - and this wakes TV up again

libcec has changed from 3.x to 4.0, that's the main difference between 16.x and 17.x

I can assure you that I have not changed TV or HDMI cable between upgrades to 17 Tongue Big Grin

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:48 AM
Post: #107
RE: Kodi 17 “Krypton”
this updated libcec is pretty messed up my system Smile now even 16.1 does not work anymore.
So will do a fresh install tomorrow

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:57 AM
Post: #108
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:48 AM)rikardo1979 Wrote:  this updated libcec is pretty messed up my system Smile now even 16.1 does not work anymore.
So will do a fresh install tomorrow

Ooops, libcec3 and libcec4 can be installed at the same time and Kodi 16.1 does not take care of libcec4
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 06:43 PM
Post: #109
RE: Kodi 17 “Krypton”
so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th Dec, 2016, 11:26 PM
Post: #110
RE: Kodi 17 “Krypton”
(30th Dec, 2016 06:43 PM)rikardo1979 Wrote:  so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

I would agree, there is issue in libcec.

If you still have 17 installed, could you stop Kodi, remove or rename folder /home/xbian/.kodi and start Kodi again? If CEC is working again, then I suppose it is libcec issue I already posted.
Find all posts by this user
Quote this message in a reply
31st Dec, 2016, 01:40 AM
Post: #111
RE: Kodi 17 “Krypton”
(30th Dec, 2016 11:26 PM)Nachteule Wrote:  
(30th Dec, 2016 06:43 PM)rikardo1979 Wrote:  so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

I would agree, there is issue in libcec.

If you still have 17 installed, could you stop Kodi, remove or rename folder /home/xbian/.kodi and start Kodi again? If CEC is working again, then I suppose it is libcec issue I already posted.

sorry I dont. Reverted back to 16.1 as I need working environment. May create some test build on spare SD card. Maybe tomorrow when missus will be at work Tongue

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
3rd Jan, 2017, 12:37 AM
Post: #112
RE: Kodi 17 “Krypton”
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

I had the same problem in the past with Kodi 17. My RPi2 has turned the TV on without any reason (especially at night). So i did a fresh istall of Xbian two weeks ago (with Kodi 17) and since then the problem no longer occurred.

RPi2+Xbian(Kodi 17)
Find all posts by this user
Quote this message in a reply
3rd Jan, 2017, 02:32 AM
Post: #113
RE: Kodi 17 “Krypton”
(3rd Jan, 2017 12:37 AM)Harald654 Wrote:  
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

I had the same problem in the past with Kodi 17. My RPi2 has turned the TV on without any reason (especially at night). So i did a fresh istall of Xbian two weeks ago (with Kodi 17) and since then the problem no longer occurred.
unfortunately this is with latest builds which makes them unusable for me

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
3rd Jan, 2017, 05:06 AM
Post: #114
RE: Kodi 17 “Krypton”
(3rd Jan, 2017 12:37 AM)Harald654 Wrote:  
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

I had the same problem in the past with Kodi 17. My RPi2 has turned the TV on without any reason (especially at night). So i did a fresh istall of Xbian two weeks ago (with Kodi 17) and since then the problem no longer occurred.

Probably you had different issue: Kodi crashes sometimes, restart automatically and turns on TV during start.
Find all posts by this user
Quote this message in a reply
3rd Jan, 2017, 05:25 AM
Post: #115
RE: Kodi 17 “Krypton”
(3rd Jan, 2017 05:06 AM)Nachteule Wrote:  
(3rd Jan, 2017 12:37 AM)Harald654 Wrote:  
(30th Dec, 2016 05:47 AM)rikardo1979 Wrote:  now even better fun Smile
So CEC was working after reboot. Than I switched TV OFF to standby. TV turns back ON few secs later on input where RPi is plugged and CEC does not work at all again Smile
Log

I had the same problem in the past with Kodi 17. My RPi2 has turned the TV on without any reason (especially at night). So i did a fresh istall of Xbian two weeks ago (with Kodi 17) and since then the problem no longer occurred.

Probably you had different issue: Kodi crashes sometimes, restart automatically and turns on TV during start.

maybe maybe not. But I dont see a reason why as same behaviour on fresh install with no addons or any extras installed, no system modifications or hardware changes

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
3rd Jan, 2017, 05:32 AM
Post: #116
RE: Kodi 17 “Krypton”
Rikardo, my answer was for Harald654 Shy
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 01:59 AM (This post was last modified: 10th Jan, 2017 02:06 AM by Nachteule.)
Post: #117
RE: Kodi 17 “Krypton”
@rikardo1979
(30th Dec, 2016 06:43 PM)rikardo1979 Wrote:  so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

Sounds familiar? See this issue

Maybe this issue caused your strange CEC problem
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 02:06 AM (This post was last modified: 10th Jan, 2017 02:06 AM by rikardo1979.)
Post: #118
RE: Kodi 17 “Krypton”
(10th Jan, 2017 01:59 AM)Nachteule Wrote:  @rikardo1979
(30th Dec, 2016 06:43 PM)rikardo1979 Wrote:  so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

Sounds familiar? See this issue
looks like it Smile Do we have patch in place?If yes I may try an update tonight and test it.
Cheers

Sent from my ONE A2003 using Tapatalk

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 02:09 AM
Post: #119
RE: Kodi 17 “Krypton”
(10th Jan, 2017 02:06 AM)rikardo1979 Wrote:  
(10th Jan, 2017 01:59 AM)Nachteule Wrote:  @rikardo1979
(30th Dec, 2016 06:43 PM)rikardo1979 Wrote:  so I did a fresh install of 16.1 than update to 17 and have exact same behaviour.
CEC working fine after 1st reboot, than I turn TV OFF to standby and RPi brings it back ON in few seconds and CEC does not work anymore.

So there is definitely a bug somewhere in latest build/libcec ?

Sounds familiar? See this issue
looks like it Smile Do we have patch in place?If yes I may try an update tonight and test it.
Cheers

Sent from my ONE A2003 using Tapatalk

Not yet, but ...

just building new firmware package, so you can test it tonight
Find all posts by this user
Quote this message in a reply
14th Jan, 2017, 02:45 PM
Post: #120
RE: Kodi 17 “Krypton”
RC3 is out (kodi is complaining. Never seen this before).
Should we expect and update to it soon?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: