Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official XBian 1.0 Alpha 5 thread
14th Aug, 2013, 10:46 PM
Post: #361
RE: Official XBian 1.0 Alpha 5 thread
ah maybe that is the problem then. I installed Alpha5 so in my notes I ran the update, so maybe I'll just go with the base install as I don't really want to go the beta versions personally.

Thanks
Ant
Find all posts by this user
Quote this message in a reply
14th Aug, 2013, 11:17 PM
Post: #362
RE: Official XBian 1.0 Alpha 5 thread
I would still appreciate the original output you got from apt - why the dependencies chain ended up on config-shell (dialog).

It is probably due to package-cec which is replacing xbian-update below beta 1 what is triggering the problem.

But otherwise the newer xbmc should run even on alpha (so if you have 20 minutes, clone files with git for packxage-xbmc, package-cec and simply write it over to your alpha5).

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
14th Aug, 2013, 11:22 PM
Post: #363
RE: Official XBian 1.0 Alpha 5 thread
I will give it another go later on and post the entire output - thats no problem.

You lost me a bit with the rest of it though. Sorry...
Find all posts by this user
Quote this message in a reply
14th Aug, 2013, 11:23 PM
Post: #364
RE: Official XBian 1.0 Alpha 5 thread
just got one idea with alternative dependencies. I could prepare special deb for you to test. If it installs and if it runs.

And if yes, then even alpha5 could be running xbmc updates again.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
15th Aug, 2013, 05:18 AM
Post: #365
RE: Official XBian 1.0 Alpha 5 thread
just run it again, this is the output:

xbian@xbian ~ $ sudo apt-get install xbian-package-xbmc -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
pmount xbian-package-kernel3.6.11
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
anacron btrfs-tools busybox dialog gettext gettext-base initramfs-tools kbd
klibc-utils libafpclient0 libasprintf0c2 libbluetooth3 libc-bin libc-dev-bin
libc6 libc6-dev libcroco3 libgettextpo0 libgmp10 libgomp1 libjson0 libklibc
libmad0 libnih-dbus1 libnih1 libsqlite0 libunistring0 makedev mountall
plymouth python-sqlite triggerhappy udhcpc upstart xbian-package-cec
xbian-package-config-shell xbian-package-config-xbmc
xbian-package-initramfs-tools xbian-package-kernel
xbian-package-libshairport xbian-package-libtag xbian-package-splash
xbian-package-usbmount xbian-package-zram-swap xbian-update
Suggested packages:
default-mta mail-transport-agent gettext-doc glibc-doc desktop-base
plymouth-drm python-sqlite-dbg graphviz xbian-package-kernel-headers
Recommended packages:
autopoint console-setup console-data gcc c-compiler
The following packages will be REMOVED:
console-tools sysvinit usbmount
The following NEW packages will be installed:
anacron btrfs-tools busybox dialog gettext gettext-base initramfs-tools kbd
klibc-utils libafpclient0 libasprintf0c2 libbluetooth3 libcroco3
libgettextpo0 libgmp10 libgomp1 libjson0 libklibc libmad0 libnih-dbus1
libnih1 libsqlite0 libunistring0 makedev mountall plymouth python-sqlite
triggerhappy udhcpc upstart xbian-package-cec xbian-package-initramfs-tools
xbian-package-kernel xbian-package-libshairport xbian-package-libtag
xbian-package-splash xbian-package-usbmount xbian-package-zram-swap
The following packages will be upgraded:
libc-bin libc-dev-bin libc6 libc6-dev xbian-package-config-shell
xbian-package-config-xbmc xbian-package-xbmc xbian-update
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
sysvinit
8 upgraded, 38 newly installed, 3 to remove and 1 not upgraded.
Need to get 0 B/74.0 MB of archives.
After this operation, 74.3 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes

So running with the recommended --force-yes flag:

xbian@xbian ~ $ sudo apt-get install xbian-package-xbmc --force-yes
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
pmount xbian-package-kernel3.6.11
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
anacron btrfs-tools busybox dialog gettext gettext-base initramfs-tools kbd
klibc-utils libafpclient0 libasprintf0c2 libbluetooth3 libc-bin libc-dev-bin
libc6 libc6-dev libcroco3 libgettextpo0 libgmp10 libgomp1 libjson0 libklibc
libmad0 libnih-dbus1 libnih1 libsqlite0 libunistring0 makedev mountall
plymouth python-sqlite triggerhappy udhcpc upstart xbian-package-cec
xbian-package-config-shell xbian-package-config-xbmc
xbian-package-initramfs-tools xbian-package-kernel xbian-package-libshairport
xbian-package-libtag xbian-package-splash xbian-package-usbmount
xbian-package-zram-swap xbian-update
Suggested packages:
default-mta mail-transport-agent gettext-doc glibc-doc desktop-base
plymouth-drm python-sqlite-dbg graphviz xbian-package-kernel-headers
Recommended packages:
autopoint console-setup console-data gcc c-compiler
The following packages will be REMOVED:
console-tools sysvinit usbmount
The following NEW packages will be installed:
anacron btrfs-tools busybox dialog gettext gettext-base initramfs-tools kbd
klibc-utils libafpclient0 libasprintf0c2 libbluetooth3 libcroco3
libgettextpo0 libgmp10 libgomp1 libjson0 libklibc libmad0 libnih-dbus1
libnih1 libsqlite0 libunistring0 makedev mountall plymouth python-sqlite
triggerhappy udhcpc upstart xbian-package-cec xbian-package-initramfs-tools
xbian-package-kernel xbian-package-libshairport xbian-package-libtag
xbian-package-splash xbian-package-usbmount xbian-package-zram-swap
The following packages will be upgraded:
libc-bin libc-dev-bin libc6 libc6-dev xbian-package-config-shell
xbian-package-config-xbmc xbian-package-xbmc xbian-update
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
sysvinit
8 upgraded, 38 newly installed, 3 to remove and 1 not upgraded.
Need to get 0 B/74.0 MB of archives.
After this operation, 74.3 MB of additional disk space will be used.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
?] Yes, do as I say!
E: This installation run will require temporarily removing the essential package xbian-package-config-shell:armhf due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
E: Reverse conflicts early remove for package 'dialog:armhf' failed
Find all posts by this user
Quote this message in a reply
15th Aug, 2013, 06:39 AM
Post: #366
RE: Official XBian 1.0 Alpha 5 thread
can you try installing xbian-package-xbmc, xbian-package-cec, xbian-package-libtag, xbian-package-libshairport from updated deb I just created?

you will find them at http://ivka57.dyndns-ip.com/pool/main/x/ … download to xbian with wget for instance and try to install like this:
Code:
wget http://ivka57.dyndns-ip.com/pool/main/x/xbian-package-xbmc/xbian-package-xbmc_2.3-1.4_armhf.deb
wget http://ivka57.dyndns-ip.com/pool/main/x/xbian-package-libtag/xbian-package-libtag_1.0-1_armhf.deb
wget http://ivka57.dyndns-ip.com/pool/main/x/xbian-package-libshairport/xbian-package-libshairport_1.0-1_armhf.deb
wget http://ivka57.dyndns-ip.com/pool/main/x/xbian-package-cec/xbian-package-cec_1.1-0.3_armhf.deb

sudo dpkg -i --simulate *.deb

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
15th Aug, 2013, 07:35 AM
Post: #367
RE: Official XBian 1.0 Alpha 5 thread
Thanks for sorting those mk01 - I have put a Beta1.1 image on just now - problems there too which I'll put in the relevant thread. Not sure which way to go at the moment. It was all going fine till a couple days ago and had nothing but problems since.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Official XBian Raspberry B+ models thread IriDium 4 9,798 23rd Nov, 2014 09:14 PM
Last Post: 0xFF
  Official XBian 1.0 RC 2 Gotham (XBMC 13) thread IriDium 167 253,370 10th Sep, 2014 04:41 AM
Last Post: weezer
  Official XBian 1.0 RC 2 thread IriDium 61 83,898 16th Aug, 2014 03:10 PM
Last Post: mehlvogel
  Official XBian 1.0 RC 1 thread IriDium 173 267,274 1st May, 2014 02:44 PM
Last Post: dharmabm
  Official XBian 1.0 Beta 2 thread IriDium 411 638,263 7th Mar, 2014 09:56 PM
Last Post: leadergr
  Official XBian 1.0 Beta 1 thread Koenkk 303 599,008 12th Dec, 2013 12:46 AM
Last Post: Exnor
  Official XBMC 12.2 Thread Koenkk 118 233,054 4th Jul, 2013 09:11 AM
Last Post: mk01

Forum Jump: