Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official CuBox-i XBian 1.0 RC3 Thread
1st Jan, 2015, 01:59 AM (This post was last modified: 1st Jan, 2015 02:20 AM by mk01.)
Post: #16
RE: Official CuBox-i XBian 1.0 RC3 Thread
@didlich

dvd drives have no mapping to sd* but sr* or cdrom. recheck.

@ramonskie

honestly, report result of 1 month old system is at least - not possible to recheck, reuse, make anything usefull out of it.
Only thing I can do is generate a new image when you don't want to upgrade.

Normally I would go to ask details to try to fix later, but honesty, what you are saying is that the cubox is unusable - I would throw it into trash as if a platform does that what you describe, it is weeks months of fixing or messed HW in in-reparable state. without any side intentions - what you say is quite inconsistent we other reports and quite much. That kind of state was the hw & sw let me think, mabe Feb, March?

Isn't possible you have short circuit somewhere ? sounds very similar. Otherwise, send ANY kernel log / xbmc, it must be something reported all over the place/time.
will provide the img in few minutes as build finishes.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
1st Jan, 2015, 03:18 AM
Post: #17
RE: Official CuBox-i XBian 1.0 RC3 Thread
Is there no pci support on xbian kernel??

lspci yields no results

there is a /proc/pci/devices output but I cannot setup a broadcom BCM94322HM8L wich has been plug n play on previous debian based systems
Find all posts by this user
Quote this message in a reply
1st Jan, 2015, 05:44 AM
Post: #18
RE: Official CuBox-i XBian 1.0 RC3 Thread
@ramonskie

http://download.serveftp.net/xbian-image-imx6-20141231.img.xz

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
4th Jan, 2015, 02:07 AM
Post: #19
RE: Official CuBox-i XBian 1.0 RC3 Thread
** Well done to all involved **

I've been using RC3 for a couple of weeks now and haven't come across any problems (bar the excessive hdmi debug messages in dmesg (posted elsewhere - possible RC2 thread))

So congrats to all involved, you never get the credit you deserve.

(Sods law will dictate I find an error 3 minutes after posting this Big Grin )

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
6th Jan, 2015, 07:27 PM
Post: #20
RE: Official CuBox-i XBian 1.0 RC3 Thread
@mk01

yes thats right, there is no mapping whether to sd* nor to sr* as you can see in the log files

Code:
ls /dev/sd*
/dev/sda  /dev/sda2

Code:
ls /dev/sr*
ls: cannot access /dev/sr*: No such file or directory
Find all posts by this user
Quote this message in a reply
8th Jan, 2015, 05:05 AM
Post: #21
RE: Official CuBox-i XBian 1.0 RC3 Thread
(1st Jan, 2015 05:44 AM)mk01 Wrote:  @ramonskie

http://download.serveftp.net/xbian-image-imx6-20141231.img.xz

Is this xbmc or kodi?
Find all posts by this user
Quote this message in a reply
13th Jan, 2015, 11:29 AM
Post: #22
RE: Official CuBox-i XBian 1.0 RC3 Thread
in image is XBMC
kodi is available with
Code:
apt-get install xbian-package-xbmc-nightly-6q

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
13th Jan, 2015, 11:31 AM
Post: #23
RE: Official CuBox-i XBian 1.0 RC3 Thread
(6th Jan, 2015 07:27 PM)didlich Wrote:  @mk01

yes thats right, there is no mapping whether to sd* nor to sr* as you can see in the log files

Code:
ls /dev/sd*
/dev/sda  /dev/sda2

Code:
ls /dev/sr*
ls: cannot access /dev/sr*: No such file or directory

@didlich
ok, will check that - I should have USB DVDRW drive somewhere.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
13th Jan, 2015, 11:46 AM (This post was last modified: 13th Jan, 2015 12:37 PM by mk01.)
Post: #24
RE: Official CuBox-i XBian 1.0 RC3 Thread
(1st Jan, 2015 03:18 AM)zarboz Wrote:  Is there no pci support on xbian kernel??

lspci yields no results

there is a /proc/pci/devices output but I cannot setup a broadcom BCM94322HM8L wich has been plug n play on previous debian based systems

if the support is covered via B43 driver, then this wasn't included. changed .config. linux-image-3.14.28-armmp will be at DEVEL to test (after it recompiles).

(pushed now)

@didlich
test your cdrom issue with that kernel too please.

(easiest way is to uncomment DEVEL in /etc/apt/sources.list.d/xbian.list, run
Code:
apt-get update
apt-get install linux-image-3.14.28-armmp

possibility is also:
Code:
cd /tmp
wget http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp3.0.0-1421115902.deb
dpkg --force-all -r linux-image-3.14.27-armmp
dpkg -i linux-image-3.14.28-armmp3.0.0-1421115902.deb

if anyone has DVI monitor, please give me feedback if all ok with video output (modes). this kernel contains experimental 3D mode support and DVI wasn't tested after all the changes (of course no 3D on DVI but the changes can have effect on DVI). thanks.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
14th Jan, 2015, 07:37 AM
Post: #25
RE: Official CuBox-i XBian 1.0 RC3 Thread
@mk01, thanks for your effort

the link you posted didn't work, I used this one:

http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp_3.0.0-1421115902_armhf.deb

now, the output of dmesg looks much better:
Code:
[   64.451499] usb 1-1.3: new high-speed USB device number 5 using ci_hdrc
[   64.527575] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[   64.527797] usb-storage 1-1.3:1.0: Quirks match for vid 14cd pid 6600: 20
[   64.527855] scsi2 : usb-storage 1-1.3:1.0
[   65.530551] scsi 2:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GSA-H55N 1.00 PQ: 0 ANSI: 0
[   65.614513] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[   65.614525] cdrom: Uniform CD-ROM driver Revision: 3.20
[   65.615094] sr 2:0:0:0: Attached scsi CD-ROM sr0
[   65.615447] sr 2:0:0:0: Attached scsi generic sg1 type 5

to play DVDs from XBMC I had to add the user to cdrom group:
Code:
sudo usermod -a -G cdrom xbian

after the restart of XBMC "DISC" menu appeared

very nice, thanks Shy

when the linux-image-3.14.28-armmp dev will find its way to stable???
Find all posts by this user
Quote this message in a reply
14th Jan, 2015, 07:42 AM
Post: #26
RE: Official CuBox-i XBian 1.0 RC3 Thread
(13th Jan, 2015 11:46 AM)mk01 Wrote:  
(1st Jan, 2015 03:18 AM)zarboz Wrote:  Is there no pci support on xbian kernel??

lspci yields no results

there is a /proc/pci/devices output but I cannot setup a broadcom BCM94322HM8L wich has been plug n play on previous debian based systems

if the support is covered via B43 driver, then this wasn't included. changed .config. linux-image-3.14.28-armmp will be at DEVEL to test (after it recompiles).

(pushed now)

@didlich
test your cdrom issue with that kernel too please.

(easiest way is to uncomment DEVEL in /etc/apt/sources.list.d/xbian.list, run
Code:
apt-get update
apt-get install linux-image-3.14.28-armmp

possibility is also:
Code:
cd /tmp
wget http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp3.0.0-1421115902.deb
dpkg --force-all -r linux-image-3.14.27-armmp
dpkg -i linux-image-3.14.28-armmp3.0.0-1421115902.deb

if anyone has DVI monitor, please give me feedback if all ok with video output (modes). this kernel contains experimental 3D mode support and DVI wasn't tested after all the changes (of course no 3D on DVI but the changes can have effect on DVI). thanks.


Code:
cd /tmp
wget http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp3.0.0-1421115902.deb
dpkg --force-all -r linux-image-3.14.27-armmp
dpkg -i linux-image-3.14.28-armmp3.0.0-1421115902.deb

System stuck at
kernel log saying Loading.

i cloned into the repo and am attempting to follow the wiki directions but end up stuck at these steps everytime and nothing is working

Code:
sudo $xbiangit --arch imx6
Wrong setup. Open folder containing xbianonpi/xbian clone and rerun "./run.me prepare"
zarboz@Cerebro ~/xbian/xbian-build-img $ cd ..
zarboz@Cerebro ~/xbian $ sudo ./run.me prepare
Writing loader file /etc/profile.d/xbiangit.sh
Installing
Installing done...
Successfully initialised. Please logout and login again.
then logged out and logged in
Code:
zarboz@Cerebro ~/xbian/xbian-build-img $ sudo $xbiangit --arch imx6
/bin/bash: /build.img: No such file or directory


With latest kerrnel update I no longer have /proc/pci/devices showing
and lspci still yields me no results Sad
Find all posts by this user
Quote this message in a reply
19th Jan, 2015, 04:53 AM (This post was last modified: 19th Jan, 2015 04:54 AM by mk01.)
Post: #27
RE: Official CuBox-i XBian 1.0 RC3 Thread
@zarboz

building .img is only one process needing root rights (due to working with loop module & virtual storage devices) and I think the sudo is problem in that case. the actual "xbiangit" builder configs are loaded on session startup from /etc/profile.d/xbiangit.sh and with regular sudo call sudo is just providing UID/GID, it doesn't run standard login process. it should be possible if -i parameter is used to sudo...

Code:
sudo -i
$xbiangit -m imx6

to the kernel stuck problem - you use DVI or HDMI ?

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
19th Jan, 2015, 04:57 AM
Post: #28
RE: Official CuBox-i XBian 1.0 RC3 Thread
(14th Jan, 2015 07:37 AM)didlich Wrote:  @mk01, thanks for your effort

the link you posted didn't work, I used this one:

http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp_3.0.0-1421115902_armhf.deb

now, the output of dmesg looks much better:
Code:
[   64.451499] usb 1-1.3: new high-speed USB device number 5 using ci_hdrc
[   64.527575] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[   64.527797] usb-storage 1-1.3:1.0: Quirks match for vid 14cd pid 6600: 20
[   64.527855] scsi2 : usb-storage 1-1.3:1.0
[   65.530551] scsi 2:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GSA-H55N 1.00 PQ: 0 ANSI: 0
[   65.614513] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[   65.614525] cdrom: Uniform CD-ROM driver Revision: 3.20
[   65.615094] sr 2:0:0:0: Attached scsi CD-ROM sr0
[   65.615447] sr 2:0:0:0: Attached scsi generic sg1 type 5

to play DVDs from XBMC I had to add the user to cdrom group:
Code:
sudo usermod -a -G cdrom xbian

after the restart of XBMC "DISC" menu appeared

very nice, thanks Shy

when the linux-image-3.14.28-armmp dev will find its way to stable???

IMX6 as whole is still still using STAGING but it is allowed by default for this platform (so you should have it allowed) and actually I already pushed it from DEVEL there.
By any chance don't you have 3D compatible TV to check if Kernel/XBMC is getting all the info correctly ?

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
19th Jan, 2015, 05:27 AM
Post: #29
RE: Official CuBox-i XBian 1.0 RC3 Thread
(19th Jan, 2015 04:57 AM)mk01 Wrote:  
(14th Jan, 2015 07:37 AM)didlich Wrote:  @mk01, thanks for your effort

the link you posted didn't work, I used this one:

http://xbian.serveftp.net/pool/devel/imx6-jessie/l/linux-image-3.14.28-armmp/linux-image-3.14.28-armmp_3.0.0-1421115902_armhf.deb

now, the output of dmesg looks much better:
Code:
[   64.451499] usb 1-1.3: new high-speed USB device number 5 using ci_hdrc
[   64.527575] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[   64.527797] usb-storage 1-1.3:1.0: Quirks match for vid 14cd pid 6600: 20
[   64.527855] scsi2 : usb-storage 1-1.3:1.0
[   65.530551] scsi 2:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GSA-H55N 1.00 PQ: 0 ANSI: 0
[   65.614513] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[   65.614525] cdrom: Uniform CD-ROM driver Revision: 3.20
[   65.615094] sr 2:0:0:0: Attached scsi CD-ROM sr0
[   65.615447] sr 2:0:0:0: Attached scsi generic sg1 type 5

to play DVDs from XBMC I had to add the user to cdrom group:
Code:
sudo usermod -a -G cdrom xbian

after the restart of XBMC "DISC" menu appeared

very nice, thanks Shy

when the linux-image-3.14.28-armmp dev will find its way to stable???

IMX6 as whole is still still using STAGING but it is allowed by default for this platform (so you should have it allowed) and actually I already pushed it from DEVEL there.
By any chance don't you have 3D compatible TV to check if Kernel/XBMC is getting all the info correctly ?

@mk01, thanks for the response, I'm sorry no 3D compatible TV
Find all posts by this user
Quote this message in a reply
19th Jan, 2015, 06:10 AM
Post: #30
RE: Official CuBox-i XBian 1.0 RC3 Thread
(19th Jan, 2015 04:53 AM)mk01 Wrote:  @zarboz

building .img is only one process needing root rights (due to working with loop module & virtual storage devices) and I think the sudo is problem in that case. the actual "xbiangit" builder configs are loaded on session startup from /etc/profile.d/xbiangit.sh and with regular sudo call sudo is just providing UID/GID, it doesn't run standard login process. it should be possible if -i parameter is used to sudo...

Code:
sudo -i
$xbiangit -m imx6

to the kernel stuck problem - you use DVI or HDMI ?

Build seems fine now


as for the error:
I was plugged via HDMI

I have since reformatted and installed your updated kernel successfully but still do not get PCI results although the image is much more stable (still has some tearing on 1080p mkvs) on my Sony Television havent got a chance to try on my other television.

I was hoping to build from source so that I can try to patch up the kernel to have pci support for the device and test wifi. I will keep at it until I figure something out. Quitting is never an option
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Official CuBox-i XBian 1.0 Beta 2 thread IriDium 184 239,579 20th Nov, 2015 10:43 PM
Last Post: evianway123

Forum Jump: