Full Version: [Part 2] Download torrent & newsserver package(s)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
After a big amount of positive reactions on our idea to offer an all-in-one newsserver and torrent package - the topic on our forum got around 16.000 views - we also received a lot of complains about the unstableness of the whole. That's why i called the help of our great community and made a second version.

There have been some big changes:
- All packages offered by the download package are also separately installable.
* xbian-package-transmission
* xbian-package-nzbget
* xbian-package-sickbeard
* xbian-package-couchpotato
* xbian-package-headphones
- All packages are configured (or patched*) so they seemingly work together
- All packages are configured (or patched**) so they support the same username and password combination.
- Instead of using the official debian version of transmission i recompiled it so it uses less resources.
- All packages originally found on git, have been linked to the XBian repository. So no risk of damaging our packages because all updates are first approved by our package maintainers.

For all of you who already used the previous version of the package are advices to completely remove it and backup your settings. Due to the big changes in version 2, it doesn't run well with left-overs of version 1. The ideal solution is to install the package on a clean Alpha 5 installation.

To install/upgrade the all-in-one package:
sudo apt-get install xbian-package-download

The addresses are still the same.
The default login: xbian, pass: raspberry

If you want to download everything to an external hard-drive/usb stick:
mv /home/xbian/downloads /media/usb/
mv /home/xbian/incomplete /media/usb/
mv /home/xbian/torrents /media/usb/
ln -s /media/usb/downloads /home/xbian/downloads
ln -s /media/usb/incomplete /home/xbian/incomplete
ln -s /media/usb/torrents /home/xbian/torrents

* Headphones didn't have nzbget support
** NZBget didn't have a custom username ability. Sickbeard and Couchpotato also had a static username built in for NZBget.
I installed a clean xbian alpha 5 with Transmission+NZBGET+SickBeard, and NZBGET gave an error because could not find unrar.
Is this expected?
Whould I install unrar with:

sudo sh -c "echo \"deb-src wheezy main contrib non-free rpi\" >> /etc/apt/sources.list"
sudo apt-get update
sudo apt-get -y build-dep unrar-nonfree
sudo apt-get source -b unrar-nonfree
sudo dpkg -i unrar*.deb
NZBget normally uses par
(23rd Feb, 2013 04:00 AM)CurlyMo Wrote: [ -> ]NZBget normally uses par

Hi! And first of all, thanks for what looks a great package.

Regarding this particular problem, I might be wrong but I thought NZBGet used PAR for "repair" of damaged file purpose but that UnRar was still needed for uncompression.
Isn't it working this way ?
Don't know, but if you do please consider:
(23rd Feb, 2013 04:22 AM)CurlyMo Wrote: [ -> ]Don't know, but if you do please consider:

I'm sorry, I'm not at all a linux expert (totally the opposite actually), but I've tried to install the package and tried NZBGet.

Here are my results:
- downloads work great (speed up to 1100KB/s)
- PAR check completed just fine
- UNRAR gave me error : Here's the error message "Post-Process: Unrar not found. Set the path to unrar in script's configuration"

I've checked the configuration file (nzbget-postprocess.conf) and found this string:
# Set the full path to unrar if it is not in your PATH.

so I would say that the unrar package is indeed needed. Thing is (as a linux noob), I don't know how to install it.... I've tried sudo apt-get install unrar with no luck (package 'unrar' has no installation candidate)

Any idea ?
Thanks in advance
Instructions on installing unrar are in the second post. But can you first try:
sudo apt-get install unrar-free
(23rd Feb, 2013 06:00 AM)CurlyMo Wrote: [ -> ]Instructions on installing unrar are in the second post. But can you first try:
sudo apt-get install unrar-free

Sorry about that last question, I've realized the answer was present just after posting...
I finally went with the above method for unrar installation and I can CONFIRM that NZBGet finally works PERFECTLY !!!!

(Can't tell if it would works with sudo apt-get install unrar-free)

Thank you very much for your help !
I really want you to try unrar-free, so i can make it work perfect by default.
(23rd Feb, 2013 06:40 AM)CurlyMo Wrote: [ -> ]I really want you to try unrar-free, so i can make it work perfect by default.

Should I uninstall unrar-nonfree to avoid conflict, and how can I do it ?
Maybe backup the image and reinstall everything to test.
(23rd Feb, 2013 07:12 AM)CurlyMo Wrote: [ -> ]Maybe backup the image and reinstall everything to test.

Oh... OK, so I won't be able to do that right now. I have 2 littles kids waiting for me at the time. Will try to find time to reinstall everything from scratch tomorow and will keep you posted.

Sorry about that
unrar-free doesn't support the current version of rar-archives RAR3, so unrar-nonfree should be the better choice.
However, we can't include unrar-nonfree due to license issues.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
Reference URL's